aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-12-02 09:46:26 +0800
committermarcus <marcus@FreeBSD.org>2002-12-02 09:46:26 +0800
commit5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c (patch)
tree8fff65858897566cf55bf4561bdb9c042ad6ea29
parent01c354cd736678bf2a1b4dd6f4935a15200d0eca (diff)
downloadfreebsd-ports-gnome-5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c.tar.gz
freebsd-ports-gnome-5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c.tar.zst
freebsd-ports-gnome-5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c.zip
Fix package building.
Reported by: bento
-rw-r--r--emulators/grustibus/Makefile4
-rw-r--r--news/glitter/Makefile8
-rw-r--r--x11-fm/vide/Makefile5
3 files changed, 8 insertions, 9 deletions
diff --git a/emulators/grustibus/Makefile b/emulators/grustibus/Makefile
index 99c01a78f59b..ad4baf9708dd 100644
--- a/emulators/grustibus/Makefile
+++ b/emulators/grustibus/Makefile
@@ -14,10 +14,10 @@ MASTER_SITE_SUBDIR= grustibus
MAINTAINER= verm@drunkmonk.net
RUN_DEPENDS= xmame:${PORTSDIR}/emulators/xmame
-LIB_DEPENDS= gnomecanvaspixbuf.1:${PORTSDIR}/graphics/gnomecanvas
USE_GNOMENG= yes
WANT_GNOME= yes
+USE_GNOME= gnomeprefix gnomecanvas
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=`${GNOME_CONFIG} --sysconfdir`
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+= --sysconfdir=`${GNOME_CONFIG} --sysconfdir`
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mgnomelibs}!=""
-USE_GNOME= gnomelibs libcapplet
+USE_GNOME+= gnomelibs libcapplet
.endif
.include <bsd.port.post.mk>
diff --git a/news/glitter/Makefile b/news/glitter/Makefile
index 6e3de6fe921d..a2a205eb3f3a 100644
--- a/news/glitter/Makefile
+++ b/news/glitter/Makefile
@@ -17,16 +17,14 @@ MAINTAINER= greg@gregnet.net
USE_X_PREFIX= yes
USE_GNOMENG= yes
-USE_GNOME= gnomelibs gtk12
+USE_GNOME= gnomeprefix gnomehack gnomelibs gtk12
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/x11-fm/vide/Makefile b/x11-fm/vide/Makefile
index 9e1504d689a7..95968d9379c8 100644
--- a/x11-fm/vide/Makefile
+++ b/x11-fm/vide/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= vim:${PORTSDIR}/editors/vim5
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMENG= yes
-USE_GNOME= gnomelibs
+USE_GNOME= gnomeprefix gnomelibs
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-DHAVE_SYS_PARAM_H"
@@ -26,6 +27,6 @@ PLIST_SUB= VERSION=${PORTVERSION}
PATCH_WRKSRC= ${WRKSRC}/src
post-patch:
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/src/*.c
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/src/*.c
.include <bsd.port.mk>