aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-07-12 09:57:57 +0800
committerlinimon <linimon@FreeBSD.org>2019-07-12 09:57:57 +0800
commit5bc6b3e98f335fdce678acd8b4dd14348f58428d (patch)
tree8ec4f270012859c295f1f26a9f1f67e45039dbda
parent2f445a72bb4f8af73648960272d1cb8a21e9e90d (diff)
downloadfreebsd-ports-gnome-5bc6b3e98f335fdce678acd8b4dd14348f58428d.tar.gz
freebsd-ports-gnome-5bc6b3e98f335fdce678acd8b4dd14348f58428d.tar.zst
freebsd-ports-gnome-5bc6b3e98f335fdce678acd8b4dd14348f58428d.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for libstdc++.so
as a stand-in for "are we running on gcc". These 4 cases are outliers because they set compiler:nestedfct which currently hardwires gcc. So the real test for including -fnested-functions into CFLAGS is "are we on the ancient base gcc". Approved by: portmgr (tier-2 blanket)
-rw-r--r--deskutils/growl-for-linux/Makefile6
-rw-r--r--devel/tigcc/Makefile2
-rw-r--r--multimedia/kissdx/Makefile6
-rw-r--r--net-mgmt/chillispot/Makefile6
4 files changed, 13 insertions, 7 deletions
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 4b44c20bb0c0..0637e72acaeb 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -41,7 +41,9 @@ USE_GNOME= cairo gdkpixbuf2 gtk20 libxml2
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}/display \
${PREFIX}/lib/${PORTNAME}/subscribe
-.if exists(/usr/lib/libstdc++.so)
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
CFLAGS+= -fnested-functions
.endif
@@ -52,4 +54,4 @@ post-patch:
post-install:
${RM} ${STAGEDIR}${PREFIX}/lib/libgolplug.a
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/tigcc/Makefile b/devel/tigcc/Makefile
index 4a99049353f8..da50dcb52068 100644
--- a/devel/tigcc/Makefile
+++ b/devel/tigcc/Makefile
@@ -144,7 +144,7 @@ do-install-EXAMPLES-on:
.include <bsd.port.pre.mk>
-.if exists(/usr/lib/libstdc++.so)
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
CFLAGS+= -fnested-functions
.endif
diff --git a/multimedia/kissdx/Makefile b/multimedia/kissdx/Makefile
index 7c8e5ca51833..03ece6a45469 100644
--- a/multimedia/kissdx/Makefile
+++ b/multimedia/kissdx/Makefile
@@ -43,7 +43,9 @@ post-patch:
s|^\.o :|${PORTNAME}: $$(OBJS)| ; \
/^all:/s| $$(OBJS)||' ${WRKSRC}/Makefile
-.if exists(/usr/lib/libstdc++.so)
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
CFLAGS+= -fnested-functions
.endif
@@ -60,4 +62,4 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/chillispot/Makefile b/net-mgmt/chillispot/Makefile
index 1b2c8c18aa9e..0f2366a194c4 100644
--- a/net-mgmt/chillispot/Makefile
+++ b/net-mgmt/chillispot/Makefile
@@ -32,7 +32,9 @@ APACHE_USE= apache_run=22+
FREERADIUS_RUN_DEPENDS= radiusd:net/freeradius
OPENRADIUS_RUN_DEPENDS= radiusd:net/openradius
-.if exists(/usr/lib/libstdc++.so)
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
CFLAGS+= -fnested-functions
.endif
@@ -46,4 +48,4 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/pf.conf.sample ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${FILESDIR}/ipfw-config.sample ${STAGEDIR}${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>