aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-05-24 04:51:27 +0800
committerdinoex <dinoex@FreeBSD.org>2010-05-24 04:51:27 +0800
commit5dd76f2fccd6f98568fdec08566c786a114ddf37 (patch)
treeb517ced326dcf66b1e3c13f5b6aaf41add629d91
parent211a882e5b7eb8f967d8e1ecec4d37339f9a71d0 (diff)
downloadfreebsd-ports-gnome-5dd76f2fccd6f98568fdec08566c786a114ddf37.tar.gz
freebsd-ports-gnome-5dd76f2fccd6f98568fdec08566c786a114ddf37.tar.zst
freebsd-ports-gnome-5dd76f2fccd6f98568fdec08566c786a114ddf37.zip
- fix build for gnustep-base 1.21.0
-rw-r--r--audio/cynthiune/files/patch-EsoundPreference.m10
-rw-r--r--biology/adun/Makefile5
-rw-r--r--deskutils/helpviewer/Makefile8
-rw-r--r--deskutils/plopfolio/Makefile8
-rw-r--r--deskutils/preferences.app/files/patch-Keyboard.m10
-rw-r--r--devel/performance/files/patch-GSTicker.m10
-rw-r--r--devel/projectmanager/files/patch-ApplicationTypeAttributes.m10
-rw-r--r--devel/projectmanager/files/patch-GNUstepAppLauncher.m19
-rw-r--r--devel/projectmanager/files/patch-MakeBuilder.m22
-rw-r--r--devel/projectmanager/files/patch-Preferences.m10
-rw-r--r--devel/projectmanager/files/patch-ProjectCreator.m7
-rw-r--r--devel/projectmanager/files/patch-ProjectDocument.m11
-rw-r--r--devel/projectmanager/files/patch-ProjectImageView.m10
-rw-r--r--devel/projectmanager/files/patch-ProjectWindowController.m21
-rw-r--r--devel/projectmanager/files/patch-SubprojectsManager.m10
-rw-r--r--editors/textedit.app/files/patch-ScalingScrollView.m12
-rw-r--r--games/gmastermind/files/patch-Controller.h10
-rw-r--r--games/gnustep-ladder/files/patch-Clock.h22
-rw-r--r--games/gnustep-ladder/files/patch-Clock.m20
-rw-r--r--graphics/gnustep-slideshow/files/patch-PreferencesController.m12
-rw-r--r--graphics/svgviewer/files/patch-Document.m9
-rw-r--r--news/lusernet/files/patch-NNTPSource.m10
-rw-r--r--news/lusernet/files/patch-Pref_Posting.m10
-rw-r--r--x11-toolkits/renaissance/files/patch-GSHBox.m10
-rw-r--r--x11-toolkits/renaissance/files/patch-GSMarkupCoder.m11
-rw-r--r--x11-toolkits/renaissance/files/patch-GSMarkupWindowController.m10
-rw-r--r--x11-toolkits/renaissance/files/patch-GSVBox.m10
-rw-r--r--x11/terminal.app/files/patch-ServicesPrefs.m14
-rw-r--r--x11/terminal.app/files/patch-TerminalParser_LinuxPrefs.m11
-rw-r--r--x11/terminal.app/files/patch-TerminalView.m10
-rw-r--r--x11/terminal.app/files/patch-TerminalViewPrefs.m11
31 files changed, 346 insertions, 17 deletions
diff --git a/audio/cynthiune/files/patch-EsoundPreference.m b/audio/cynthiune/files/patch-EsoundPreference.m
new file mode 100644
index 000000000000..17f4bc3ab98d
--- /dev/null
+++ b/audio/cynthiune/files/patch-EsoundPreference.m
@@ -0,0 +1,10 @@
+--- Bundles/Esound/EsoundPreference.m.orig 2006-03-18 05:18:51.000000000 +0100
++++ Bundles/Esound/EsoundPreference.m 2010-05-23 06:40:35.000000000 +0200
+@@ -26,6 +26,7 @@
+ #import <AppKit/NSTextField.h>
+ #import <AppKit/NSWindow.h>
+ #import <Foundation/NSBundle.h>
++#import <Foundation/NSDictionary.h>
+ #import <Foundation/NSNotification.h>
+ #import <Foundation/NSUserDefaults.h>
+
diff --git a/biology/adun/Makefile b/biology/adun/Makefile
index 2428d9aad2d4..97a1e7ce6f16 100644
--- a/biology/adun/Makefile
+++ b/biology/adun/Makefile
@@ -37,8 +37,9 @@ PLIST_SUB+= LIBVERSION5=${DEFAULT_LIBVERSION5}
PLIST_SUB+= MAJORLIBVERSION5=${DEFAULT_LIBVERSION5:C/([0-9]).*/\1/1}
ADDITIONAL_CPPFLAGS= -D__FREEBSD__
ADDITIONAL_INCLUDE_DIRS= -I${WRKSRC}/Kernel -I${WRKSRC}
-ADDITIONAL_LIB_DIRS= -L${WRKSRC}/Kernel/AdunKernel/AdunKernel.framework -L${LOCALBASE}/MolTalk/MolTalk.framework
-ADDITIONAL_LDFLAGS= -rpath-link=${WRKSRC}/Kernel/AdunKernel/AdunKernel.framework:${LOCALBASE}/MolTalk/MolTalk.framework
+ADDITIONAL_LIB_DIRS= -L${WRKSRC}/Kernel/AdunKernel/AdunKernel.framework -L${WRKSRC}/MolTalk/MolTalk.framework -L${WRKSRC}/Kernel/Base/obj
+ADDITIONAL_LDFLAGS= -rpath-link=${WRKSRC}/Kernel/AdunKernel/AdunKernel.framework:${WRKSRC}/MolTalk/MolTalk.framework:${WRKSRC}/Kernel/Base/obj
+
MAKE_ENV+= GSL_LIB_DIR=${LOCALBASE}/lib
MAKE_ENV+= GSL_INCLUDE_DIR=${LOCALBASE}/include
diff --git a/deskutils/helpviewer/Makefile b/deskutils/helpviewer/Makefile
index 32eb4532a8f7..cb121e731566 100644
--- a/deskutils/helpviewer/Makefile
+++ b/deskutils/helpviewer/Makefile
@@ -22,4 +22,12 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
+FIXME= HandlerStructureXLP.h TextFormatterXLP.h
+
+post-patch:
+.for i in ${FIXME}
+ ${REINPLACE_CMD} -e 's|Foundation/GSXML.h|GNUstepBase/GSXML.h|' \
+ ${WRKSRC}/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/deskutils/plopfolio/Makefile b/deskutils/plopfolio/Makefile
index cde32fd9642b..9897eb41f076 100644
--- a/deskutils/plopfolio/Makefile
+++ b/deskutils/plopfolio/Makefile
@@ -21,4 +21,12 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
+FIXME= Channel.m PlopFolio.m PreferencesPanelController.m
+
+post-patch:
+.for i in ${FIXME}
+ ${REINPLACE_CMD} -e 's|Foundation/GSXML.h|GNUstepBase/GSXML.h|' \
+ ${WRKSRC}/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/deskutils/preferences.app/files/patch-Keyboard.m b/deskutils/preferences.app/files/patch-Keyboard.m
new file mode 100644
index 000000000000..bdf962baf8c3
--- /dev/null
+++ b/deskutils/preferences.app/files/patch-Keyboard.m
@@ -0,0 +1,10 @@
+--- Modules/Keyboard/Keyboard.m.orig 2002-06-08 10:29:36.000000000 +0200
++++ Modules/Keyboard/Keyboard.m 2010-05-22 11:24:43.000000000 +0200
+@@ -37,6 +37,7 @@
+ #import <AppKit/NSButton.h>
+ #import <AppKit/NSNibLoading.h>
+ #import <AppKit/NSOpenPanel.h>
++#import <Foundation/NSUserDefaults.h>
+
+ #import "Keyboard.h"
+ #import "KeyboardView.h"
diff --git a/devel/performance/files/patch-GSTicker.m b/devel/performance/files/patch-GSTicker.m
new file mode 100644
index 000000000000..b25e76d23ef8
--- /dev/null
+++ b/devel/performance/files/patch-GSTicker.m
@@ -0,0 +1,10 @@
+--- GSTicker.m.orig 2007-09-14 14:54:56.000000000 +0200
++++ GSTicker.m 2010-05-23 07:17:13.000000000 +0200
+@@ -27,6 +27,7 @@
+
+ #include <Foundation/NSArray.h>
+ #include <Foundation/NSDate.h>
++#include <Foundation/NSDictionary.h>
+ #include <Foundation/NSThread.h>
+ #include <Foundation/NSTimer.h>
+
diff --git a/devel/projectmanager/files/patch-ApplicationTypeAttributes.m b/devel/projectmanager/files/patch-ApplicationTypeAttributes.m
new file mode 100644
index 000000000000..cd651f682714
--- /dev/null
+++ b/devel/projectmanager/files/patch-ApplicationTypeAttributes.m
@@ -0,0 +1,10 @@
+--- ProjectTypes/Application/ApplicationTypeAttributes.m.orig 2006-07-09 16:11:43.000000000 +0200
++++ ProjectTypes/Application/ApplicationTypeAttributes.m 2010-05-23 06:11:38.000000000 +0200
+@@ -24,6 +24,7 @@
+ #import "ApplicationTypeAttributes.h"
+
+ #import <Foundation/NSString.h>
++#import <Foundation/NSDictionary.h>
+
+ #import <AppKit/NSNibLoading.h>
+ #import <AppKit/NSTextField.h>
diff --git a/devel/projectmanager/files/patch-GNUstepAppLauncher.m b/devel/projectmanager/files/patch-GNUstepAppLauncher.m
new file mode 100644
index 000000000000..281203ca3c3d
--- /dev/null
+++ b/devel/projectmanager/files/patch-GNUstepAppLauncher.m
@@ -0,0 +1,19 @@
+--- ProjectModules/GNUstepAppLauncher/GNUstepAppLauncher.m.orig 2006-07-09 16:11:41.000000000 +0200
++++ ProjectModules/GNUstepAppLauncher/GNUstepAppLauncher.m 2010-05-23 05:53:40.000000000 +0200
+@@ -30,6 +30,7 @@
+ #import <Foundation/NSProcessInfo.h>
+ #import <Foundation/NSString.h>
+ #import <Foundation/NSTask.h>
++#import <Foundation/NSValue.h>
+
+ #import <AppKit/NSColor.h>
+ #import <AppKit/NSFont.h>
+@@ -44,7 +45,7 @@
+ #import <AppKit/NSTableView.h>
+ #import <AppKit/NSTextStorage.h>
+ #import <AppKit/NSTextView.h>
+-#import <AppKit/NSWindow+Toolbar.h>
++#import <AppKit/NSWindow.h>
+ #import <AppKit/NSToolbar.h>
+ #import <AppKit/NSToolbarItem.h>
+
diff --git a/devel/projectmanager/files/patch-MakeBuilder.m b/devel/projectmanager/files/patch-MakeBuilder.m
index 5466a7acaabc..c7451421637b 100644
--- a/devel/projectmanager/files/patch-MakeBuilder.m
+++ b/devel/projectmanager/files/patch-MakeBuilder.m
@@ -1,10 +1,28 @@
--- ProjectModules/MakeBuilder/MakeBuilder.m.orig 2006-07-09 16:11:41.000000000 +0200
-+++ ProjectModules/MakeBuilder/MakeBuilder.m 2008-05-03 08:58:15.000000000 +0200
-@@ -30,6 +30,7 @@
++++ ProjectModules/MakeBuilder/MakeBuilder.m 2010-05-23 06:03:12.000000000 +0200
+@@ -23,13 +23,16 @@
+ #import "MakeBuilder.h"
+
+ #import <Foundation/NSArray.h>
++#import <Foundation/NSCharacterSet.h>
+ #import <Foundation/NSException.h>
+ #import <Foundation/NSFileHandle.h>
+ #import <Foundation/NSNotification.h>
+ #import <Foundation/NSString.h>
#import <Foundation/NSTask.h>
#import <Foundation/NSUserDefaults.h>
++#import <Foundation/NSValue.h>
+#import <AppKit/NSAttributedString.h>
#import <AppKit/NSButton.h>
#import <AppKit/NSCell.h>
#import <AppKit/NSDocumentController.h>
+@@ -46,7 +49,7 @@
+ #import <AppKit/NSToolbar.h>
+ #import <AppKit/NSToolbarItem.h>
+ #import <AppKit/NSView.h>
+-#import <AppKit/NSWindow+Toolbar.h>
++#import <AppKit/NSWindow.h>
+
+ #import "MakeBuilderDelegate.h"
+ #import "../../ProjectDocument.h"
diff --git a/devel/projectmanager/files/patch-Preferences.m b/devel/projectmanager/files/patch-Preferences.m
new file mode 100644
index 000000000000..0437444f75a0
--- /dev/null
+++ b/devel/projectmanager/files/patch-Preferences.m
@@ -0,0 +1,10 @@
+--- Preferences.m.orig 2006-07-09 16:11:44.000000000 +0200
++++ Preferences.m 2010-05-23 05:27:20.000000000 +0200
+@@ -26,6 +26,7 @@
+ #import <Foundation/NSString.h>
+ #import <Foundation/NSArray.h>
+ #import <Foundation/NSDictionary.h>
++#import <Foundation/NSDebug.h>
+
+ #import <AppKit/NSNibLoading.h>
+ #import <AppKit/NSBox.h>
diff --git a/devel/projectmanager/files/patch-ProjectCreator.m b/devel/projectmanager/files/patch-ProjectCreator.m
index 9460b068ec3c..35e83e4efdd2 100644
--- a/devel/projectmanager/files/patch-ProjectCreator.m
+++ b/devel/projectmanager/files/patch-ProjectCreator.m
@@ -1,10 +1,11 @@
---- ProjectCreator.m.orig Sun Jul 9 16:11:43 2006
-+++ ProjectCreator.m Mon Apr 30 10:53:41 2007
-@@ -27,6 +27,7 @@
+--- ProjectCreator.m.orig 2006-07-09 16:11:43.000000000 +0200
++++ ProjectCreator.m 2010-05-23 06:01:30.000000000 +0200
+@@ -27,6 +27,8 @@
#import <Foundation/NSUserDefaults.h>
#import <Foundation/NSNotification.h>
#import <Foundation/NSError.h>
+#import <Foundation/NSProcessInfo.h>
++#import <Foundation/NSPathUtilities.h>
#import <AppKit/NSOpenPanel.h>
#import <AppKit/NSView.h>
diff --git a/devel/projectmanager/files/patch-ProjectDocument.m b/devel/projectmanager/files/patch-ProjectDocument.m
index 298df00a6d56..19ebb99d43e7 100644
--- a/devel/projectmanager/files/patch-ProjectDocument.m
+++ b/devel/projectmanager/files/patch-ProjectDocument.m
@@ -1,7 +1,12 @@
---- ProjectDocument.m.orig Sun Jul 9 16:11:43 2006
-+++ ProjectDocument.m Mon Apr 30 10:54:26 2007
-@@ -28,6 +28,7 @@
+--- ProjectDocument.m.orig 2006-07-09 16:11:43.000000000 +0200
++++ ProjectDocument.m 2010-05-23 06:04:25.000000000 +0200
+@@ -25,9 +25,12 @@
+
+ #import <Foundation/NSString.h>
+ #import <Foundation/NSArray.h>
++#import <Foundation/NSCharacterSet.h>
#import <Foundation/NSDictionary.h>
++#import <Foundation/NSDistributedNotificationCenter.h>
#import <Foundation/NSUserDefaults.h>
#import <Foundation/NSProcessInfo.h>
+#import <Foundation/NSError.h>
diff --git a/devel/projectmanager/files/patch-ProjectImageView.m b/devel/projectmanager/files/patch-ProjectImageView.m
new file mode 100644
index 000000000000..d2e2a78b2de1
--- /dev/null
+++ b/devel/projectmanager/files/patch-ProjectImageView.m
@@ -0,0 +1,10 @@
+--- ProjectModules/FileManager/ProjectImageView.m.orig 2006-07-09 16:11:41.000000000 +0200
++++ ProjectModules/FileManager/ProjectImageView.m 2010-05-23 06:06:35.000000000 +0200
+@@ -24,6 +24,7 @@
+ #import "ProjectImageView.h"
+
+ #import <Foundation/NSArray.h>
++#import <Foundation/NSDictionary.h>
+
+ #import <AppKit/NSEvent.h>
+ #import <AppKit/NSPasteboard.h>
diff --git a/devel/projectmanager/files/patch-ProjectWindowController.m b/devel/projectmanager/files/patch-ProjectWindowController.m
new file mode 100644
index 000000000000..b938d055569a
--- /dev/null
+++ b/devel/projectmanager/files/patch-ProjectWindowController.m
@@ -0,0 +1,21 @@
+--- ProjectWindowController.m.orig 2006-07-09 16:11:43.000000000 +0200
++++ ProjectWindowController.m 2010-05-23 05:56:35.000000000 +0200
+@@ -25,7 +25,6 @@
+
+ #import <AppKit/NSImage.h>
+ #import <AppKit/NSWindow.h>
+-#import <AppKit/NSWindow+Toolbar.h>
+ #import <AppKit/NSToolbar.h>
+ #import <AppKit/NSToolbarItem.h>
+ #import <AppKit/NSBox.h>
+@@ -35,8 +34,10 @@
+ #import <AppKit/NSTextStorage.h>
+
+ #import <Foundation/NSBundle.h>
++#import <Foundation/NSCalendarDate.h>
+ #import <Foundation/NSException.h>
+ #import <Foundation/NSNotification.h>
++#import <Foundation/NSUserDefaults.h>
+
+ #import "ProjectDocument.h"
+ #import "ProjectModule.h"
diff --git a/devel/projectmanager/files/patch-SubprojectsManager.m b/devel/projectmanager/files/patch-SubprojectsManager.m
new file mode 100644
index 000000000000..a3b536797ee1
--- /dev/null
+++ b/devel/projectmanager/files/patch-SubprojectsManager.m
@@ -0,0 +1,10 @@
+--- ProjectModules/SubprojectsManager/SubprojectsManager.m.orig 2006-07-09 16:11:42.000000000 +0200
++++ ProjectModules/SubprojectsManager/SubprojectsManager.m 2010-05-23 06:13:54.000000000 +0200
+@@ -26,6 +26,7 @@
+ #import <Foundation/NSArray.h>
+ #import <Foundation/NSDictionary.h>
+ #import <Foundation/NSError.h>
++#import <Foundation/NSException.h>
+ #import <Foundation/NSFileManager.h>
+ #import <Foundation/NSNotification.h>
+ #import <Foundation/NSSortDescriptor.h>
diff --git a/editors/textedit.app/files/patch-ScalingScrollView.m b/editors/textedit.app/files/patch-ScalingScrollView.m
new file mode 100644
index 000000000000..8c68c59e4573
--- /dev/null
+++ b/editors/textedit.app/files/patch-ScalingScrollView.m
@@ -0,0 +1,12 @@
+--- ScalingScrollView.m.orig 2003-10-28 20:28:47.000000000 +0100
++++ ScalingScrollView.m 2010-05-22 12:31:35.000000000 +0200
+@@ -11,7 +11,9 @@
+
+ #import "ScalingScrollView.h"
+
++#import <Foundation/NSBundle.h>
+ #import <Foundation/NSGeometry.h>
++#import <Foundation/NSValue.h>
+ #import <AppKit/NSPopUpButton.h>
+ #import <AppKit/NSScroller.h>
+ #import <AppKit/NSButtonCell.h>
diff --git a/games/gmastermind/files/patch-Controller.h b/games/gmastermind/files/patch-Controller.h
new file mode 100644
index 000000000000..1899dabbc468
--- /dev/null
+++ b/games/gmastermind/files/patch-Controller.h
@@ -0,0 +1,10 @@
+--- Controller.h.orig 2005-02-08 12:21:42.000000000 +0100
++++ Controller.h 2010-05-23 07:14:06.000000000 +0200
+@@ -37,6 +37,7 @@
+ #include <AppKit/NSFont.h>
+ #include <AppKit/NSWindow.h>
+ #include <AppKit/NSMenu.h>
++#include <AppKit/NSPanel.h>
+
+ typedef enum {
+ MENU_NEW_WITH_REP = 500,
diff --git a/games/gnustep-ladder/files/patch-Clock.h b/games/gnustep-ladder/files/patch-Clock.h
new file mode 100644
index 000000000000..15cd617c68da
--- /dev/null
+++ b/games/gnustep-ladder/files/patch-Clock.h
@@ -0,0 +1,22 @@
+--- Clock.h.orig 2005-09-16 00:49:12.000000000 +0200
++++ Clock.h 2010-05-23 07:03:45.000000000 +0200
+@@ -24,7 +24,7 @@
+
+ NSFont *font;
+
+- NSDate *_date;
++ NSCalendarDate *_date;
+
+ NSTimeZone *_timeZone;
+ NSTimeInterval _tzv;
+@@ -47,8 +47,8 @@
+
+ - (void) setTimeZone:(NSTimeZone *)tz;
+ - (NSTimeZone *) timeZone;
+-- (void) setDate:(NSDate *)date;
+-- (NSDate *) date;
++- (void) setDate:(NSCalendarDate *)date;
++- (NSCalendarDate *) date;
+
+ /* move a clock to CSClockView and put these theming method into subclass */
+
diff --git a/games/gnustep-ladder/files/patch-Clock.m b/games/gnustep-ladder/files/patch-Clock.m
new file mode 100644
index 000000000000..f3072847cf15
--- /dev/null
+++ b/games/gnustep-ladder/files/patch-Clock.m
@@ -0,0 +1,20 @@
+--- Clock.m.orig 2005-09-16 00:49:12.000000000 +0200
++++ Clock.m 2010-05-23 07:03:08.000000000 +0200
+@@ -834,7 +834,7 @@
+ return _timeZone;
+ }
+
+-- (void) setDate:(NSDate *)date
++- (void) setDate:(NSCalendarDate *)date
+ {
+ ASSIGN(_date, date);
+ handsTime = [date timeIntervalSinceReferenceDate] + _tzv;
+@@ -842,7 +842,7 @@
+ [self setNeedsDisplay: YES];
+ }
+
+-- (NSDate *) date
++- (NSCalendarDate *) date
+ {
+ return _date;
+ }
diff --git a/graphics/gnustep-slideshow/files/patch-PreferencesController.m b/graphics/gnustep-slideshow/files/patch-PreferencesController.m
new file mode 100644
index 000000000000..cec49d8a43f7
--- /dev/null
+++ b/graphics/gnustep-slideshow/files/patch-PreferencesController.m
@@ -0,0 +1,12 @@
+--- PreferencesController.m.orig 2004-12-17 10:10:22.000000000 +0100
++++ PreferencesController.m 2010-05-23 05:22:03.000000000 +0200
+@@ -32,7 +32,9 @@
+
+ #include "InputView.h"
+
++#include <Foundation/NSArchiver.h>
+ #include <Foundation/NSNotification.h>
++#include <Foundation/NSUserDefaults.h>
+
+ #include <AppKit/NSBrowser.h>
+ #include <AppKit/NSBrowserCell.h>
diff --git a/graphics/svgviewer/files/patch-Document.m b/graphics/svgviewer/files/patch-Document.m
index 1bb00218bd03..c4f62727f8fb 100644
--- a/graphics/svgviewer/files/patch-Document.m
+++ b/graphics/svgviewer/files/patch-Document.m
@@ -1,7 +1,12 @@
--- Document.m.orig 2005-05-23 21:30:29.000000000 +0200
-+++ Document.m 2008-05-03 09:33:21.000000000 +0200
-@@ -10,6 +10,7 @@
++++ Document.m 2010-05-23 08:46:40.000000000 +0200
+@@ -7,9 +7,12 @@
+ #include <math.h>
+ #include <time.h>
+
++#include <Foundation/NSCharacterSet.h>
#include <Foundation/NSFileManager.h>
++#include <Foundation/NSValue.h>
#include <AppKit/NSBezierPath.h>
#include <AppKit/NSFontManager.h>
+#include <AppKit/NSGraphics.h>
diff --git a/news/lusernet/files/patch-NNTPSource.m b/news/lusernet/files/patch-NNTPSource.m
new file mode 100644
index 000000000000..a1f03ed773a2
--- /dev/null
+++ b/news/lusernet/files/patch-NNTPSource.m
@@ -0,0 +1,10 @@
+--- NNTPSource.m.orig 2004-03-03 00:58:37.000000000 +0100
++++ NNTPSource.m 2010-05-23 08:56:18.000000000 +0200
+@@ -11,6 +11,7 @@
+ #include <Foundation/NSException.h>
+
+ #include <Foundation/NSBundle.h>
++#include <Foundation/NSDictionary.h>
+
+ #include "MsgDB.h"
+
diff --git a/news/lusernet/files/patch-Pref_Posting.m b/news/lusernet/files/patch-Pref_Posting.m
new file mode 100644
index 000000000000..402452a2acd3
--- /dev/null
+++ b/news/lusernet/files/patch-Pref_Posting.m
@@ -0,0 +1,10 @@
+--- Pref_Posting.m.orig 2004-03-03 00:58:37.000000000 +0100
++++ Pref_Posting.m 2010-05-23 08:54:51.000000000 +0200
+@@ -5,6 +5,7 @@
+ #include <Foundation/NSObject.h>
+ #include <Foundation/NSString.h>
+ #include <Foundation/NSUserDefaults.h>
++#include <Foundation/NSBundle.h>
+ #include <GNUstepGUI/GSVbox.h>
+ #include <GNUstepGUI/GSHbox.h>
+ #include <AppKit/NSButton.h>
diff --git a/x11-toolkits/renaissance/files/patch-GSHBox.m b/x11-toolkits/renaissance/files/patch-GSHBox.m
new file mode 100644
index 000000000000..7c8be449fcfb
--- /dev/null
+++ b/x11-toolkits/renaissance/files/patch-GSHBox.m
@@ -0,0 +1,10 @@
+--- Source/AutoLayout/GSHBox.m.orig 2003-02-05 03:38:14.000000000 +0100
++++ Source/AutoLayout/GSHBox.m 2010-05-23 06:45:21.000000000 +0200
+@@ -33,6 +33,7 @@
+ # include <Foundation/NSNotification.h>
+ # include <AppKit/NSBezierPath.h>
+ # include <AppKit/NSColor.h>
++# include <AppKit/NSGraphics.h>
+ #endif
+
+ #include "GSHBox.h"
diff --git a/x11-toolkits/renaissance/files/patch-GSMarkupCoder.m b/x11-toolkits/renaissance/files/patch-GSMarkupCoder.m
index 22b507e6f59a..633bb39e418a 100644
--- a/x11-toolkits/renaissance/files/patch-GSMarkupCoder.m
+++ b/x11-toolkits/renaissance/files/patch-GSMarkupCoder.m
@@ -1,10 +1,11 @@
--- Source/Markup/GSMarkupCoder.m.orig 2003-07-15 11:40:54.000000000 +0200
-+++ Source/Markup/GSMarkupCoder.m 2008-05-02 18:18:37.000000000 +0200
-@@ -31,6 +31,7 @@
- # include <Foundation/Foundation.h>
- # include "GNUstep.h"
++++ Source/Markup/GSMarkupCoder.m 2010-05-23 06:50:41.000000000 +0200
+@@ -33,6 +33,8 @@
#else
-+# include <Foundation/NSString.h>
# include <Foundation/NSArray.h>
# include <Foundation/NSData.h>
++# include <Foundation/NSString.h>
++# include <Foundation/NSDictionary.h>
#endif
+
+ /*
diff --git a/x11-toolkits/renaissance/files/patch-GSMarkupWindowController.m b/x11-toolkits/renaissance/files/patch-GSMarkupWindowController.m
new file mode 100644
index 000000000000..aaef62166b11
--- /dev/null
+++ b/x11-toolkits/renaissance/files/patch-GSMarkupWindowController.m
@@ -0,0 +1,10 @@
+--- Source/TagLibrary/GSMarkupWindowController.m.orig 2003-01-26 05:41:50.000000000 +0100
++++ Source/TagLibrary/GSMarkupWindowController.m 2010-05-23 06:49:03.000000000 +0200
+@@ -31,6 +31,7 @@
+ #ifdef GNUSTEP
+ # include <Foundation/NSArray.h>
+ # include <Foundation/NSBundle.h>
++# include <Foundation/NSDictionary.h>
+ # include <Foundation/NSString.h>
+ #else
+ # include <Foundation/Foundation.h>
diff --git a/x11-toolkits/renaissance/files/patch-GSVBox.m b/x11-toolkits/renaissance/files/patch-GSVBox.m
new file mode 100644
index 000000000000..cee05bf88572
--- /dev/null
+++ b/x11-toolkits/renaissance/files/patch-GSVBox.m
@@ -0,0 +1,10 @@
+--- Source/AutoLayout/GSVBox.m.orig 2003-02-05 03:38:14.000000000 +0100
++++ Source/AutoLayout/GSVBox.m 2010-05-23 06:45:31.000000000 +0200
+@@ -33,6 +33,7 @@
+ # include <Foundation/NSNotification.h>
+ # include <AppKit/NSBezierPath.h>
+ # include <AppKit/NSColor.h>
++# include <AppKit/NSGraphics.h>
+ #endif
+
+ #include "GSVBox.h"
diff --git a/x11/terminal.app/files/patch-ServicesPrefs.m b/x11/terminal.app/files/patch-ServicesPrefs.m
new file mode 100644
index 000000000000..baba8509395e
--- /dev/null
+++ b/x11/terminal.app/files/patch-ServicesPrefs.m
@@ -0,0 +1,14 @@
+--- ServicesPrefs.m.orig 2008-05-25 21:48:19.000000000 +0200
++++ ServicesPrefs.m 2010-05-23 09:01:38.000000000 +0200
+@@ -7,8 +7,11 @@
+ of the License. See COPYING or main.m for more information.
+ */
+
++#include <Foundation/NSBundle.h>
++#include <Foundation/NSDictionary.h>
+ #include <Foundation/NSString.h>
+ #include <Foundation/NSUserDefaults.h>
++#include <Foundation/NSValue.h>
+ #include <AppKit/NSButton.h>
+ #include <AppKit/NSPopUpButton.h>
+ #include <AppKit/NSTextField.h>
diff --git a/x11/terminal.app/files/patch-TerminalParser_LinuxPrefs.m b/x11/terminal.app/files/patch-TerminalParser_LinuxPrefs.m
new file mode 100644
index 000000000000..71006c615069
--- /dev/null
+++ b/x11/terminal.app/files/patch-TerminalParser_LinuxPrefs.m
@@ -0,0 +1,11 @@
+--- TerminalParser_LinuxPrefs.m.orig 2008-05-25 21:48:19.000000000 +0200
++++ TerminalParser_LinuxPrefs.m 2010-05-23 09:08:25.000000000 +0200
+@@ -7,6 +7,8 @@
+ of the License. See COPYING or main.m for more information.
+ */
+
++#include <Foundation/NSBundle.h>
++#include <Foundation/NSNotification.h>
+ #include <Foundation/NSString.h>
+ #include <Foundation/NSUserDefaults.h>
+ #include <AppKit/NSPopUpButton.h>
diff --git a/x11/terminal.app/files/patch-TerminalView.m b/x11/terminal.app/files/patch-TerminalView.m
new file mode 100644
index 000000000000..12c088c9174b
--- /dev/null
+++ b/x11/terminal.app/files/patch-TerminalView.m
@@ -0,0 +1,10 @@
+--- TerminalView.m.orig 2009-08-05 19:28:45.000000000 +0200
++++ TerminalView.m 2010-05-23 09:03:04.000000000 +0200
+@@ -70,6 +70,7 @@
+ #include <AppKit/NSGraphics.h>
+ #include <AppKit/NSScroller.h>
+ #include <AppKit/DPSOperators.h>
++#include <AppKit/NSButtonCell.h>
+
+ #include "TerminalView.h"
+
diff --git a/x11/terminal.app/files/patch-TerminalViewPrefs.m b/x11/terminal.app/files/patch-TerminalViewPrefs.m
new file mode 100644
index 000000000000..350783548f4a
--- /dev/null
+++ b/x11/terminal.app/files/patch-TerminalViewPrefs.m
@@ -0,0 +1,11 @@
+--- TerminalViewPrefs.m.orig 2009-11-24 22:45:33.000000000 +0100
++++ TerminalViewPrefs.m 2010-05-23 09:05:57.000000000 +0200
+@@ -19,6 +19,8 @@
+ #include <AppKit/NSImage.h>
+ #include <AppKit/NSTextField.h>
+ #include <AppKit/NSFontManager.h>
++#include <AppKit/NSMatrix.h>
++#include <AppKit/NSButtonCell.h>
+ #include <GNUstepGUI/GSVbox.h>
+ #include <GNUstepGUI/GSHbox.h>
+ #include "Label.h"