diff options
author | bapt <bapt@FreeBSD.org> | 2015-07-20 21:03:15 +0800 |
---|---|---|
committer | bapt <bapt@FreeBSD.org> | 2015-07-20 21:03:15 +0800 |
commit | 617546c255d8194e3391c619203f58b043fb52a7 (patch) | |
tree | 63eca285342c21507b4f067d1c05a8f7a2a9469f | |
parent | 61e302bc23ee8d8925d117de3dc5588d916f5207 (diff) | |
download | freebsd-ports-gnome-617546c255d8194e3391c619203f58b043fb52a7.tar.gz freebsd-ports-gnome-617546c255d8194e3391c619203f58b043fb52a7.tar.zst freebsd-ports-gnome-617546c255d8194e3391c619203f58b043fb52a7.zip |
Fix with custom SYSCONF_DIR and fix qa tests
Change the home directory of the quagga user to /var/empty which prevent QA
First the home does not need to be harcoded to /usr/local/etc/quagga, second
it fixes issues where the home created by the user addition is 755 then the
plist modifies it to 750
Reviewed by: mat
Approved by: mat (maintainer)
Sponsored by: gandi.net
Differential Revision: https://reviews.freebsd.org/D3135
-rw-r--r-- | UIDs | 2 | ||||
-rw-r--r-- | net/quagga/Makefile | 4 | ||||
-rw-r--r-- | net/quagga/pkg-plist | 2 |
3 files changed, 4 insertions, 4 deletions
@@ -47,7 +47,7 @@ mud:*:97:97::0:0:MUD Owner:/nonexistent:/bin/sh msql:*:98:98::0:0:mSQL-2 pseudo-user:/var/db/msqldb:/bin/sh rscsi:*:99:99::0:0:Remote SCSI:/usr/local/rscsi:/usr/local/sbin/rscsi squid:*:100:100::0:0:squid caching-proxy pseudo user:/var/squid:/usr/sbin/nologin -quagga:*:101:101::0:0:Quagga route daemon pseudo user:/usr/local/etc/quagga:/usr/sbin/nologin +quagga:*:101:101::0:0:Quagga route daemon pseudo user:/var/empty:/usr/sbin/nologin ganglia:*:102:102::0:0:Ganglia User:/nonexistent:/usr/sbin/nologin sgeadmin:*:103:103::0:0:Sun Grid Engine Admin:/nonexistent:/usr/sbin/nologin slimserv:*:104:104::0:0:Slim Devices SlimServer pseudo-user:/nonexistent:/usr/sbin/nologin diff --git a/net/quagga/Makefile b/net/quagga/Makefile index 56a6c98f3531..787dd26d6f7b 100644 --- a/net/quagga/Makefile +++ b/net/quagga/Makefile @@ -3,7 +3,7 @@ PORTNAME= quagga PORTVERSION= 0.99.24.1 -PORTREVISION= 1 +PORTREVISION= 2 CATEGORIES= net ipv6 MASTER_SITES= SAVANNAH @@ -102,6 +102,6 @@ pre-everything:: post-install: ${MKDIR} ${STAGEDIR}${LOCALSTATE_DIR} ${STAGEDIR}${SYSCONF_DIR} \ ${STAGEDIR}${EXAMPLESDIR} - @${MV} ${STAGEDIR}${ETCDIR}/* ${STAGEDIR}${EXAMPLESDIR} + @${MV} ${STAGEDIR}${SYSCONF_DIR}/* ${STAGEDIR}${EXAMPLESDIR} .include <bsd.port.mk> diff --git a/net/quagga/pkg-plist b/net/quagga/pkg-plist index 80dcb9f43661..81afca378203 100644 --- a/net/quagga/pkg-plist +++ b/net/quagga/pkg-plist @@ -95,4 +95,4 @@ sbin/zebra %%EXAMPLESDIR%%/vtysh.conf.sample %%EXAMPLESDIR%%/zebra.conf.sample @dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%LOCALSTATE_DIR%% -@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%ETCDIR%% +@dir(%%ENABLE_USER%%,%%ENABLE_GROUP%%,750) %%SYSCONF_DIR%% |