aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2007-05-26 01:49:31 +0800
committeroliver <oliver@FreeBSD.org>2007-05-26 01:49:31 +0800
commit6349edc77037ee87909f885a411b48f2895bc928 (patch)
treef2f6a7d79c19862635ca518e6ddb5133112cf678
parent7876f06d27aeb5fbecbbe5f217efffc87b902af3 (diff)
downloadfreebsd-ports-gnome-6349edc77037ee87909f885a411b48f2895bc928.tar.gz
freebsd-ports-gnome-6349edc77037ee87909f885a411b48f2895bc928.tar.zst
freebsd-ports-gnome-6349edc77037ee87909f885a411b48f2895bc928.zip
fix build
move from X11BASE to LOCALBASE bump PORTREVISION
-rw-r--r--graphics/ogre312/Makefile9
-rw-r--r--graphics/ogre3d/Makefile9
-rw-r--r--graphics/ogre3d12/Makefile9
3 files changed, 15 insertions, 12 deletions
diff --git a/graphics/ogre312/Makefile b/graphics/ogre312/Makefile
index 33dd53cc3fa9..d050da604a9a 100644
--- a/graphics/ogre312/Makefile
+++ b/graphics/ogre312/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ogre3d
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
@@ -22,13 +22,14 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
WRKSRC= ${WRKDIR}/ogrenew
CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-platform=SDL \
--with-cppunit-prefix=/nonexistent
-CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG" \
+ ZZIPLIB_CFLAGS="-I${LOCALBASE}/include" \
+ ZZIPLIB_LIBS="-L${LOCALBASE}/lib -lzzip"
GNU_CONFIGURE= YES
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= YES
-USE_GCC= 3.4+
USE_BZIP2= YES
-USE_X_PREFIX= YES
+USE_XLIB= YES
USE_GNOME= gnomehack
USE_GMAKE= YES
USE_SDL= sdl
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 33dd53cc3fa9..d050da604a9a 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ogre3d
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
@@ -22,13 +22,14 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
WRKSRC= ${WRKDIR}/ogrenew
CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-platform=SDL \
--with-cppunit-prefix=/nonexistent
-CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG" \
+ ZZIPLIB_CFLAGS="-I${LOCALBASE}/include" \
+ ZZIPLIB_LIBS="-L${LOCALBASE}/lib -lzzip"
GNU_CONFIGURE= YES
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= YES
-USE_GCC= 3.4+
USE_BZIP2= YES
-USE_X_PREFIX= YES
+USE_XLIB= YES
USE_GNOME= gnomehack
USE_GMAKE= YES
USE_SDL= sdl
diff --git a/graphics/ogre3d12/Makefile b/graphics/ogre3d12/Makefile
index 33dd53cc3fa9..d050da604a9a 100644
--- a/graphics/ogre3d12/Makefile
+++ b/graphics/ogre3d12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ogre3d
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
@@ -22,13 +22,14 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
WRKSRC= ${WRKDIR}/ogrenew
CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-platform=SDL \
--with-cppunit-prefix=/nonexistent
-CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG" \
+ ZZIPLIB_CFLAGS="-I${LOCALBASE}/include" \
+ ZZIPLIB_LIBS="-L${LOCALBASE}/lib -lzzip"
GNU_CONFIGURE= YES
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= YES
-USE_GCC= 3.4+
USE_BZIP2= YES
-USE_X_PREFIX= YES
+USE_XLIB= YES
USE_GNOME= gnomehack
USE_GMAKE= YES
USE_SDL= sdl