aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorler <ler@FreeBSD.org>2017-04-24 00:54:28 +0800
committerler <ler@FreeBSD.org>2017-04-24 00:54:28 +0800
commit66ab78fcea0ab635a8c5044032a7d461bb2a5706 (patch)
tree9c99fd9c6980562a42d7f9ca2ea8ca8bb902b340
parentc3573b660aa01110dbd1e3e26a9b7bba54ac5bb8 (diff)
downloadfreebsd-ports-gnome-66ab78fcea0ab635a8c5044032a7d461bb2a5706.tar.gz
freebsd-ports-gnome-66ab78fcea0ab635a8c5044032a7d461bb2a5706.tar.zst
freebsd-ports-gnome-66ab78fcea0ab635a8c5044032a7d461bb2a5706.zip
Update net-mgmt/prometheus to 1.6.1, add version info
Removed STRIP=, as since go 1.6 stripping go binaries doesn't break them. Details of changes in this release are available here: https://github.com/prometheus/prometheus/releases/tag/v1.6.1 PR: 218737 Submitted by: ports@ecadlabs.com (maintainer) Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D10423
-rw-r--r--net-mgmt/prometheus/Makefile12
-rw-r--r--net-mgmt/prometheus/distinfo6
-rw-r--r--net-mgmt/prometheus/files/prometheus.in2
3 files changed, 11 insertions, 9 deletions
diff --git a/net-mgmt/prometheus/Makefile b/net-mgmt/prometheus/Makefile
index acb59d51b756..9751d52626ef 100644
--- a/net-mgmt/prometheus/Makefile
+++ b/net-mgmt/prometheus/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= prometheus
-PORTVERSION= 1.5.2
+PORTVERSION= 1.6.1
DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt
@@ -21,11 +21,13 @@ USE_RC_SUBR= prometheus
USERS= prometheus
GROUPS= prometheus
-STRIP= # stripping can break go binaries
-
+LD_FLAG_STRING= ${GO_PKGNAME}/vendor/github.com/prometheus/common/version.
do-build:
- (cd ${GO_WRKSRC}/cmd/prometheus ; ${SETENV} ${GO_ENV} go install)
- (cd ${GO_WRKSRC}/cmd/promtool ; ${SETENV} ${GO_ENV} go install)
+ (cd ${GO_WRKSRC}/cmd/prometheus ; ${SETENV} ${GO_ENV} go install -ldflags \
+ "-s -X ${LD_FLAG_STRING}.Version=${PORTVERSION}")
+
+ (cd ${GO_WRKSRC}/cmd/promtool ; ${SETENV} ${GO_ENV} go install -ldflags \
+ "-s -X ${LD_FLAG_STRING}.Version=${PORTVERSION}")
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/prometheus ${STAGEDIR}${PREFIX}/bin
diff --git a/net-mgmt/prometheus/distinfo b/net-mgmt/prometheus/distinfo
index fa622eb813b3..fa4d212e41e3 100644
--- a/net-mgmt/prometheus/distinfo
+++ b/net-mgmt/prometheus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1486719210
-SHA256 (prometheus-prometheus-v1.5.2_GH0.tar.gz) = c4881cc305263cc8da434be69a20aa039386d4feab5e58f8b89a60bfe8b556ac
-SIZE (prometheus-prometheus-v1.5.2_GH0.tar.gz) = 5183537
+TIMESTAMP = 1492658004
+SHA256 (prometheus-prometheus-v1.6.1_GH0.tar.gz) = ecc9ce94fce45994c23b76eb0c5acbb1b942513be601872c8cd74d0821450c5e
+SIZE (prometheus-prometheus-v1.6.1_GH0.tar.gz) = 5220870
diff --git a/net-mgmt/prometheus/files/prometheus.in b/net-mgmt/prometheus/files/prometheus.in
index 4f98eecf8e1e..03dd73c0aa88 100644
--- a/net-mgmt/prometheus/files/prometheus.in
+++ b/net-mgmt/prometheus/files/prometheus.in
@@ -44,7 +44,7 @@ extra_commands="reload"
command_args="-p ${pidfile} /usr/bin/env ${procname} \
-config.file=${prometheus_config} \
-storage.local.path=${prometheus_data_dir} \
- ${prometheus_args} > ${prometheus_log_file} 2>&1"
+ ${prometheus_args} >> ${prometheus_log_file} 2>&1"
start_precmd=prometheus_startprecmd