aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2012-10-29 06:19:55 +0800
committerhq <hq@FreeBSD.org>2012-10-29 06:19:55 +0800
commit66dc27bd42d85ead26a13e2782e6ff3e6b1004a7 (patch)
treecef0ca1eceeccef5c0a1a8de29f125590e6d9080
parent7f1118124fb15a8beb028bc6f3e8571d30c38c1f (diff)
downloadfreebsd-ports-gnome-66dc27bd42d85ead26a13e2782e6ff3e6b1004a7.tar.gz
freebsd-ports-gnome-66dc27bd42d85ead26a13e2782e6ff3e6b1004a7.tar.zst
freebsd-ports-gnome-66dc27bd42d85ead26a13e2782e6ff3e6b1004a7.zip
- Add support for tomcat6/7 instead of tomcat55
- Move docs and examples to optionsNG and define portdocs and portexamples explictly PR: 173011 Submitted by: jgh Feature safe: yes
-rw-r--r--www/axis/Makefile38
1 files changed, 16 insertions, 22 deletions
diff --git a/www/axis/Makefile b/www/axis/Makefile
index 12567d5734ea..fe3fdc270057 100644
--- a/www/axis/Makefile
+++ b/www/axis/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: AXIS
-# Date created: 6 JUNE 2003
-# Whom: Kensaku MASUDA <greg@greg.rim.or.jp>
+# Created by: Kensaku MASUDA <greg@greg.rim.or.jp>
#
# $FreeBSD$
PORTNAME= axis
PORTVERSION= 1.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= ws/axis/${PORTVERSION:S,.,_,g}
@@ -15,23 +13,22 @@ DISTNAME= axis-bin-${PORTVERSION:S,.,_,g}
MAINTAINER= hq@FreeBSD.org
COMMENT= Java SOAP implementation by Apache
+OPTIONS_SINGLE= AS
+OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
+OPTIONS_DEFAULT= TOMCAT6
+
.include <bsd.port.pre.mk>
-#
-# Change webapp directory by TOMCAT version
-#
-.if exists(${LOCALBASE}/tomcat5.5/webapps)
-WEBAPPDIR= ${PREFIX}/tomcat5.5/webapps
-BUILD_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
-RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
-.elif exists(${LOCALBASE}/apache-tomcat-6.0/webapps)
+.if ${PORT_OPTIONS:MTOMCAT6}
WEBAPPDIR= ${PREFIX}/apache-tomcat-6.0/webapps
BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
-.else
-WEBAPPDIR= ${PREFIX}/tomcat5.5/webapps
-BUILD_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
-RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+.endif
+
+.if ${PORT_OPTIONS:MTOMCAT7}
+WEBAPPDIR= ${PREFIX}/apache-tomcat-7.0/webapps
+BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-7.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-7.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
.endif
NO_BUILD= YES
@@ -47,12 +44,9 @@ WRKSRC= ${WRKDIR}/axis-${PORTVERSION:S,.,_,g}
#
SYSTEM_JARS= axis.jar jaxrpc.jar saaj.jar
PLIST_SUB+= WEBAPPS=${WEBAPPDIR:S|^${PREFIX}/||} USER=${USER} GROUP=${GROUP}
-.if !defined(NOPORTDOCS)
+
PORTDOCS= *
-.endif
-.if !defined(NOPORTEXAMPLES)
PORTEXAMPLES= *
-.endif
do-install:
.for i in ${SYSTEM_JARS}
@@ -60,11 +54,11 @@ do-install:
.endfor
cd ${WRKSRC}/webapps && ${FIND} axis -type d -exec ${INSTALL} -d -g ${GROUP} -o ${USER} -m 755 ${WEBAPPDIR}/{} \;
cd ${WRKSRC}/webapps && ${FIND} axis -type f -exec ${INSTALL} -g ${GROUP} -o ${USER} -m 444 {} ${WEBAPPDIR}/{} \;
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
cd ${WRKSRC}/docs && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
cd ${WRKSRC}/docs && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
cd ${WRKSRC}/samples && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \;
cd ${WRKSRC}/samples && ${FIND} . -type f -not -name '*.class' -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
.endif