aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-12-23 18:08:52 +0800
committerdanfe <danfe@FreeBSD.org>2004-12-23 18:08:52 +0800
commit68089e0f2c3a805fbfc38594615600af63c2d59c (patch)
tree8de9baebfc7877ed17467bc022b5eecac59e0664
parent61293d3c93748920a0826f3ad106e23659c5a808 (diff)
downloadfreebsd-ports-gnome-68089e0f2c3a805fbfc38594615600af63c2d59c.tar.gz
freebsd-ports-gnome-68089e0f2c3a805fbfc38594615600af63c2d59c.tar.zst
freebsd-ports-gnome-68089e0f2c3a805fbfc38594615600af63c2d59c.zip
- Unbreak; remove BROKEN and DEPRECATED marks
- Reword COMMENT to make it sound better
-rw-r--r--deskutils/kluje/Makefile6
-rw-r--r--deskutils/kluje/files/patch-editeventsdialog.cpp20
2 files changed, 21 insertions, 5 deletions
diff --git a/deskutils/kluje/Makefile b/deskutils/kluje/Makefile
index 8e5820378ef6..c5d5021b0551 100644
--- a/deskutils/kluje/Makefile
+++ b/deskutils/kluje/Makefile
@@ -13,17 +13,13 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A KDE application for submitting updates to livejournal.com
+COMMENT= A KDE client for the popular online journal site LiveJournal
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-BROKEN= "Does not compile"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
-
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/deskutils/kluje/files/patch-editeventsdialog.cpp b/deskutils/kluje/files/patch-editeventsdialog.cpp
new file mode 100644
index 000000000000..40ca7dc527ec
--- /dev/null
+++ b/deskutils/kluje/files/patch-editeventsdialog.cpp
@@ -0,0 +1,20 @@
+--- kluje/editeventsdialog.cpp.orig Wed Jul 17 06:01:24 2002
++++ kluje/editeventsdialog.cpp Thu Dec 23 10:56:25 2004
+@@ -159,7 +159,7 @@
+ this->setEnabled(false);
+ this->setCursor(QCursor(Qt::WaitCursor));
+ subjLineEdit->setCursor(QCursor(Qt::WaitCursor));
+- eventEdit->setCursor(QCursor(Qt::WaitCursor));
++ eventEdit->QMultiLineEdit::setCursor(QCursor(Qt::WaitCursor));
+ }
+
+ void EditEventsDialog::enable()
+@@ -167,7 +167,7 @@
+ this->setEnabled(true);
+ this->setCursor(QCursor(Qt::ArrowCursor));
+ subjLineEdit->setCursor(QCursor(Qt::ArrowCursor));
+- eventEdit->setCursor(QCursor(Qt::ArrowCursor));
++ eventEdit->QMultiLineEdit::setCursor(QCursor(Qt::ArrowCursor));
+ }
+
+ EditEventsDialog::~EditEventsDialog()