aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2014-10-06 05:40:29 +0800
committerrobak <robak@FreeBSD.org>2014-10-06 05:40:29 +0800
commit6e838a3d275b89d5d6e2414a4f6c14cc0c80d74d (patch)
treeebff34a4fc346b190c9cf521c31f2df07c2c89d4
parent9f978bc1dd4a0718c7277014620d89014324c0d6 (diff)
downloadfreebsd-ports-gnome-6e838a3d275b89d5d6e2414a4f6c14cc0c80d74d.tar.gz
freebsd-ports-gnome-6e838a3d275b89d5d6e2414a4f6c14cc0c80d74d.tar.zst
freebsd-ports-gnome-6e838a3d275b89d5d6e2414a4f6c14cc0c80d74d.zip
net-mgmt/nagios-check_dhcp.pl: NEW PORT - Nagios DHCP check plugin
This plugin tests the availability of a given DHCP server using unicast delivery. PR: 187623 Submitted by: Lawrence Chen <beastie@tardisi.com> Approved by: mentors (implicit)
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-check_dhcp.pl/Makefile37
-rw-r--r--net-mgmt/nagios-check_dhcp.pl/distinfo2
-rw-r--r--net-mgmt/nagios-check_dhcp.pl/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 654c07447648..9c3222bbe2f2 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -108,6 +108,7 @@
SUBDIR += nagios-check_bacula5
SUBDIR += nagios-check_clamav
SUBDIR += nagios-check_cpu_usage
+ SUBDIR += nagios-check_dhcp.pl
SUBDIR += nagios-check_email_delivery
SUBDIR += nagios-check_hdd_health
SUBDIR += nagios-check_hp_bladechassis
diff --git a/net-mgmt/nagios-check_dhcp.pl/Makefile b/net-mgmt/nagios-check_dhcp.pl/Makefile
new file mode 100644
index 000000000000..614f80876ed1
--- /dev/null
+++ b/net-mgmt/nagios-check_dhcp.pl/Makefile
@@ -0,0 +1,37 @@
+# Created by: Lawrence Chen <beastie@tardisi.com>
+# $FreeBSD$
+
+PORTNAME= check_dhcp.pl
+PORTVERSION= 0.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://exchange.nagios.org/components/com_mtree/attachment.php?link_id=1526&cf_id=24&dummy=/
+PKGNAMEPREFIX= nagios-
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX=
+
+MAINTAINER= beastie@tardisi.com
+COMMENT= Check the availability of a DHCP server using unicast delivery
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/utils.pm:${PORTSDIR}/net-mgmt/nagios-plugins \
+ p5-IO-Interface>=0:${PORTSDIR}/net/p5-IO-Interface \
+ p5-Net-DHCP-Watch>=0:${PORTSDIR}/net/p5-Net-DHCP-Watch
+
+USES= perl5
+USE_PERL5= run
+
+PLIST_FILES= libexec/nagios/check_dhcp.pl
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL}," ${WRKSRC}/${PORTNAME}
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}/
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_dhcp.pl ${STAGEDIR}${PREFIX}/libexec/nagios/check_dhcp.pl
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-check_dhcp.pl/distinfo b/net-mgmt/nagios-check_dhcp.pl/distinfo
new file mode 100644
index 000000000000..198264f85dcf
--- /dev/null
+++ b/net-mgmt/nagios-check_dhcp.pl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (check_dhcp.pl) = 7aa6f26ae11f66e7b7a0100649a42fbd7179279a1bc2ff0305d633be59bcc87b
+SIZE (check_dhcp.pl) = 4171
diff --git a/net-mgmt/nagios-check_dhcp.pl/pkg-descr b/net-mgmt/nagios-check_dhcp.pl/pkg-descr
new file mode 100644
index 000000000000..018ba6eb4b55
--- /dev/null
+++ b/net-mgmt/nagios-check_dhcp.pl/pkg-descr
@@ -0,0 +1,4 @@
+This plugin tests the availability of a given DHCP server using unicast
+delivery.
+
+WWW: http://exchange.nagios.org/