diff options
author | yuri <yuri@FreeBSD.org> | 2018-09-04 14:07:39 +0800 |
---|---|---|
committer | yuri <yuri@FreeBSD.org> | 2018-09-04 14:07:39 +0800 |
commit | 6f196bb0566885af085da9c8370df84c6a81ab8f (patch) | |
tree | 1adaedbbaa2b2fa1c0ca8a913aea1f8fe0ba0e08 | |
parent | d3d72509c9f80b05c9761cb6b32cb962d32a085f (diff) | |
download | freebsd-ports-gnome-6f196bb0566885af085da9c8370df84c6a81ab8f.tar.gz freebsd-ports-gnome-6f196bb0566885af085da9c8370df84c6a81ab8f.tar.zst freebsd-ports-gnome-6f196bb0566885af085da9c8370df84c6a81ab8f.zip |
Remove science/mpqc-mpich: Enable MPI option in science/mpqc by default
* MPICH option in science/mpqc is renamed to MPI, because MPI exists in many other
ports and there's MPI_DESC predefined for it.
* MPI option in science/mpqc is made default.
-rw-r--r-- | MOVED | 1 | ||||
-rw-r--r-- | science/Makefile | 1 | ||||
-rw-r--r-- | science/mpqc-mpich/Makefile | 11 | ||||
-rw-r--r-- | science/mpqc/Makefile | 13 |
4 files changed, 7 insertions, 19 deletions
@@ -10514,3 +10514,4 @@ devel/renpy6|games/renpy6|2018-09-03|Moved to better category devel/rlvm|games/rlvm|2018-09-03|Moved to better category dns/openmdns|net/openmdns|2018-09-03|Moved to better category www/hs-activehs||2018-09-03|Has expired: Doesn't build with recent dependencies +science/mpqc-mpich|science/mpqc|2018-09-03|MPI option is enabled by default in mpqc, no need for mpqc-mpich diff --git a/science/Makefile b/science/Makefile index 43710ed93aa1..4e40c981ba73 100644 --- a/science/Makefile +++ b/science/Makefile @@ -131,7 +131,6 @@ SUBDIR += mol2ps SUBDIR += mpb SUBDIR += mpqc - SUBDIR += mpqc-mpich SUBDIR += multiwfn SUBDIR += ncs SUBDIR += netcdf diff --git a/science/mpqc-mpich/Makefile b/science/mpqc-mpich/Makefile deleted file mode 100644 index 1a6fb3245ea9..000000000000 --- a/science/mpqc-mpich/Makefile +++ /dev/null @@ -1,11 +0,0 @@ -# Created by: Nakata Maho <chat95@mbox.kyoto-inet.or.jp> -# $FreeBSD$ - -MASTERDIR= ${.CURDIR}/../mpqc - -PORTREVISION= 1 -PKGNAMESUFFIX= -mpich - -OPTIONS_SLAVE= MPICH - -.include "${MASTERDIR}/Makefile" diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile index b364b44a4e68..0e53c0e4a84a 100644 --- a/science/mpqc/Makefile +++ b/science/mpqc/Makefile @@ -3,7 +3,7 @@ PORTNAME= mpqc PORTVERSION= 2.3.1 -PORTREVISION= 37 +PORTREVISION= 38 CATEGORIES= science parallel MASTER_SITES= SF @@ -34,23 +34,22 @@ SHEBANG_FILES= src/bin/mpqc/ccarunproc src/bin/mpqc/mpqcrunproc USE_LDCONFIG= yes USE_CXXSTD= c++98 # workaround https://github.com/ValeevGroup/mpqc/issues/57 -OPTIONS_DEFINE= ATLAS DOXYGEN EXAMPLES ICC MPICH OPTIFLAGS -OPTIONS_DEFAULT= DOXYGEN +OPTIONS_DEFINE= ATLAS DOXYGEN EXAMPLES ICC MPI OPTIFLAGS +OPTIONS_DEFAULT= DOXYGEN MPI OPTIONS_SUB= yes ICC_DESC= Build with ICC compiler instead ATLAS_DESC= Link with ATLAS instead of BLAS -MPICH_DESC= Parallel processing support via MPICH OPTIFLAGS_DESC= Build with optimized flags ATLAS_USES= blaslapack:atlas ATLAS_USES_OFF= blaslapack:netlib -DOXYGEN_CONFIGURE_ENABLE=doxygen-man +DOXYGEN_CONFIGURE_ENABLE= doxygen-man DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \ dot:graphics/graphviz ICC_BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:lang/icc -MPICH_CONFIGURE_ENABLE= parallel -MPICH_LIB_DEPENDS= libmpich.so:net/mpich2 +MPI_CONFIGURE_ENABLE= parallel +MPI_LIB_DEPENDS= libmpich.so:net/mpich2 OPTIFLAGS_CFLAGS= -ffast-math OPTIFLAGS_CXXFLAGS= -ffast-math |