aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-03 02:23:34 +0800
committeraz <az@FreeBSD.org>2013-09-03 02:23:34 +0800
commit6fcb190e486fac9b692dd8daaaaaadbe348038f1 (patch)
tree7649b1f5002c942331d22ad69679217a24b1ddf3
parentbdaeee6c097c63aa0044805e42e07c85989a63e3 (diff)
downloadfreebsd-ports-gnome-6fcb190e486fac9b692dd8daaaaaadbe348038f1.tar.gz
freebsd-ports-gnome-6fcb190e486fac9b692dd8daaaaaadbe348038f1.tar.zst
freebsd-ports-gnome-6fcb190e486fac9b692dd8daaaaaadbe348038f1.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
-rw-r--r--www/libwww/Makefile3
-rw-r--r--www/p5-Amon2-Lite/Makefile3
-rw-r--r--www/p5-Apache-ParseFormData/Makefile3
-rw-r--r--www/p5-Blog-Spam/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-HTDot/Makefile3
-rw-r--r--www/p5-Catalyst-View-REST-XML/Makefile3
-rw-r--r--www/p5-Emplacken/Makefile3
-rw-r--r--www/p5-Flea/Makefile3
-rw-r--r--www/p5-FurlX-Coro/Makefile3
-rw-r--r--www/p5-LWP-UserAgent-WithCache/Makefile3
-rw-r--r--www/p5-Path-Class-URI/Makefile3
-rw-r--r--www/p5-Plack-Middleware-Reproxy/Makefile3
-rw-r--r--www/p5-REST-Client/Makefile3
-rw-r--r--www/p5-Reddit/Makefile3
-rw-r--r--www/p5-Template-Multilingual/Makefile3
-rw-r--r--www/p5-WWW-FreeProxy/Makefile3
-rw-r--r--www/p5-WWW-NicoVideo-Download/Makefile3
-rw-r--r--www/p5-WWW-SourceForge/Makefile3
-rw-r--r--www/p5-ZConf-RSS-GUI-GTK/Makefile3
19 files changed, 38 insertions, 19 deletions
diff --git a/www/libwww/Makefile b/www/libwww/Makefile
index ca381e6ad44b..69d2f3f6ee33 100644
--- a/www/libwww/Makefile
+++ b/www/libwww/Makefile
@@ -20,7 +20,8 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-shared --enable-static --with-zlib --with-ssl=${OPENSSLBASE}
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
USE_LDCONFIG= yes
USE_OPENSSL= yes
diff --git a/www/p5-Amon2-Lite/Makefile b/www/p5-Amon2-Lite/Makefile
index b57d16da919e..eae1c81c01f1 100644
--- a/www/p5-Amon2-Lite/Makefile
+++ b/www/p5-Amon2-Lite/Makefile
@@ -23,7 +23,8 @@ TEST_DEPENDS= \
p5-Tiffany>0:${PORTSDIR}/textproc/p5-Tiffany \
p5-Plack-Middleware-ReverseProxy>0:${PORTSDIR}/www/p5-Plack-Middleware-ReverseProxy
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Amon2::Lite.3 \
Amon2::Setup::Flavor::Lite.3
diff --git a/www/p5-Apache-ParseFormData/Makefile b/www/p5-Apache-ParseFormData/Makefile
index cb07f867ffa5..e511433cbc49 100644
--- a/www/p5-Apache-ParseFormData/Makefile
+++ b/www/p5-Apache-ParseFormData/Makefile
@@ -18,7 +18,8 @@ COMMENT= Module allows you to easily decode/parse form and query data
BUILD_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_APACHE= 22+
MAN3= Apache::ParseFormData.3
diff --git a/www/p5-Blog-Spam/Makefile b/www/p5-Blog-Spam/Makefile
index 89cd30800c49..7644f452614a 100644
--- a/www/p5-Blog-Spam/Makefile
+++ b/www/p5-Blog-Spam/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= p5-Net-CIDR-Lite>=0:${PORTSDIR}/net/p5-Net-CIDR-Lite \
p5-URI-Find>=0:${PORTSDIR}/textproc/p5-URI-Find \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= blogspam.1
MAN3= Blog::Spam::API.3 \
diff --git a/www/p5-CGI-Application-Plugin-HTDot/Makefile b/www/p5-CGI-Application-Plugin-HTDot/Makefile
index d757370af077..ac226b19713f 100644
--- a/www/p5-CGI-Application-Plugin-HTDot/Makefile
+++ b/www/p5-CGI-Application-Plugin-HTDot/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-CGI-Application>=4.0:${PORTSDIR}/www/p5-CGI-Application \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Application::Plugin::HTDot.3
diff --git a/www/p5-Catalyst-View-REST-XML/Makefile b/www/p5-Catalyst-View-REST-XML/Makefile
index 0365f63052fc..615b4b8429be 100644
--- a/www/p5-Catalyst-View-REST-XML/Makefile
+++ b/www/p5-Catalyst-View-REST-XML/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::View::REST::XML.3
diff --git a/www/p5-Emplacken/Makefile b/www/p5-Emplacken/Makefile
index 7d5c2053892b..832cbcc3d156 100644
--- a/www/p5-Emplacken/Makefile
+++ b/www/p5-Emplacken/Makefile
@@ -29,7 +29,8 @@ RUN_DEPENDS= p5-Class-Load>=0:${PORTSDIR}/devel/p5-Class-Load \
p5-autodie>=0:${PORTSDIR}/devel/p5-autodie \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Emplacken.3 \
Emplacken::Types.3
diff --git a/www/p5-Flea/Makefile b/www/p5-Flea/Makefile
index c7e40e02b8b1..95ddc1a31ddf 100644
--- a/www/p5-Flea/Makefile
+++ b/www/p5-Flea/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS= \
p5-URI>0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Flea.3
diff --git a/www/p5-FurlX-Coro/Makefile b/www/p5-FurlX-Coro/Makefile
index e4d9e20ce7fa..52658dc725be 100644
--- a/www/p5-FurlX-Coro/Makefile
+++ b/www/p5-FurlX-Coro/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= \
${RUN_DEPENDS} \
p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= FurlX::Coro.3 \
FurlX::Coro::HTTP.3
diff --git a/www/p5-LWP-UserAgent-WithCache/Makefile b/www/p5-LWP-UserAgent-WithCache/Makefile
index 6d3ae4548183..a24a71843fb1 100644
--- a/www/p5-LWP-UserAgent-WithCache/Makefile
+++ b/www/p5-LWP-UserAgent-WithCache/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= LWP::UserAgent::WithCache.3
diff --git a/www/p5-Path-Class-URI/Makefile b/www/p5-Path-Class-URI/Makefile
index eab8d87113f0..f99e05d322d7 100644
--- a/www/p5-Path-Class-URI/Makefile
+++ b/www/p5-Path-Class-URI/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= \
p5-Exporter-Lite>0:${PORTSDIR}/devel/p5-Exporter-Lite
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Path::Class::URI.3 \
Path::Class::Unicode.3
diff --git a/www/p5-Plack-Middleware-Reproxy/Makefile b/www/p5-Plack-Middleware-Reproxy/Makefile
index 7ac7e577edac..de7a9925b603 100644
--- a/www/p5-Plack-Middleware-Reproxy/Makefile
+++ b/www/p5-Plack-Middleware-Reproxy/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-TEST-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::Reproxy.3 \
Plack::Middleware::Reproxy::Callback.3 \
diff --git a/www/p5-REST-Client/Makefile b/www/p5-REST-Client/Makefile
index 87c3d8220d38..10db4ee64891 100644
--- a/www/p5-REST-Client/Makefile
+++ b/www/p5-REST-Client/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= REST::Client.3
diff --git a/www/p5-Reddit/Makefile b/www/p5-Reddit/Makefile
index 73cb4f243e49..b1062ee7bb37 100644
--- a/www/p5-Reddit/Makefile
+++ b/www/p5-Reddit/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-HTTP-Cookies>=6:${PORTSDIR}/www/p5-HTTP-Cookies \
p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Reddit.3
diff --git a/www/p5-Template-Multilingual/Makefile b/www/p5-Template-Multilingual/Makefile
index 5aceb3a09bde..0d525076ff50 100644
--- a/www/p5-Template-Multilingual/Makefile
+++ b/www/p5-Template-Multilingual/Makefile
@@ -16,7 +16,8 @@ COMMENT= Multilingual templates for Template Toolkit
RUN_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Multilingual.3 \
Template::Multilingual::Parser.3
diff --git a/www/p5-WWW-FreeProxy/Makefile b/www/p5-WWW-FreeProxy/Makefile
index b1739f4bbcd6..e8bd00e15655 100644
--- a/www/p5-WWW-FreeProxy/Makefile
+++ b/www/p5-WWW-FreeProxy/Makefile
@@ -17,7 +17,8 @@ COMMENT= Fetch proxies from free proxy lists
BUILD_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::FreeProxy.3 WWW::FreeProxy::Proxy4Free.3 WWW::FreeProxy::Samair.3 WWW::FreeProxy::Look.3 WWW::FreeProxy::PublicProxyServers.3
diff --git a/www/p5-WWW-NicoVideo-Download/Makefile b/www/p5-WWW-NicoVideo-Download/Makefile
index 400db0916185..49642d184e16 100644
--- a/www/p5-WWW-NicoVideo-Download/Makefile
+++ b/www/p5-WWW-NicoVideo-Download/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::NicoVideo::Download.3
diff --git a/www/p5-WWW-SourceForge/Makefile b/www/p5-WWW-SourceForge/Makefile
index 73fde8ff0495..aa24381e899e 100644
--- a/www/p5-WWW-SourceForge/Makefile
+++ b/www/p5-WWW-SourceForge/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::SourceForge.3 WWW::SourceForge::Project.3
diff --git a/www/p5-ZConf-RSS-GUI-GTK/Makefile b/www/p5-ZConf-RSS-GUI-GTK/Makefile
index bfdbed213248..4b1f2f0232a5 100644
--- a/www/p5-ZConf-RSS-GUI-GTK/Makefile
+++ b/www/p5-ZConf-RSS-GUI-GTK/Makefile
@@ -15,7 +15,8 @@ COMMENT= Provides a GTK backend for ZConf::RSS::GUI
RUN_DEPENDS= p5-ZConf-RSS>=0:${PORTSDIR}/www/p5-ZConf-RSS \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf::RSS::GUI::GTK.3