aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-19 00:45:09 +0800
committermat <mat@FreeBSD.org>2013-11-19 00:45:09 +0800
commit7104d04fa6390b447400eba5b28df71a85aab421 (patch)
tree1f4367f53911cc112a7fd0f4bec71bfa584b45b6
parent7544e51fe11fe9aeb75e8a7245e6ddda8daa40d1 (diff)
downloadfreebsd-ports-gnome-7104d04fa6390b447400eba5b28df71a85aab421.tar.gz
freebsd-ports-gnome-7104d04fa6390b447400eba5b28df71a85aab421.tar.zst
freebsd-ports-gnome-7104d04fa6390b447400eba5b28df71a85aab421.zip
Use new USES=dos2unix
-rw-r--r--devel/p5-Class-Contract/Makefile3
-rw-r--r--devel/p5-Config-IniHash/Makefile3
-rw-r--r--devel/p5-Devel-Diagram/Makefile3
-rw-r--r--graphics/p5-GD-Graph3d/Makefile4
-rw-r--r--graphics/p5-SWF-Builder/Makefile3
-rw-r--r--graphics/p5-SWF-File/Makefile3
-rw-r--r--math/p5-Math-Bezier-Convert/Makefile3
-rw-r--r--textproc/p5-Pod-Parser/Makefile3
-rw-r--r--textproc/p5-Pod-Stripper/Makefile3
-rw-r--r--textproc/p5-SVG/Makefile3
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/Makefile3
-rw-r--r--textproc/p5-XML-Handler-Trees/Makefile4
-rw-r--r--textproc/p5-XML-SAXDriver-CSV/Makefile3
-rw-r--r--textproc/p5-XML-SAXDriver-Excel/Makefile3
-rw-r--r--www/p5-HTTP-Recorder/Makefile3
-rw-r--r--www/p5-WWW-Search/Makefile3
16 files changed, 18 insertions, 32 deletions
diff --git a/devel/p5-Class-Contract/Makefile b/devel/p5-Class-Contract/Makefile
index ad853e688438..895a8beb0f20 100644
--- a/devel/p5-Class-Contract/Makefile
+++ b/devel/p5-Class-Contract/Makefile
@@ -10,9 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Design-by-Contract OO in Perl
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
PLIST_SUB+= EXAMPLESDIR="share/examples/${PORTNAME}"
pre-configure:
diff --git a/devel/p5-Config-IniHash/Makefile b/devel/p5-Config-IniHash/Makefile
index d8342a86ed29..83a5d3ad9588 100644
--- a/devel/p5-Config-IniHash/Makefile
+++ b/devel/p5-Config-IniHash/Makefile
@@ -16,8 +16,7 @@ RUN_DEPENDS= p5-Hash-Case>=0:${PORTSDIR}/devel/p5-Hash-Case \
p5-Hash-WithDefaults>=0.04:${PORTSDIR}/devel/p5-Hash-WithDefaults
BUILD_DEPENDS:= ${RUN_DEPENDS}
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
.include <bsd.port.mk>
diff --git a/devel/p5-Devel-Diagram/Makefile b/devel/p5-Devel-Diagram/Makefile
index 5dc6ec507749..6b7e7416c8ad 100644
--- a/devel/p5-Devel-Diagram/Makefile
+++ b/devel/p5-Devel-Diagram/Makefile
@@ -10,9 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Discover the classes of an arbitrary suite of Perl modules
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
post-install:
.ifndef(NOPORTDOCS)
diff --git a/graphics/p5-GD-Graph3d/Makefile b/graphics/p5-GD-Graph3d/Makefile
index bd028f7946ad..3cb18a2f3688 100644
--- a/graphics/p5-GD-Graph3d/Makefile
+++ b/graphics/p5-GD-Graph3d/Makefile
@@ -14,8 +14,8 @@ COMMENT= Creates 3D charts with GD::Graph and GD
BUILD_DEPENDS= p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= lib/GD/Graph3d.pm # pod2man doesn't work without this
+DOS2UNIX_FILES= lib/GD/Graph3d.pm # pod2man doesn't work without this
.include <bsd.port.mk>
diff --git a/graphics/p5-SWF-Builder/Makefile b/graphics/p5-SWF-Builder/Makefile
index c5e0b6125875..a20a076e6e6d 100644
--- a/graphics/p5-SWF-Builder/Makefile
+++ b/graphics/p5-SWF-Builder/Makefile
@@ -15,9 +15,8 @@ BUILD_DEPENDS= p5-SWF-File>=0:${PORTSDIR}/graphics/p5-SWF-File \
p5-Font-TTF>=0:${PORTSDIR}/x11-fonts/p5-Font-TTF
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
index f20cf64d80e3..0b6c5022961a 100644
--- a/graphics/p5-SWF-File/Makefile
+++ b/graphics/p5-SWF-File/Makefile
@@ -15,9 +15,8 @@ COMMENT= Manipulating Flash movie (SWF) files
BUILD_DEPENDS= p5-Data-TemporaryBag>=0:${PORTSDIR}/devel/p5-Data-TemporaryBag
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
diff --git a/math/p5-Math-Bezier-Convert/Makefile b/math/p5-Math-Bezier-Convert/Makefile
index b0be74b1c5c3..c9f9dfbb6de0 100644
--- a/math/p5-Math-Bezier-Convert/Makefile
+++ b/math/p5-Math-Bezier-Convert/Makefile
@@ -10,9 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Convert cubic and quadratic Bezier each other
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index ce78fd72b2bc..9df5a2c79a88 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -13,9 +13,8 @@ COMMENT= Modules to work with POD (Plain Old Documentation)
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
post-patch:
@${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
diff --git a/textproc/p5-Pod-Stripper/Makefile b/textproc/p5-Pod-Stripper/Makefile
index f00065867c2f..26d277b75fb8 100644
--- a/textproc/p5-Pod-Stripper/Makefile
+++ b/textproc/p5-Pod-Stripper/Makefile
@@ -11,8 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Strip all pod, and output what's left
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
.include <bsd.port.mk>
diff --git a/textproc/p5-SVG/Makefile b/textproc/p5-SVG/Makefile
index f5756cef13ce..25175766617f 100644
--- a/textproc/p5-SVG/Makefile
+++ b/textproc/p5-SVG/Makefile
@@ -15,9 +15,8 @@ LICENSE_COMB= dual
OPTIONS_DEFINE= EXAMPLES
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
.include <bsd.port.options.mk>
diff --git a/textproc/p5-Spreadsheet-WriteExcel/Makefile b/textproc/p5-Spreadsheet-WriteExcel/Makefile
index 3fd6942cd344..b949742a4a71 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/Makefile
+++ b/textproc/p5-Spreadsheet-WriteExcel/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= DOCS EXAMPLES
-USES= perl5 shebangfix
-USE_DOS2UNIX= yes
+USES= perl5 shebangfix dos2unix
USE_PERL5= configure
DOS2UNIX_REGEX= "*.p[lm]"
diff --git a/textproc/p5-XML-Handler-Trees/Makefile b/textproc/p5-XML-Handler-Trees/Makefile
index 81c831270d6a..c737979465d1 100644
--- a/textproc/p5-XML-Handler-Trees/Makefile
+++ b/textproc/p5-XML-Handler-Trees/Makefile
@@ -10,9 +10,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= PerlSAX handlers for building tree structures
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= Trees.pm
+DOS2UNIX_FILES= Trees.pm
post-extract:
@${CHMOD} +w ${WRKSRC}/Trees.pm
diff --git a/textproc/p5-XML-SAXDriver-CSV/Makefile b/textproc/p5-XML-SAXDriver-CSV/Makefile
index c003739a1f7b..526b48c2c06a 100644
--- a/textproc/p5-XML-SAXDriver-CSV/Makefile
+++ b/textproc/p5-XML-SAXDriver-CSV/Makefile
@@ -16,8 +16,7 @@ BUILD_DEPENDS= p5-Text-CSV_XS>=0.22:${PORTSDIR}/textproc/p5-Text-CSV_XS \
p5-XML-SAX>=0.14:${PORTSDIR}/textproc/p5-XML-SAX
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SAXDriver-Excel/Makefile b/textproc/p5-XML-SAXDriver-Excel/Makefile
index f0be0eaba617..004b0b3ab8e6 100644
--- a/textproc/p5-XML-SAXDriver-Excel/Makefile
+++ b/textproc/p5-XML-SAXDriver-Excel/Makefile
@@ -14,8 +14,7 @@ BUILD_DEPENDS= p5-Spreadsheet-ParseExcel>=0.2603:${PORTSDIR}/textproc/p5-Spreads
p5-XML-SAX>=0.14:${PORTSDIR}/textproc/p5-XML-SAX
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Recorder/Makefile b/www/p5-HTTP-Recorder/Makefile
index ba2fbb8a44cf..093302d34b58 100644
--- a/www/p5-HTTP-Recorder/Makefile
+++ b/www/p5-HTTP-Recorder/Makefile
@@ -17,9 +17,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
post-patch:
@${RM} -f ${WRKSRC}/lib/HTTP/Recorder.pm.orig
diff --git a/www/p5-WWW-Search/Makefile b/www/p5-WWW-Search/Makefile
index 3211ffa53214..216ec56ccbd5 100644
--- a/www/p5-WWW-Search/Makefile
+++ b/www/p5-WWW-Search/Makefile
@@ -35,8 +35,7 @@ TEST_DEPENDS= p5-IO-Capture>=0:${PORTSDIR}/devel/p5-IO-Capture \
p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-USES= perl5
+USES= perl5 dos2unix
USE_PERL5= configure
-USE_DOS2UNIX= yes
.include <bsd.port.mk>