aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjase <jase@FreeBSD.org>2014-02-08 04:09:51 +0800
committerjase <jase@FreeBSD.org>2014-02-08 04:09:51 +0800
commit716acae28ed087f25055eb548295d36363bf7651 (patch)
treee3ebceb4796cd3120f537c5fb85bd3a4b990596e
parent78aa59fca98e723e5a3e7231606ac8981820a49b (diff)
downloadfreebsd-ports-gnome-716acae28ed087f25055eb548295d36363bf7651.tar.gz
freebsd-ports-gnome-716acae28ed087f25055eb548295d36363bf7651.tar.zst
freebsd-ports-gnome-716acae28ed087f25055eb548295d36363bf7651.zip
- Update to 1.2
- Modernise OPTIONS configuration - Support custom LOCALBASE - Stage support Changes: http://wiki.znc.in/ChangeLog/1.2
-rw-r--r--irc/znc/Makefile92
-rw-r--r--irc/znc/distinfo4
-rw-r--r--irc/znc/files/patch-modules-webadmin_cpp38
-rw-r--r--irc/znc/pkg-plist4
4 files changed, 47 insertions, 91 deletions
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index b703ee6ebd59..92c7acbb7fea 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -2,15 +2,14 @@
# $FreeBSD$
PORTNAME= znc
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= irc ipv6
MASTER_SITES= http://znc.in/releases/
MAINTAINER= jase@FreeBSD.org
COMMENT= An advanced IRC bouncer
-LICENSE= GPLv2
+LICENSE= APACHE20
GNU_CONFIGURE= yes
USE_RC_SUBR= znc
@@ -20,91 +19,82 @@ NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= DEBUG IPV6 OPENSSL CYRUS PERL PYTHON TCL
OPTIONS_DEFAULT= OPENSSL PERL
+OPTIONS_SUB= yes
+CYRUS_DESC= Cyrus SASL module
DEBUG_DESC= Debugging support
PERL_DESC= Perl scripting module
PYTHON_DESC= Python scripting module
TCL_DESC= Tcl scripting module
-CYRUS_DESC= Cyrus SASL module
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+CYRUS_CONFIGURE_ON= --enable-cyrus
+CYRUS_LDFLAGS= -L${LOCALBASE}/lib
+CYRUS_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+DEBUG_CONFIGURE_ON= --enable-debug
+IPV6_CONFIGURE_OFF= --disable-ipv6
+PERL_BUILD_DEPENDS= swig>=2.0.11:${PORTSDIR}/devel/swig20
+PERL_CONFIGURE_ENABLE= perl
+PERL_CONFIGURE_ON= --enable-swig
+PERL_USES= perl5
+PYTHON_BUILD_DEPENDS= swig>=2.0.11:${PORTSDIR}/devel/swig20
+PYTHON_CONFIGURE_ON= --enable-python=python-${PYTHON_VER} --enable-swig
+PYTHON_USES= perl5
+OPENSSL_CONFIGURE_OFF= --disable-openssl
+TCL_CONFIGURE_ENABLE= tcl
-.if empty(PORT_OPTIONS:MIPV6)
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-PLIST_SUB+= OPENSSL=""
-.else
-CONFIGURE_ARGS+= --disable-openssl
-PLIST_SUB+= OPENSSL="@comment "
.endif
.if ${PORT_OPTIONS:MPERL}
-USES+= perl5
USE_PERL5+= run build
-CONFIGURE_ARGS+= --enable-perl
-PLIST_SUB+= PERL=""
-BUILD_DEPENDS+= swig>=2.0.4:${PORTSDIR}/devel/swig20
-.else
-PLIST_SUB+= PERL="@comment "
.endif
.if ${PORT_OPTIONS:MTCL}
USE_TCL= 84+
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
-CONFIGURE_ARGS+= --enable-tcl --with-tcl=${TCL_LIBDIR}
-PLIST_SUB+= TCL=""
-.else
-CONFIGURE_ARGS+= --without-tcl
-PLIST_SUB+= TCL="@comment "
+CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 3.1-3.2
-USES+= perl5
-USE_PERL5+= build
-PLIST_SUB+= PYTHON=""
-CONFIGURE_ARGS+= --enable-python=python-${PYTHON_VER}
-BUILD_DEPENDS+= swig>=2.0.4:${PORTSDIR}/devel/swig20
-.else
-PLIST_SUB+= PYTHON="@comment "
+USE_PYTHON= 3.1-
+USE_PERL5+= build
.endif
-.if ${PORT_OPTIONS:MCYRUS}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
-CONFIGURE_ARGS+= --enable-cyrus
-LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB+= CYRUS=""
-.else
-PLIST_SUB+= CYRUS="@comment "
-.endif
+PORTDOCS= README.md
-MANCOMPRESSED= yes
-MAN1= znc.1 znc-buildmod.1
-
-PORTDOCS= README.md
+pre-configure:
+# No need to cast to char** in AM_ICONV, fixes charset/iconv detection
+# and by extension, successfully builds charset module
+ @${REINPLACE_CMD} -e \
+ 's#(char \*\*)##g' \
+ ${WRKSRC}/configure
+# Instead of using bundled swig generated files, delete them to force
+# regeneration using swig 2.0.11+ (fixes port compilation using clang)
+.if ${PORT_OPTIONS:MPERL}
+ @${RM} ${WRKSRC}/modules/modperl/ZNC.cpp
+.endif
+.if ${PORT_OPTIONS:MPYTHON}
+ @${RM} ${WRKSRC}/modules/modpython/_znc_core.cpp
+.endif
post-patch:
@${REINPLACE_CMD} -e \
's#$$(libdir)/pkgconfig#${PREFIX}/libdata/pkgconfig#' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's#/usr/local#${LOCALBASE}#' ${WRKSRC}/configure
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}"
- @${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.mk>
diff --git a/irc/znc/distinfo b/irc/znc/distinfo
index 123dd7270710..6b048ae5ecf9 100644
--- a/irc/znc/distinfo
+++ b/irc/znc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (znc-1.0.tar.gz) = a85539da42697b26e4d46205def36bb799f83d6aeef401d53c49ee674142062a
-SIZE (znc-1.0.tar.gz) = 1222361
+SHA256 (znc-1.2.tar.gz) = d9a2cd2a484ff23e6fc9cbde8dd8a43efbcd8d288afca7b1268914ca0d18701d
+SIZE (znc-1.2.tar.gz) = 1235150
diff --git a/irc/znc/files/patch-modules-webadmin_cpp b/irc/znc/files/patch-modules-webadmin_cpp
deleted file mode 100644
index dc68df02012b..000000000000
--- a/irc/znc/files/patch-modules-webadmin_cpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- modules/webadmin.cpp.orig 2012-11-06 16:02:20.000000000 +0000
-+++ modules/webadmin.cpp 2013-05-28 12:43:53.258581961 +0100
-@@ -404,7 +404,7 @@
- CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
-
- // Admin||Self Check
-- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
-+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
- return false;
- }
-
-@@ -433,7 +433,7 @@
- CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
-
- // Admin||Self Check
-- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
-+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
- return false;
- }
-
-@@ -457,7 +457,7 @@
- CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
-
- // Admin||Self Check
-- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
-+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
- return false;
- }
-
-@@ -471,7 +471,7 @@
- CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
-
- // Admin||Self Check
-- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
-+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
- return false;
- }
-
diff --git a/irc/znc/pkg-plist b/irc/znc/pkg-plist
index 15e882d2dbfc..0fdf80fda037 100644
--- a/irc/znc/pkg-plist
+++ b/irc/znc/pkg-plist
@@ -18,6 +18,7 @@ include/znc/SHA256.h
include/znc/Server.h
include/znc/Socket.h
include/znc/Template.h
+include/znc/Threads.h
include/znc/User.h
include/znc/Utils.h
include/znc/WebModules.h
@@ -57,6 +58,7 @@ lib/znc/lastseen.so
lib/znc/listsockets.so
lib/znc/log.so
lib/znc/missingmotd.so
+lib/znc/modules_online.so
lib/znc/nickserv.so
lib/znc/notes.so
lib/znc/notify_connect.so
@@ -74,6 +76,8 @@ lib/znc/stickychan.so
lib/znc/watch.so
lib/znc/webadmin.so
libdata/pkgconfig/znc.pc
+man/man1/znc-buildmod.1.gz
+man/man1/znc.1.gz
%%CYRUS%%lib/znc/cyrusauth.so
%%OPENSSL%%lib/znc/awaystore.so
%%OPENSSL%%lib/znc/cert.so