aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-05-13 01:35:56 +0800
committerantoine <antoine@FreeBSD.org>2015-05-13 01:35:56 +0800
commit73390f54f5f07e158801cb00f3515bca144d34fc (patch)
treeb4f784a42d6ff0bc33a2e94533405e49f2f510e0
parentd552f8259832d75627e7faaea105c863384f7709 (diff)
downloadfreebsd-ports-gnome-73390f54f5f07e158801cb00f3515bca144d34fc.tar.gz
freebsd-ports-gnome-73390f54f5f07e158801cb00f3515bca144d34fc.tar.zst
freebsd-ports-gnome-73390f54f5f07e158801cb00f3515bca144d34fc.zip
This port links against libcrypto, so use the openssl header and not the libmd one
-rw-r--r--security/sectok/Makefile1
-rw-r--r--security/sectok/files/patch-cyberflex.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/security/sectok/Makefile b/security/sectok/Makefile
index 2d464d19b29e..71241295772e 100644
--- a/security/sectok/Makefile
+++ b/security/sectok/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sectok
PORTVERSION= 20030825
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.citi.umich.edu/projects/smartcard/
EXTRACT_SUFX= .tgz
diff --git a/security/sectok/files/patch-cyberflex.c b/security/sectok/files/patch-cyberflex.c
index f5889c1ed600..5dbbf31f50a5 100644
--- a/security/sectok/files/patch-cyberflex.c
+++ b/security/sectok/files/patch-cyberflex.c
@@ -10,7 +10,7 @@
+#define SHA1Init SHA1_Init
+#define SHA1Update SHA1_Update
+#define SHA1Final SHA1_Final
-+#include <sha.h>
++#include <openssl/sha.h>
+#else
#include <sha1.h>
#endif