aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrezny <rezny@FreeBSD.org>2017-03-31 09:48:55 +0800
committerrezny <rezny@FreeBSD.org>2017-03-31 09:48:55 +0800
commit7378b435c5e6d7d17c844596271e065bc2c5d5b5 (patch)
treec579aa0eed091c6f021d1caa936d798d42d3eeca
parent73852b6b11b6d65b3d4d4f703308e10491a67d5a (diff)
downloadfreebsd-ports-gnome-7378b435c5e6d7d17c844596271e065bc2c5d5b5.tar.gz
freebsd-ports-gnome-7378b435c5e6d7d17c844596271e065bc2c5d5b5.tar.zst
freebsd-ports-gnome-7378b435c5e6d7d17c844596271e065bc2c5d5b5.zip
Fix fetch, update to 1.0.1, and add option for Qt 4 or 5 (default).
PR: 217824 Reviewed by: mat Approved by: swills (mentor), maintainer (timeout) Differential Revision: https://reviews.freebsd.org/D10199
-rw-r--r--devel/fuel/Makefile31
-rw-r--r--devel/fuel/distinfo5
-rw-r--r--devel/fuel/pkg-descr6
3 files changed, 24 insertions, 18 deletions
diff --git a/devel/fuel/Makefile b/devel/fuel/Makefile
index 7a35b8695ef9..307f60912e22 100644
--- a/devel/fuel/Makefile
+++ b/devel/fuel/Makefile
@@ -2,28 +2,33 @@
# $FreeBSD$
PORTNAME= fuel
-DISTVERSION= 0.9.6
+DISTVERSION= 1.0.1
CATEGORIES= devel
-MASTER_SITES= https://fuel-scm.googlecode.com/files/
+MASTER_SITES= https://fuel-scm.org/files/releases/
MAINTAINER= nukama+maintainer@gmail.com
-COMMENT= GUI front-end to fossil SCM tool
+COMMENT= GUI Front-End to the Fossil SCM tool
LICENSE= GPLv2
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
+BUILD_DEPENDS= bash:shells/bash
+RUN_DEPENDS= fossil:devel/fossil
-RUN_DEPENDS= ${LOCALBASE}/bin/fossil:devel/fossil
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI= QT4 QT5
+OPTIONS_DEFAULT= QT5
-USES= qmake
-USE_QT4= corelib gui \
- moc_build rcc_build uic_build
+USES= qmake shebangfix
+QT4_USE= QT4=corelib,gui,webkit,linguisttools_build,moc_build,rcc_build,uic_build
+QT5_USE= QT5=core,gui,network,webkit,widgets,buildtools_build,linguisttools_build
-PLIST_FILES= bin/Fuel
+SHEBANG_FILES= intl/convert.sh
+PLIST_FILES= bin/fuel share/applications/fuel.desktop \
+ share/icons/hicolor/256x256/apps/fuel.png
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Fuel ${STAGEDIR}${PREFIX}/bin/Fuel
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ -e 's|/usr$$|${PREFIX}|' ${WRKSRC}/fuel.pro
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' ${WRKSRC}/rsrc/fuel.desktop
.include <bsd.port.mk>
diff --git a/devel/fuel/distinfo b/devel/fuel/distinfo
index e3df6dca5b93..115e3757f908 100644
--- a/devel/fuel/distinfo
+++ b/devel/fuel/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fuel-0.9.6.tar.gz) = 83b7e1f327f5c411d5f9f758fd74e9de274618fe601dea8128561186548381e2
-SIZE (fuel-0.9.6.tar.gz) = 3958347
+TIMESTAMP = 1489581484
+SHA256 (fuel-1.0.1.tar.gz) = 4e463cb9f3cf9c31c7ae95ce76b558502c0b07e1dd4109da714997f0dc9a65db
+SIZE (fuel-1.0.1.tar.gz) = 4041886
diff --git a/devel/fuel/pkg-descr b/devel/fuel/pkg-descr
index ca9e383b8350..a3a8e489f1d7 100644
--- a/devel/fuel/pkg-descr
+++ b/devel/fuel/pkg-descr
@@ -1,4 +1,4 @@
-Fuel is a cross-platform GUI front-end to the excellent fossil SCM tool,
-implemented in Qt.
+Fuel is a cross-platform GUI front-end for the excellent Fossil SCM tool
+written in Qt.
-WWW: https://code.google.com/p/fuel-scm/
+WWW: https://fuel-scm.org/fossil/home