aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-03 17:57:52 +0800
committeryuri <yuri@FreeBSD.org>2018-07-03 17:57:52 +0800
commit794cd8a45ab29632018b66d45489ec806ef23acc (patch)
treeb0b0398d5cd05227787a7b3df09b21bd9430b623
parent3b780a082025904ad65194157127d5ef70e78137 (diff)
downloadfreebsd-ports-gnome-794cd8a45ab29632018b66d45489ec806ef23acc.tar.gz
freebsd-ports-gnome-794cd8a45ab29632018b66d45489ec806ef23acc.tar.zst
freebsd-ports-gnome-794cd8a45ab29632018b66d45489ec806ef23acc.zip
math/SoPlex: Update 3.1.1 -> 4.0.0
Also bump math/SCIP. Reported by: portscout
-rw-r--r--math/SCIP/Makefile3
-rw-r--r--math/SoPlex/Makefile2
-rw-r--r--math/SoPlex/distinfo6
-rw-r--r--math/SoPlex/files/patch-src_CMakeLists.txt23
-rw-r--r--math/SoPlex/pkg-plist185
5 files changed, 107 insertions, 112 deletions
diff --git a/math/SCIP/Makefile b/math/SCIP/Makefile
index b7f7d9e8c03d..98e708bbbc5f 100644
--- a/math/SCIP/Makefile
+++ b/math/SCIP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= SCIP
DISTVERSION= 5.0.1
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://scip.zib.de/download/release/
DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
@@ -26,4 +27,6 @@ EXTRACT_CMD= gtar
USE_LDCONFIG= yes
PLIST_SUB= SHL4=${DISTVERSION}.0 SHL2=${DISTVERSION:R}
+CXXFLAGS+= -I${LOCALBASE}/include/soplex
+
.include <bsd.port.mk>
diff --git a/math/SoPlex/Makefile b/math/SoPlex/Makefile
index b752ce2c5494..4ad530612a07 100644
--- a/math/SoPlex/Makefile
+++ b/math/SoPlex/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= SoPlex
-DISTVERSION= 3.1.1
+DISTVERSION= 4.0.0
CATEGORIES= math science
MASTER_SITES= http://soplex.zib.de/download/release/
DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
diff --git a/math/SoPlex/distinfo b/math/SoPlex/distinfo
index 05c4f3b6f308..8efe8991812c 100644
--- a/math/SoPlex/distinfo
+++ b/math/SoPlex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518427232
-SHA256 (soplex-3.1.1.tgz) = 138d8af2aa8570ba6a755c24aa1c047682433a740fb5d8729b90b61eeb812c66
-SIZE (soplex-3.1.1.tgz) = 963447
+TIMESTAMP = 1530610167
+SHA256 (soplex-4.0.0.tgz) = c1467370e2682762589463603b763d40b0dd6f22aee8ec9e98441a0e9326e016
+SIZE (soplex-4.0.0.tgz) = 960284
diff --git a/math/SoPlex/files/patch-src_CMakeLists.txt b/math/SoPlex/files/patch-src_CMakeLists.txt
index f1bc542ed2e3..561781886549 100644
--- a/math/SoPlex/files/patch-src_CMakeLists.txt
+++ b/math/SoPlex/files/patch-src_CMakeLists.txt
@@ -1,17 +1,15 @@
---- src/CMakeLists.txt.orig 2017-09-04 15:08:47 UTC
+--- src/CMakeLists.txt.orig 2018-07-03 09:33:09 UTC
+++ src/CMakeLists.txt
-@@ -159,20 +159,20 @@ set(headers
- wallclocktimer.h)
+@@ -158,7 +158,7 @@ set(headers
+ soplex/wallclocktimer.h)
- # create soplex library with pic
--add_library(libsoplex-pic STATIC ${sources})
-+add_library(libsoplex-pic SHARED ${sources})
- set_target_properties(libsoplex-pic PROPERTIES
+ # create soplex library with pic
+- add_library(libsoplex-pic STATIC ${sources})
++ add_library(libsoplex-pic SHARED ${sources})
+ set_target_properties(libsoplex-pic PROPERTIES
POSITION_INDEPENDENT_CODE on
VERSION ${SOPLEX_VERSION_MAJOR}.${SOPLEX_VERSION_MINOR}.${SOPLEX_VERSION_PATCH}.${SOPLEX_VERSION_SUB}
- SOVERSION ${SOPLEX_VERSION_MAJOR}.${SOPLEX_VERSION_MINOR})
--add_dependencies(libsoplex-pic soplex_update_githash)
-+#add_dependencies(libsoplex-pic soplex_update_githash)
+@@ -167,7 +167,7 @@ add_dependencies(libsoplex-pic soplex_up
target_link_libraries(libsoplex-pic ${libs})
# create soplex library without pic
@@ -20,8 +18,3 @@
set_target_properties(libsoplex PROPERTIES
VERSION ${SOPLEX_VERSION_MAJOR}.${SOPLEX_VERSION_MINOR}.${SOPLEX_VERSION_PATCH}.${SOPLEX_VERSION_SUB}
SOVERSION ${SOPLEX_VERSION_MAJOR}.${SOPLEX_VERSION_MINOR})
--add_dependencies(libsoplex soplex_update_githash)
-+#add_dependencies(libsoplex soplex_update_githash)
- target_link_libraries(libsoplex ${libs})
-
- # create soplex binary using library without pic
diff --git a/math/SoPlex/pkg-plist b/math/SoPlex/pkg-plist
index df160c9aa029..d7c2803032ce 100644
--- a/math/SoPlex/pkg-plist
+++ b/math/SoPlex/pkg-plist
@@ -1,98 +1,97 @@
bin/soplex
-include/array.h
-include/basevectors.h
-include/classarray.h
-include/clufactor.h
-include/clufactor_rational.h
-include/cring.h
-include/dataarray.h
-include/datahashtable.h
-include/datakey.h
-include/dataset.h
-include/didxset.h
-include/dsvector.h
-include/dsvectorbase.h
-include/dvector.h
-include/dvectorbase.h
-include/exceptions.h
-include/gzstream.h
-include/idlist.h
-include/idxset.h
-include/islist.h
-include/lpcol.h
-include/lpcolbase.h
-include/lpcolset.h
-include/lpcolsetbase.h
-include/lprow.h
-include/lprowbase.h
-include/lprowset.h
-include/lprowsetbase.h
-include/mpsinput.h
-include/nameset.h
-include/notimer.h
-include/random.h
-include/rational.h
-include/ratrecon.h
-include/slinsolver.h
-include/slinsolver_rational.h
-include/slufactor.h
-include/slufactor_rational.h
-include/sol.h
-include/solbase.h
include/soplex.h
-include/soplexlegacy.h
-include/sorter.h
-include/spxalloc.h
-include/spxautopr.h
-include/spxbasis.h
-include/spxboundflippingrt.h
-include/spxdantzigpr.h
-include/spxdefaultrt.h
-include/spxdefines.h
-include/spxdevexpr.h
-include/spxequilisc.h
-include/spxfastrt.h
-include/spxfileio.h
-include/spxgeometsc.h
-include/spxgithash.h
-include/spxharrisrt.h
-include/spxhybridpr.h
-include/spxid.h
-include/spxleastsqsc.h
-include/spxlp.h
-include/spxlpbase.h
-include/spxmainsm.h
-include/spxout.h
-include/spxparmultpr.h
-include/spxpricer.h
-include/spxratiotester.h
-include/spxscaler.h
-include/spxsimplifier.h
-include/spxsolver.h
-include/spxstarter.h
-include/spxsteepexpr.h
-include/spxsteeppr.h
-include/spxsumst.h
-include/spxvectorst.h
-include/spxweightpr.h
-include/spxweightst.h
-include/ssvector.h
-include/ssvectorbase.h
-include/statistics.h
-include/svector.h
-include/svectorbase.h
-include/svset.h
-include/svsetbase.h
-include/timer.h
-include/timerfactory.h
-include/unitvector.h
-include/unitvectorbase.h
-include/updatevector.h
-include/usertimer.h
-include/validation.h
-include/vector.h
-include/vectorbase.h
-include/wallclocktimer.h
+include/soplex/array.h
+include/soplex/basevectors.h
+include/soplex/classarray.h
+include/soplex/clufactor.h
+include/soplex/clufactor_rational.h
+include/soplex/cring.h
+include/soplex/dataarray.h
+include/soplex/datahashtable.h
+include/soplex/datakey.h
+include/soplex/dataset.h
+include/soplex/didxset.h
+include/soplex/dsvector.h
+include/soplex/dsvectorbase.h
+include/soplex/dvector.h
+include/soplex/dvectorbase.h
+include/soplex/exceptions.h
+include/soplex/gzstream.h
+include/soplex/idlist.h
+include/soplex/idxset.h
+include/soplex/islist.h
+include/soplex/lpcol.h
+include/soplex/lpcolbase.h
+include/soplex/lpcolset.h
+include/soplex/lpcolsetbase.h
+include/soplex/lprow.h
+include/soplex/lprowbase.h
+include/soplex/lprowset.h
+include/soplex/lprowsetbase.h
+include/soplex/mpsinput.h
+include/soplex/nameset.h
+include/soplex/notimer.h
+include/soplex/random.h
+include/soplex/rational.h
+include/soplex/ratrecon.h
+include/soplex/slinsolver.h
+include/soplex/slinsolver_rational.h
+include/soplex/slufactor.h
+include/soplex/slufactor_rational.h
+include/soplex/sol.h
+include/soplex/solbase.h
+include/soplex/sorter.h
+include/soplex/spxalloc.h
+include/soplex/spxautopr.h
+include/soplex/spxbasis.h
+include/soplex/spxboundflippingrt.h
+include/soplex/spxdantzigpr.h
+include/soplex/spxdefaultrt.h
+include/soplex/spxdefines.h
+include/soplex/spxdevexpr.h
+include/soplex/spxequilisc.h
+include/soplex/spxfastrt.h
+include/soplex/spxfileio.h
+include/soplex/spxgeometsc.h
+include/soplex/spxgithash.h
+include/soplex/spxharrisrt.h
+include/soplex/spxhybridpr.h
+include/soplex/spxid.h
+include/soplex/spxleastsqsc.h
+include/soplex/spxlp.h
+include/soplex/spxlpbase.h
+include/soplex/spxmainsm.h
+include/soplex/spxout.h
+include/soplex/spxparmultpr.h
+include/soplex/spxpricer.h
+include/soplex/spxratiotester.h
+include/soplex/spxscaler.h
+include/soplex/spxsimplifier.h
+include/soplex/spxsolver.h
+include/soplex/spxstarter.h
+include/soplex/spxsteepexpr.h
+include/soplex/spxsteeppr.h
+include/soplex/spxsumst.h
+include/soplex/spxvectorst.h
+include/soplex/spxweightpr.h
+include/soplex/spxweightst.h
+include/soplex/ssvector.h
+include/soplex/ssvectorbase.h
+include/soplex/statistics.h
+include/soplex/svector.h
+include/soplex/svectorbase.h
+include/soplex/svset.h
+include/soplex/svsetbase.h
+include/soplex/timer.h
+include/soplex/timerfactory.h
+include/soplex/unitvector.h
+include/soplex/unitvectorbase.h
+include/soplex/updatevector.h
+include/soplex/usertimer.h
+include/soplex/validation.h
+include/soplex/vector.h
+include/soplex/vectorbase.h
+include/soplex/wallclocktimer.h
lib/cmake/soplex/soplex-config.cmake
lib/cmake/soplex/soplex-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/soplex/soplex-targets.cmake