aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2016-10-19 18:20:01 +0800
committermartymac <martymac@FreeBSD.org>2016-10-19 18:20:01 +0800
commit7b8e7b9d59161d73d32ef1291fb2bf606635b639 (patch)
tree4c52dc8b90a4615aa5ceff71f1edecf1ea56c2d4
parent146c5239a687008c70ffd7ad5f8352e68084185a (diff)
downloadfreebsd-ports-gnome-7b8e7b9d59161d73d32ef1291fb2bf606635b639.tar.gz
freebsd-ports-gnome-7b8e7b9d59161d73d32ef1291fb2bf606635b639.tar.zst
freebsd-ports-gnome-7b8e7b9d59161d73d32ef1291fb2bf606635b639.zip
Update to 1.97.2
-rw-r--r--benchmarks/bonnie++/Makefile5
-rw-r--r--benchmarks/bonnie++/distinfo5
-rw-r--r--benchmarks/bonnie++/files/patch-bonnie++.cpp36
-rw-r--r--benchmarks/bonnie++/files/patch-duration.cpp15
-rw-r--r--benchmarks/bonnie++/files/patch-port.h.in32
-rw-r--r--benchmarks/bonnie++/files/patch-rand.h6
6 files changed, 20 insertions, 79 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index a127a8c29bb0..64969d45c699 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bonnie++
-PORTVERSION= 1.97
-PORTREVISION= 3
+PORTVERSION= 1.97.2
CATEGORIES= benchmarks
MASTER_SITES= http://www.coker.com.au/bonnie++/experimental/
@@ -17,8 +16,6 @@ GNU_CONFIGURE= yes
USES= shebangfix tar:tgz
SHEBANG_FILES= bon_csv2txt.in
-WRKSRC= ${WRKDIR}/${PORTNAME}-1.97.1
-
PORTDOCS= readme.html
OPTIONS_DEFINE= DOCS
diff --git a/benchmarks/bonnie++/distinfo b/benchmarks/bonnie++/distinfo
index 82a3cfc66714..771b192e48fc 100644
--- a/benchmarks/bonnie++/distinfo
+++ b/benchmarks/bonnie++/distinfo
@@ -1,2 +1,3 @@
-SHA256 (bonnie++-1.97.tgz) = 44f5a05937648a6526ba99354555d7d15f2dd392e55d3436f6746da6f6c35982
-SIZE (bonnie++-1.97.tgz) = 102604
+TIMESTAMP = 1476819885
+SHA256 (bonnie++-1.97.2.tgz) = 3f34a4c52ae9b2c3d493af8f794ba18cbf6732e9b76c3a4fa64549d95d914ce3
+SIZE (bonnie++-1.97.2.tgz) = 102533
diff --git a/benchmarks/bonnie++/files/patch-bonnie++.cpp b/benchmarks/bonnie++/files/patch-bonnie++.cpp
index 2d0cb9272723..550f66b03411 100644
--- a/benchmarks/bonnie++/files/patch-bonnie++.cpp
+++ b/benchmarks/bonnie++/files/patch-bonnie++.cpp
@@ -1,24 +1,6 @@
---- bonnie++.cpp.orig 2009-07-03 02:38:14 UTC
-+++ bonnie++.cpp
-@@ -73,7 +73,7 @@ public:
- void set_io_chunk_size(int size)
- { delete m_buf; pa_new(size, m_buf, m_buf_pa); m_io_chunk_size = size; }
- void set_file_chunk_size(int size)
-- { delete m_buf; m_buf = new char[__max(size, m_io_chunk_size)]; m_file_chunk_size = size; }
-+ { delete m_buf; m_buf = new char[max(size, m_io_chunk_size)]; m_file_chunk_size = size; }
-
- // Return the page-aligned version of the local buffer
- char *buf() { return m_buf_pa; }
-@@ -138,7 +138,7 @@ CGlobalItems::CGlobalItems(bool *exitFla
- , m_buf(NULL)
- , m_buf_pa(NULL)
- {
-- pa_new(__max(m_io_chunk_size, m_file_chunk_size), m_buf, m_buf_pa);
-+ pa_new(max(m_io_chunk_size, m_file_chunk_size), m_buf, m_buf_pa);
- SetName(".");
- }
-
-@@ -294,11 +294,7 @@ int main(int argc, char *argv[])
+--- bonnie++.cpp.orig 2016-06-30 09:41:41.000000000 +0000
++++ bonnie++.cpp 2016-10-18 19:52:40.381679719 +0000
+@@ -294,11 +294,7 @@
{
char *sbuf = _strdup(optarg);
char *size = strtok(sbuf, ":");
@@ -30,7 +12,7 @@
size = strtok(NULL, "");
if(size)
{
-@@ -384,17 +380,8 @@ int main(int argc, char *argv[])
+@@ -384,15 +380,6 @@
if(file_size % 1024 > 512)
file_size = file_size + 1024 - (file_size % 1024);
}
@@ -43,14 +25,10 @@
- usage();
- }
-#endif
-- globals.byte_io_size = __min(file_size, globals.byte_io_size);
-- globals.byte_io_size = __max(0, globals.byte_io_size);
-+ globals.byte_io_size = min(file_size, globals.byte_io_size);
-+ globals.byte_io_size = max(0, globals.byte_io_size);
+ globals.byte_io_size = min(file_size, globals.byte_io_size);
+ globals.byte_io_size = max(0, globals.byte_io_size);
- if(machine == NULL)
- {
-@@ -465,14 +452,6 @@ int main(int argc, char *argv[])
+@@ -465,14 +452,6 @@
&& (directory_max_size < directory_min_size || directory_max_size < 0
|| directory_min_size < 0) )
usage();
diff --git a/benchmarks/bonnie++/files/patch-duration.cpp b/benchmarks/bonnie++/files/patch-duration.cpp
index 7ba96bc261ed..3368eb7060de 100644
--- a/benchmarks/bonnie++/files/patch-duration.cpp
+++ b/benchmarks/bonnie++/files/patch-duration.cpp
@@ -1,12 +1,12 @@
---- duration.cpp.orig 2008-12-23 22:26:42 UTC
-+++ duration.cpp
+--- duration.cpp.orig 2016-06-30 09:41:58.000000000 +0000
++++ duration.cpp 2016-10-18 20:09:09.173611133 +0000
@@ -1,5 +1,3 @@
-using namespace std;
-
#include <stdlib.h>
#include "duration.h"
-@@ -20,6 +18,8 @@ using namespace std;
+@@ -20,6 +18,8 @@
#endif
#endif
@@ -15,12 +15,3 @@
Duration_Base::Duration_Base()
: m_start(0.0)
, m_max(0.0)
-@@ -38,7 +38,7 @@ double Duration_Base::stop()
- getTime(&tv);
- double ret;
- ret = tv - m_start;
-- m_max = __max(m_max, ret);
-+ m_max = max(m_max, ret);
- return ret;
- }
-
diff --git a/benchmarks/bonnie++/files/patch-port.h.in b/benchmarks/bonnie++/files/patch-port.h.in
index c9ec73421e9b..6c6566bdec7a 100644
--- a/benchmarks/bonnie++/files/patch-port.h.in
+++ b/benchmarks/bonnie++/files/patch-port.h.in
@@ -1,23 +1,6 @@
---- port.h.in.orig 2008-12-24 00:16:16 UTC
-+++ port.h.in
-@@ -4,12 +4,12 @@
- #include "conf.h"
-
- #ifndef HAVE_MIN_MAX
--#if defined(HAVE_ALGO_H) || defined(HAVE_ALGO)
--#ifdef HAVE_ALGO
-+#if defined(HAVE_ALGORITHM)
-+#include <algorithm>
-+#elif defined(HAVE_ALGO)
- #include <algo>
--#else
-+#elif defined(HAVE_ALGO_H)
- #include <algo.h>
--#endif
- #else
- #define min(XX,YY) ((XX) < (YY) ? (XX) : (YY))
- #define max(XX,YY) ((XX) > (YY) ? (XX) : (YY))
-@@ -19,14 +19,7 @@
+--- port.h.in.orig 2016-10-18 19:58:02.629657140 +0000
++++ port.h.in 2016-10-18 20:02:26.501248353 +0000
+@@ -6,14 +6,7 @@
@semun@
@bool@
@snprintf@
@@ -33,12 +16,3 @@
#if @true_false@
#define false 0
-@@ -49,8 +42,6 @@ typedef struct timeval TIMEVAL_TYPE;
- #endif
-
- typedef int FILE_TYPE;
--#define __min min
--#define __max max
- typedef unsigned int UINT;
- typedef unsigned long ULONG;
- typedef const char * PCCHAR;
diff --git a/benchmarks/bonnie++/files/patch-rand.h b/benchmarks/bonnie++/files/patch-rand.h
index 59753d937b43..24ee7dc54583 100644
--- a/benchmarks/bonnie++/files/patch-rand.h
+++ b/benchmarks/bonnie++/files/patch-rand.h
@@ -1,14 +1,14 @@
---- rand.h.orig 2003-01-08 19:52:53 UTC
-+++ rand.h
+--- rand.h.orig 2016-06-30 09:38:55.000000000 +0000
++++ rand.h 2016-10-18 20:04:31.159630423 +0000
@@ -1,11 +1,11 @@
#ifndef RAND_H
#define RAND_H
-using namespace std;
#include "port.h"
+ #include <string>
#include <stdio.h>
#include <stdlib.h>
- #include <string>
+using namespace std;
class Rand