aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-04 04:50:46 +0800
committerultima <ultima@FreeBSD.org>2017-08-04 04:50:46 +0800
commit7ca9560acd8fd482837099cf0f66ec7965428254 (patch)
treec9c46ec36fb99aee09787c9361de396f53f43a08
parent0c81eea5af3d31bdcf22acc5ccebf1f2ded8ea19 (diff)
downloadfreebsd-ports-gnome-7ca9560acd8fd482837099cf0f66ec7965428254.tar.gz
freebsd-ports-gnome-7ca9560acd8fd482837099cf0f66ec7965428254.tar.zst
freebsd-ports-gnome-7ca9560acd8fd482837099cf0f66ec7965428254.zip
* Updated to 0.9.13
* Sorted USES/OPTION section to better comply with PHB * Removed custom etcdir and changed to ETCDIR, added note in UPDATING Changelog: https://guacamole.incubator.apache.org/releases/0.9.13-incubating Reviewed by: matthew (mentor), mat Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D11817
-rw-r--r--UPDATING8
-rw-r--r--www/guacamole-client/Makefile60
-rw-r--r--www/guacamole-client/distinfo10
-rw-r--r--www/guacamole-client/files/pkg-message.in6
-rw-r--r--www/guacamole-client/pkg-plist10
5 files changed, 52 insertions, 42 deletions
diff --git a/UPDATING b/UPDATING
index 44e4ca23175b..b02b5848e9ce 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,14 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20170803:
+ AFFECTS: users of net/guacamole-client
+ AUTHOR: ultima@FreeBSD.org
+
+ As of version 0.9.13, the configuration directory for guacamole-client
+ has changed from /usr/local/etc/guacamole to
+ /usr/local/etc/guacamole-client.
+
+20170803:
AFFECTS: users of net/guacamole-server
AUTHOR: ultima@FreeBSD.org
diff --git a/www/guacamole-client/Makefile b/www/guacamole-client/Makefile
index 960468469fe3..c89ac8a72d1f 100644
--- a/www/guacamole-client/Makefile
+++ b/www/guacamole-client/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= guacamole-client
-PORTVERSION= 0.9.12
+PORTVERSION= 0.9.13
DISTVERSIONSUFFIX= -incubating
-PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES+= https://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo \
http://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo
@@ -19,30 +18,32 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/share/java/maven33/bin/mvn:devel/maven33
+USES= tar:xz
+USE_JAVA= yes
+JAVA_VERSION= 1.8+
+
USE_GITHUB= yes
GH_ACCOUNT= apache
GH_PROJECT= incubator-guacamole-client
MVN= mvn
MVN_ARGS= package -Duser.home=${WRKDIR}
-USE_JAVA= yes
-JAVA_VERSION= 1.8+
NO_ARCH= yes
-OPTIONS_SUB= yes
SUB_FILES= pkg-message
OPTIONS_DEFINE= MK_LINK SERVER TOMCAT
OPTIONS_DEFAULT= MK_LINK SERVER TOMCAT
+OPTIONS_SUB= yes
+
MK_LINK_DESC= Make sybolic links
-TOMCAT_RUN_DEPENDS= ${LOCALBASE}/apache-tomcat-8.0/bin/bootstrap.jar:www/tomcat8
+SERVER_DESC= Include Guacamole Server
TOMCAT_DESC= Use Tomcat as your servlet
+TOMCAT_RUN_DEPENDS= ${LOCALBASE}/apache-tomcat-8.0/bin/bootstrap.jar:www/tomcat8
SERVER_RUN_DEPENDS= guacd:net/guacamole-server
-SERVER_DESC= Include Guacamole Server
-GUACAMOLE_CONF= ${PREFIX}/etc/guacamole
-GUACAMOLE_DATA= ${PREFIX}/share/${PORTNAME}
+AUTH_EXTENSION= duo cas header ldap noauth
.include <bsd.port.pre.mk>
@@ -50,29 +51,28 @@ do-build:
cd ${WRKSRC} && ${MVN} ${MVN_ARGS}
do-install:
- @${MKDIR} ${STAGEDIR}${GUACAMOLE_DATA}
- @${MKDIR} ${STAGEDIR}${GUACAMOLE_CONF}
-
- @${CP} ${WRKSRC}/guacamole/target/guacamole-${DISTVERSIONFULL}.war \
- ${STAGEDIR}${GUACAMOLE_DATA}/guacamole.war
- @${CP} ${WRKSRC}/extensions/guacamole-auth-duo/target/guacamole-auth-duo-${DISTVERSIONFULL}.tar.gz \
- ${STAGEDIR}/${GUACAMOLE_DATA}/guacamole-auth-duo.tar.gz
- @${CP} ${WRKSRC}/extensions/guacamole-auth-jdbc/modules/guacamole-auth-jdbc-dist/target/guacamole-auth-jdbc-${DISTVERSIONFULL}.tar.gz \
- ${STAGEDIR}/${GUACAMOLE_DATA}/guacamole-auth-jdbc.tar.gz
- @${CP} ${WRKSRC}/extensions/guacamole-auth-ldap/target/guacamole-auth-ldap-${DISTVERSIONFULL}.tar.gz \
- ${STAGEDIR}/${GUACAMOLE_DATA}/guacamole-auth-ldap.tar.gz
- @${CP} ${WRKSRC}/extensions/guacamole-auth-noauth/target/guacamole-auth-noauth-${DISTVERSIONFULL}.tar.gz \
- ${STAGEDIR}/${GUACAMOLE_DATA}/guacamole-auth-noauth.tar.gz
-
-.if ${PORT_OPTIONS:MMK_LINK}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+
+ ${INSTALL_DATA} ${WRKSRC}/guacamole/target/guacamole-${DISTVERSIONFULL}.war \
+ ${STAGEDIR}${DATADIR}/guacamole.war
+.for i in ${AUTH_EXTENSION}
+ ${INSTALL_DATA} ${WRKSRC}/extensions/guacamole-auth-$i/target/guacamole-auth-$i-${DISTVERSIONFULL}.tar.gz \
+ ${STAGEDIR}/${DATADIR}/guacamole-auth-$i.tar.gz
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/extensions/guacamole-auth-jdbc/modules/guacamole-auth-jdbc-dist/target/guacamole-auth-jdbc-${DISTVERSIONFULL}.tar.gz \
+ ${STAGEDIR}/${DATADIR}/guacamole-auth-jdbc.tar.gz
+ ${INSTALL_DATA} ${FILESDIR}/user-mapping.xml.sample ${STAGEDIR}${ETCDIR}/
+ ${INSTALL_DATA} ${FILESDIR}/logback.xml.sample ${STAGEDIR}${ETCDIR}/
+ ${INSTALL_DATA} ${FILESDIR}/guacamole.properties.sample ${STAGEDIR}${ETCDIR}/
+
+do-install-MK_LINK-on:
@${MKDIR} ${STAGEDIR}/root
+ ${RLN} ${STAGEDIR}/${ETCDIR} ${STAGEDIR}/root/.guacamole
+.if ${PORT_OPTIONS:MTOMCAT}
@${MKDIR} ${STAGEDIR}${PREFIX}/apache-tomcat-8.0/webapps
- @${LN} -s ..${GUACAMOLE_CONF} ${STAGEDIR}/root/.guacamole
- @${LN} -s ../../share/${PORTNAME}/guacamole.war \
- ${STAGEDIR}${PREFIX}/apache-tomcat-8.0/webapps/
+ ${RLN} ${STAGEDIR}${DATADIR}/guacamole.war \
+ ${STAGEDIR}${PREFIX}/apache-tomcat-8.0/webapps
.endif
- @${CP} ${FILESDIR}/user-mapping.xml.sample ${STAGEDIR}${GUACAMOLE_CONF}/
- @${CP} ${FILESDIR}/logback.xml.sample ${STAGEDIR}${GUACAMOLE_CONF}/
- @${CP} ${FILESDIR}/guacamole.properties.sample ${STAGEDIR}${GUACAMOLE_CONF}/
.include <bsd.port.post.mk>
diff --git a/www/guacamole-client/distinfo b/www/guacamole-client/distinfo
index ed5f61463f25..7dcb4e9cabe1 100644
--- a/www/guacamole-client/distinfo
+++ b/www/guacamole-client/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1491448771
-SHA256 (guacamole-client/repository-0.9.12.tar.gz) = 2177c05a99d4727c73416d828281cd3b8c909281ef63b86b8d7c133b6700957f
-SIZE (guacamole-client/repository-0.9.12.tar.gz) = 57553854
-SHA256 (guacamole-client/apache-incubator-guacamole-client-0.9.12-incubating_GH0.tar.gz) = 860236750fdc73a7275f06289d089546d5eeae7329a3c0f84598ee5ef134b121
-SIZE (guacamole-client/apache-incubator-guacamole-client-0.9.12-incubating_GH0.tar.gz) = 1680786
+TIMESTAMP = 1501628487
+SHA256 (guacamole-client/repository-0.9.13.tar.xz) = 2e35f8dc60ba5cc38efe9e44155cd80d48f27418989edc56a4dc95eaf198368d
+SIZE (guacamole-client/repository-0.9.13.tar.xz) = 51868452
+SHA256 (guacamole-client/apache-incubator-guacamole-client-0.9.13-incubating_GH0.tar.gz) = ca5e0ddf952dea3faff2b41e87f5b47b2bf235c8640d4193dcd6b3611b9d8ebd
+SIZE (guacamole-client/apache-incubator-guacamole-client-0.9.13-incubating_GH0.tar.gz) = 5766007
diff --git a/www/guacamole-client/files/pkg-message.in b/www/guacamole-client/files/pkg-message.in
index a63df32efdfa..bcf8f3fd06fc 100644
--- a/www/guacamole-client/files/pkg-message.in
+++ b/www/guacamole-client/files/pkg-message.in
@@ -1,6 +1,6 @@
- Guacamole-client requires authentecation to start.
- cp %%PREFIX%%/etc/guacamole/user-mapping.xml.sample \
- %%PREFIX%%/etc/guacamole/user-mapping.xml
+ Guacamole-client requires authentication to start.
+ cp %%ETCDIR%%/user-mapping.xml.sample \
+ %%ETCDIR%%/user-mapping.xml
Once tomcat8 and guacd are running
http://localhost:8080/guacamole
diff --git a/www/guacamole-client/pkg-plist b/www/guacamole-client/pkg-plist
index 9906a65c278c..e01eca042c0a 100644
--- a/www/guacamole-client/pkg-plist
+++ b/www/guacamole-client/pkg-plist
@@ -1,9 +1,11 @@
%%MK_LINK%%/root/.guacamole
-%%TOMCAT%%apache-tomcat-8.0/webapps/guacamole.war
-etc/guacamole/guacamole.properties.sample
-etc/guacamole/logback.xml.sample
-etc/guacamole/user-mapping.xml.sample
+%%MK_LINK%%%%TOMCAT%%apache-tomcat-8.0/webapps/guacamole.war
+%%ETCDIR%%/guacamole.properties.sample
+%%ETCDIR%%/logback.xml.sample
+%%ETCDIR%%/user-mapping.xml.sample
%%DATADIR%%/guacamole-auth-duo.tar.gz
+%%DATADIR%%/guacamole-auth-cas.tar.gz
+%%DATADIR%%/guacamole-auth-header.tar.gz
%%DATADIR%%/guacamole-auth-jdbc.tar.gz
%%DATADIR%%/guacamole-auth-ldap.tar.gz
%%DATADIR%%/guacamole-auth-noauth.tar.gz