aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-06-09 11:20:54 +0800
committerkris <kris@FreeBSD.org>2004-06-09 11:20:54 +0800
commit7d25291daffb923c51087dfe5f875653c01e6d91 (patch)
treecfb01ed78a489776d79aa64616df3e70a833e068
parent8a11fc5fe6bb60e9ed07eaf0a0ec05fd634e6eee (diff)
downloadfreebsd-ports-gnome-7d25291daffb923c51087dfe5f875653c01e6d91.tar.gz
freebsd-ports-gnome-7d25291daffb923c51087dfe5f875653c01e6d91.tar.zst
freebsd-ports-gnome-7d25291daffb923c51087dfe5f875653c01e6d91.zip
Fix package build by using explicit paths in RUN_DEPENDS
-rw-r--r--ports-mgmt/port-authoring-tools/Makefile8
-rw-r--r--ports-mgmt/port-maintenance-tools/Makefile14
-rw-r--r--sysutils/port-authoring-tools/Makefile8
-rw-r--r--sysutils/port-maintenance-tools/Makefile14
4 files changed, 22 insertions, 22 deletions
diff --git a/ports-mgmt/port-authoring-tools/Makefile b/ports-mgmt/port-authoring-tools/Makefile
index 90d00da88487..ec3939be0205 100644
--- a/ports-mgmt/port-authoring-tools/Makefile
+++ b/ports-mgmt/port-authoring-tools/Makefile
@@ -17,10 +17,10 @@ COMMENT= "meta-port" for tools to test and submit changes to ports
# note: portlint is brought in by porttools
RUN_DEPENDS= \
- cvsup:${PORTSDIR}/net/cvsup-without-gui \
- fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
- libchk:${PORTSDIR}/sysutils/libchk \
- port:${PORTSDIR}/devel/porttools
+ ${LOCALBASE}/bin/cvsup:${PORTSDIR}/net/cvsup-without-gui \
+ ${LOCALBASE}/bin/fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
+ ${LOCALBASE}/sbin/libchk:${PORTSDIR}/sysutils/libchk \
+ ${LOCALBASE}/bin/port:${PORTSDIR}/devel/porttools
NO_BUILD= yes
diff --git a/ports-mgmt/port-maintenance-tools/Makefile b/ports-mgmt/port-maintenance-tools/Makefile
index 849c61047575..4e1b575c9870 100644
--- a/ports-mgmt/port-maintenance-tools/Makefile
+++ b/ports-mgmt/port-maintenance-tools/Makefile
@@ -17,13 +17,13 @@ COMMENT= "meta-port" for administrative tools to maintain ports
# note: portuprade is brought in by pkg_cutleaves
RUN_DEPENDS= \
- cvsup:${PORTSDIR}/net/cvsup-without-gui \
- fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
- pkg_cutleaves:${PORTSDIR}/sysutils/pkg_cutleaves \
- pkg_tree:${PORTSDIR}/sysutils/pkg_tree \
- porteasy:${PORTSDIR}/misc/porteasy \
- portell:${PORTSDIR}/misc/portell \
- portdowngrade:${PORTSDIR}/sysutils/portdowngrade
+ ${LOCALBASE}/bin/cvsup:${PORTSDIR}/net/cvsup-without-gui \
+ ${LOCALBASE}/bin/fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
+ ${LOCALBASE}/sbin/pkg_cutleaves:${PORTSDIR}/sysutils/pkg_cutleaves \
+ ${LOCALBASE}/bin/pkg_tree:${PORTSDIR}/sysutils/pkg_tree \
+ ${LOCALBASE}/bin/porteasy:${PORTSDIR}/misc/porteasy \
+ ${LOCALBASE}/bin/portell:${PORTSDIR}/misc/portell \
+ ${LOCALBASE}/sbin/portdowngrade:${PORTSDIR}/sysutils/portdowngrade
NO_BUILD= yes
diff --git a/sysutils/port-authoring-tools/Makefile b/sysutils/port-authoring-tools/Makefile
index 90d00da88487..ec3939be0205 100644
--- a/sysutils/port-authoring-tools/Makefile
+++ b/sysutils/port-authoring-tools/Makefile
@@ -17,10 +17,10 @@ COMMENT= "meta-port" for tools to test and submit changes to ports
# note: portlint is brought in by porttools
RUN_DEPENDS= \
- cvsup:${PORTSDIR}/net/cvsup-without-gui \
- fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
- libchk:${PORTSDIR}/sysutils/libchk \
- port:${PORTSDIR}/devel/porttools
+ ${LOCALBASE}/bin/cvsup:${PORTSDIR}/net/cvsup-without-gui \
+ ${LOCALBASE}/bin/fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
+ ${LOCALBASE}/sbin/libchk:${PORTSDIR}/sysutils/libchk \
+ ${LOCALBASE}/bin/port:${PORTSDIR}/devel/porttools
NO_BUILD= yes
diff --git a/sysutils/port-maintenance-tools/Makefile b/sysutils/port-maintenance-tools/Makefile
index 849c61047575..4e1b575c9870 100644
--- a/sysutils/port-maintenance-tools/Makefile
+++ b/sysutils/port-maintenance-tools/Makefile
@@ -17,13 +17,13 @@ COMMENT= "meta-port" for administrative tools to maintain ports
# note: portuprade is brought in by pkg_cutleaves
RUN_DEPENDS= \
- cvsup:${PORTSDIR}/net/cvsup-without-gui \
- fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
- pkg_cutleaves:${PORTSDIR}/sysutils/pkg_cutleaves \
- pkg_tree:${PORTSDIR}/sysutils/pkg_tree \
- porteasy:${PORTSDIR}/misc/porteasy \
- portell:${PORTSDIR}/misc/portell \
- portdowngrade:${PORTSDIR}/sysutils/portdowngrade
+ ${LOCALBASE}/bin/cvsup:${PORTSDIR}/net/cvsup-without-gui \
+ ${LOCALBASE}/bin/fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
+ ${LOCALBASE}/sbin/pkg_cutleaves:${PORTSDIR}/sysutils/pkg_cutleaves \
+ ${LOCALBASE}/bin/pkg_tree:${PORTSDIR}/sysutils/pkg_tree \
+ ${LOCALBASE}/bin/porteasy:${PORTSDIR}/misc/porteasy \
+ ${LOCALBASE}/bin/portell:${PORTSDIR}/misc/portell \
+ ${LOCALBASE}/sbin/portdowngrade:${PORTSDIR}/sysutils/portdowngrade
NO_BUILD= yes