aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-05-17 06:26:00 +0800
committerrakuco <rakuco@FreeBSD.org>2014-05-17 06:26:00 +0800
commit80b3cb67928f6c00b149e657a354a3083e66c9a9 (patch)
tree204e5031045ad50266c81e046fc830463dc1805a
parent9274dc4f79ac6365e91452176aa7371933e60951 (diff)
downloadfreebsd-ports-gnome-80b3cb67928f6c00b149e657a354a3083e66c9a9.tar.gz
freebsd-ports-gnome-80b3cb67928f6c00b149e657a354a3083e66c9a9.tar.zst
freebsd-ports-gnome-80b3cb67928f6c00b149e657a354a3083e66c9a9.zip
Stop passing -fcheck-new to the compiler.
This flag is GCC specific, and there should be no big loss with its removal. This commit fixes the build on HEAD (clang 3.4). MFH: 2014Q2
-rw-r--r--textproc/xmlppm/Makefile1
-rw-r--r--textproc/xmlppm/files/patch-src__Makefile.in11
2 files changed, 12 insertions, 0 deletions
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
index 20c780ce1c7c..575b14a6a99b 100644
--- a/textproc/xmlppm/Makefile
+++ b/textproc/xmlppm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlppm
PORTVERSION= 0.98.3
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-src/${PORTVERSION} \
http://www.cs.cornell.edu/People/jcheney/xmlppm/
diff --git a/textproc/xmlppm/files/patch-src__Makefile.in b/textproc/xmlppm/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..b62ef88b3676
--- /dev/null
+++ b/textproc/xmlppm/files/patch-src__Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2014-05-17 01:23:05.000000000 +0300
++++ src/Makefile.in 2014-05-17 01:23:13.000000000 +0300
+@@ -176,7 +176,7 @@
+ xmlppm_SOURCES = xmlppm.cpp Args.cpp Args.h Version.h
+ xmlppm_LDADD = libxmlppm.a
+ AM_CFLAGS = -Wall -ansi -pedantic -Wno-sign-compare -Wno-unknown-pragmas -Wno-conversion
+-AM_CXXFLAGS = -fno-exceptions -fno-rtti -fcheck-new -Wall -ansi -pedantic -Wno-sign-compare -Wno-unknown-pragmas -Wno-conversion
++AM_CXXFLAGS = -fno-exceptions -fno-rtti -Wall -ansi -pedantic -Wno-sign-compare -Wno-unknown-pragmas -Wno-conversion
+ xmlunppm_SOURCES = xmlunppm.cpp Args.cpp Args.h Version.h
+ xmlunppm_LDADD = libxmlppm.a
+ lib_LIBRARIES = libxmlppm.a