aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-03-04 22:57:30 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2020-03-04 22:57:30 +0800
commit84409db9ad080b8d84b8ab60b86553e71372e946 (patch)
tree44d1c9f03881c851aad3470464b8f0e9853963c1
parent5fcc56c4ab02b37929976b09cf4cc295d813cbd9 (diff)
downloadfreebsd-ports-gnome-84409db9ad080b8d84b8ab60b86553e71372e946.tar.gz
freebsd-ports-gnome-84409db9ad080b8d84b8ab60b86553e71372e946.tar.zst
freebsd-ports-gnome-84409db9ad080b8d84b8ab60b86553e71372e946.zip
games/adonthell: Allow build with Python 3
Waste's Edge seems to work fine with it too.
-rw-r--r--games/adonthell/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 8a3e6edfe5c9..c0cbd9f62261 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -4,6 +4,7 @@
PORTNAME= adonthell
PORTVERSION= 0.3.8
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SAVANNAH
DISTFILES= ${PORTNAME}-src-${PORTVERSION}${EXTRACT_SUFX}
@@ -18,12 +19,13 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
-USES= gettext gmake localbase pkgconfig python:2.7 sdl
+USES= gettext gmake localbase pkgconfig python sdl
USE_SDL= mixer2 ttf2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-py-debug --disable-pyc \
- --with-python=${PYTHON_CMD} \
- --with-py-libs="-lpython${PYTHON_VER}"
+CONFIGURE_ARGS= --disable-py-debug \
+ --disable-pyc \
+ --with-py-libs="$$(${PYTHON_CMD}-config --ldflags)" \
+ --with-python=${PYTHON_CMD}
PLIST_DIRS= ${DATADIR}/games
PLIST_FILES= bin/adonthell \