aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-04 19:00:35 +0800
committerbapt <bapt@FreeBSD.org>2014-04-04 19:00:35 +0800
commit85d581df29d0049b3f92e4b73449f0d2257b6a64 (patch)
tree5d89e5db94f86f485ea86315f71625dc2aa35874
parentf89ad4ba0a69af6393fb2e6298283455b76644f4 (diff)
downloadfreebsd-ports-gnome-85d581df29d0049b3f92e4b73449f0d2257b6a64.tar.gz
freebsd-ports-gnome-85d581df29d0049b3f92e4b73449f0d2257b6a64.tar.zst
freebsd-ports-gnome-85d581df29d0049b3f92e4b73449f0d2257b6a64.zip
Do not leak stagedir in the generated binary
Remove now useless pre-su target MFH: 2014Q2
-rw-r--r--news/sn/Makefile8
-rw-r--r--news/sn/files/patch-Makefile21
2 files changed, 25 insertions, 4 deletions
diff --git a/news/sn/Makefile b/news/sn/Makefile
index 030f8e8a9a62..ab43637b2010 100644
--- a/news/sn/Makefile
+++ b/news/sn/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sn
PORTVERSION= 0.3.8
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= http://www.infa.abo.fi/~patrik/sn/files/ \
http://home.arcor.de/teambushido/fbsd_ports/ \
@@ -13,9 +14,8 @@ COMMENT= Small news system for small sites serving
LICENSE= GPLv2
-USES= gmake
-USE_BZIP2= yes
-MAKE_ARGS+= PREFIX="${STAGEDIR}${PREFIX}" LD="${CC}" CC="${CC}"
+USES= gmake tar:bzip2
+MAKE_ARGS+= PREFIX="${PREFIX}" LD="${CC}" CC="${CC}"
PORTDOCS= README CHANGES FAQ INSTALL INTERNALS \
THANKS TODO INSTALL.notes INSTALL.notes2 \
@@ -30,7 +30,7 @@ post-patch:
s|-g -Wall -pedantic -O|${CFLAGS} -Wall -pedantic|' \
${WRKSRC}/Makefile
-pre-su-install:
+pre-install:
@${MKDIR} ${STAGEDIR}/var/spool/news
post-install:
diff --git a/news/sn/files/patch-Makefile b/news/sn/files/patch-Makefile
new file mode 100644
index 000000000000..17a8eea6af9b
--- /dev/null
+++ b/news/sn/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- ./Makefile.orig 2014-04-04 12:17:36.551829000 +0200
++++ ./Makefile 2014-04-04 12:20:01.852681999 +0200
+@@ -144,12 +144,12 @@
+ strip: $(BINS)
+ strip $^
+
+-install: all #$(SNROOT) $(BINDIR) $(MANDIR)/man8 # commented out so make -n install works without the dirs
+- $(INSTALL) $(PROGS) $(BINDIR)
+- $(INSTALL) *.8 $(MANDIR)/man8
+- -cd $(BINDIR); rm -f sncat; ln -s snscan sncat
+- -cd $(BINDIR); rm -f sncancel; ln -s snscan sncancel
+- -cd $(BINDIR); rm -f snstore; ln -s snsend snstore
++install: all #$(SNROOT) $(DESTDIR)$(BINDIR) $(DESTDIR)$(MANDIR)/man8 # commented out so make -n install works without the dirs
++ $(INSTALL) $(PROGS) $(DESTDIR)$(BINDIR)
++ $(INSTALL) *.8 $(DESTDIR)$(MANDIR)/man8
++ -cd $(DESTDIR)$(BINDIR); rm -f sncat; ln -s snscan sncat
++ -cd $(DESTDIR)$(BINDIR); rm -f sncancel; ln -s snscan sncancel
++ -cd $(DESTDIR)$(BINDIR); rm -f snstore; ln -s snsend snstore
+
+ spoolclean:
+ @echo -n "make $@ will wipe out your news spool! Sure? [y/n] "