aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2017-05-13 21:16:18 +0800
committermandree <mandree@FreeBSD.org>2017-05-13 21:16:18 +0800
commit86fa6a170b4ebfce89af3612e196ad0d27d53c42 (patch)
treedb488a197190f2e515318e5c3f884b0700300317
parent309eb104c2485fef042eca3d0c5b2969032af97c (diff)
downloadfreebsd-ports-gnome-86fa6a170b4ebfce89af3612e196ad0d27d53c42.tar.gz
freebsd-ports-gnome-86fa6a170b4ebfce89af3612e196ad0d27d53c42.tar.zst
freebsd-ports-gnome-86fa6a170b4ebfce89af3612e196ad0d27d53c42.zip
security/putty: install icon and .desktop file
PR: 219095 Submitted by: ehaupt@
-rw-r--r--security/putty/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 9c37de968389..2e0693b40a3d 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -2,6 +2,7 @@
PORTNAME= putty
PORTVERSION= 0.69
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/${PORTVERSION}/ \
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
@@ -39,7 +40,14 @@ USE_XORG= x11
PLIST_FILES+= bin/pageant bin/pterm bin/putty bin/puttytel
PLIST_FILES+= man/man1/pageant.1.gz man/man1/pterm.1.gz man/man1/putty.1.gz man/man1/puttytel.1.gz
+PLIST_FILES+= share/pixmaps/putty.ico
MAKE_ARGS+= PUTTY_WITH_GTK=yes GTK_CONFIG="pkg-config gtk+-3.0 x11 --cflags"
+DESKTOP_ENTRIES="PuTTY" \
+ "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "${PORTNAME}" \
+ "" \
+ false
.else
MAKE_ARGS+= GTK_CONFIG=:
.endif
@@ -73,4 +81,9 @@ post-patch:
s,make,${MAKE_CMD},'\
${WRKSRC}/${MAKEFILE}
+post-install-GTK3-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/../windows/putty.ico \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
.include <bsd.port.mk>