aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2017-01-01 03:51:34 +0800
committeradamw <adamw@FreeBSD.org>2017-01-01 03:51:34 +0800
commit879853ef7ad88ca7155996a7f25038b418ce3764 (patch)
tree806c8bf5953aa6382a19618cd3e756386bdbf5cb
parent990a12edb8c95236362bee3ffed8eaa96b6d33c9 (diff)
downloadfreebsd-ports-gnome-879853ef7ad88ca7155996a7f25038b418ce3764.tar.gz
freebsd-ports-gnome-879853ef7ad88ca7155996a7f25038b418ce3764.tar.zst
freebsd-ports-gnome-879853ef7ad88ca7155996a7f25038b418ce3764.zip
Purge checks for perl < 5.20. For p5-Net, remove the IPV6 knob which only
affected 5.18 and lower.
-rw-r--r--devel/p5-Alien-SDL/Makefile12
-rw-r--r--devel/p5-CPAN-Changes/Makefile9
-rw-r--r--devel/p5-CPAN-Meta-Check/Makefile9
-rw-r--r--devel/p5-Class-C3-Adopt-NEXT/Makefile9
-rw-r--r--devel/p5-Config-Any/Makefile13
-rw-r--r--devel/p5-Config-IniFiles/Makefile9
-rw-r--r--devel/p5-IO-Pipely/Makefile8
-rw-r--r--devel/p5-Module-Build/Makefile5
-rw-r--r--devel/p5-Module-CPANTS-Analyse/Makefile9
-rw-r--r--devel/p5-Module-Load-Conditional/Makefile9
-rw-r--r--devel/p5-POE-Test-Loops/Makefile9
-rw-r--r--devel/p5-Package-DeprecationManager/Makefile9
-rw-r--r--devel/p5-Parallel-ForkManager/Makefile8
-rw-r--r--mail/p5-Email-Abstract/Makefile12
-rw-r--r--mail/p5-Email-FolderType/Makefile11
-rw-r--r--net/p5-Kafka/Makefile9
-rw-r--r--net/p5-Net-Whois-Raw/Makefile9
-rw-r--r--net/p5-Net/Makefile11
-rw-r--r--security/p5-POE-Component-SSLify/Makefile8
-rw-r--r--security/p5-Unix-Passwd-File/Makefile9
-rw-r--r--textproc/p5-Lingua-EN-MatchNames/Makefile9
-rw-r--r--textproc/p5-Perl-Lint/Makefile13
-rw-r--r--textproc/p5-Pod-Elemental/Makefile9
-rw-r--r--textproc/p5-Pod-Tree/Makefile8
-rw-r--r--textproc/p5-RDF-Trine/Makefile9
-rw-r--r--www/p5-Catalyst-Action-REST/Makefile10
-rw-r--r--www/p5-HTML-FormHandler/Makefile9
-rw-r--r--www/p5-Mojolicious-Plugin-SetUserGroup/Makefile9
-rw-r--r--www/p5-WWW-Scraper-ISBN/Makefile12
-rw-r--r--x11-toolkits/p5-Alien-wxWidgets/Makefile12
30 files changed, 47 insertions, 240 deletions
diff --git a/devel/p5-Alien-SDL/Makefile b/devel/p5-Alien-SDL/Makefile
index 71817dd89410..256cbf2dbf73 100644
--- a/devel/p5-Alien-SDL/Makefile
+++ b/devel/p5-Alien-SDL/Makefile
@@ -15,7 +15,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS:= ${RUN_DEPENDS} \
p5-Text-Patch>=1.4:textproc/p5-Text-Patch
-RUN_DEPENDS= p5-File-Which>=0:sysutils/p5-File-Which \
+RUN_DEPENDS= p5-Archive-Extract>=0:archivers/p5-Archive-Extract \
+ p5-File-Which>=0:sysutils/p5-File-Which \
p5-File-ShareDir>=0:devel/p5-File-ShareDir \
p5-Capture-Tiny>=0:devel/p5-Capture-Tiny
@@ -24,11 +25,4 @@ USE_PERL5= modbuild
USE_SDL= gfx image mixer pango sdl ttf
CONFIGURE_ARGS= --with-sdl-config=${SDL_CONFIG}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Archive-Extract>=0:archivers/p5-Archive-Extract
-RUN_DEPENDS+= p5-Archive-Extract>=0:archivers/p5-Archive-Extract
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Changes/Makefile b/devel/p5-CPAN-Changes/Makefile
index 269ecfc66eb6..170d4d5d87b4 100644
--- a/devel/p5-CPAN-Changes/Makefile
+++ b/devel/p5-CPAN-Changes/Makefile
@@ -18,11 +18,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-version>=0.99.06:devel/p5-version
-RUN_DEPENDS+= p5-version>=0.99.06:devel/p5-version
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Meta-Check/Makefile b/devel/p5-CPAN-Meta-Check/Makefile
index fb219f70ebec..5e2024ac022b 100644
--- a/devel/p5-CPAN-Meta-Check/Makefile
+++ b/devel/p5-CPAN-Meta-Check/Makefile
@@ -21,11 +21,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-CPAN-Meta>=2.132830:devel/p5-CPAN-Meta
-RUN_DEPENDS+= p5-CPAN-Meta>=2.132830:devel/p5-CPAN-Meta
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-C3-Adopt-NEXT/Makefile b/devel/p5-Class-C3-Adopt-NEXT/Makefile
index 2719db5abe69..bf03b26c13ce 100644
--- a/devel/p5-Class-C3-Adopt-NEXT/Makefile
+++ b/devel/p5-Class-C3-Adopt-NEXT/Makefile
@@ -20,11 +20,4 @@ TEST_DEPENDS= p5-Test-Exception>=0.27:devel/p5-Test-Exception
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-Any/Makefile b/devel/p5-Config-Any/Makefile
index 79b2ce94a86b..b53af38e8b57 100644
--- a/devel/p5-Config-Any/Makefile
+++ b/devel/p5-Config-Any/Makefile
@@ -13,6 +13,9 @@ COMMENT= Load class configuration data from a number of file formats
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
+BUILD_DEPENDS= p5-Module-Pluggable>=3.6:devel/p5-Module-Pluggable
+RUN_DEPENDS= p5-Module-Pluggable>=3.6:devel/p5-Module-Pluggable
+
OPTIONS_DEFINE= GENERAL INI JSON XML YAML
OPTIONS_DEFAULT=GENERAL INI JSON XML YAML
@@ -33,12 +36,4 @@ XML_RUN_DEPENDS= p5-XML-Simple>=0:textproc/p5-XML-Simple
YAML_BUILD_DEPENDS= p5-YAML-LibYAML>=0:textproc/p5-YAML-LibYAML
YAML_RUN_DEPENDS= p5-YAML-LibYAML>=0:textproc/p5-YAML-LibYAML
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-# Module::Pluggable was first released with perl v5.8.9 and removed from v5.19.0
-BUILD_DEPENDS+= p5-Module-Pluggable>=3.6:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>=3.6:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-IniFiles/Makefile b/devel/p5-Config-IniFiles/Makefile
index 91eebe47fbaa..ee2024ef657a 100644
--- a/devel/p5-Config-IniFiles/Makefile
+++ b/devel/p5-Config-IniFiles/Makefile
@@ -17,11 +17,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= modbuild
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-Pipely/Makefile b/devel/p5-IO-Pipely/Makefile
index 02fb5a755a0e..22adad091756 100644
--- a/devel/p5-IO-Pipely/Makefile
+++ b/devel/p5-IO-Pipely/Makefile
@@ -18,10 +18,4 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-TEST_DEPENDS= p5-Scalar-List-Utils>=1.29:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 33be7b1229fe..4827b3dbc71f 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -29,11 +29,6 @@ USE_PERL5= modbuild
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Test-Harness>=3.29:devel/p5-Test-Harness
-RUN_DEPENDS+= p5-Test-Harness>=3.29:devel/p5-Test-Harness
-.endif
-
.if ${PERL_LEVEL} < 502105
BUILD_DEPENDS+= p5-CPAN-Meta>=2.142060:devel/p5-CPAN-Meta
RUN_DEPENDS+= p5-CPAN-Meta>=2.142060:devel/p5-CPAN-Meta
diff --git a/devel/p5-Module-CPANTS-Analyse/Makefile b/devel/p5-Module-CPANTS-Analyse/Makefile
index b29fc28e4774..847fc51d93c2 100644
--- a/devel/p5-Module-CPANTS-Analyse/Makefile
+++ b/devel/p5-Module-CPANTS-Analyse/Makefile
@@ -34,11 +34,4 @@ BUILD_DEPENDS+= p5-ExtUtils-MakeMaker-CPANfile>=0.06:devel/p5-ExtUtils-MakeMaker
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-CPAN-Meta>=2.133380:devel/p5-CPAN-Meta
-RUN_DEPENDS+= p5-CPAN-Meta>=2.133380:devel/p5-CPAN-Meta
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Load-Conditional/Makefile b/devel/p5-Module-Load-Conditional/Makefile
index 34fe299a8a12..4de00b3cc317 100644
--- a/devel/p5-Module-Load-Conditional/Makefile
+++ b/devel/p5-Module-Load-Conditional/Makefile
@@ -16,11 +16,4 @@ LICENSE_COMB= dual
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS= p5-Module-Load>=0.28:devel/p5-Module-Load
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Test-Loops/Makefile b/devel/p5-POE-Test-Loops/Makefile
index 4eb6e3f18321..b9c4586521c4 100644
--- a/devel/p5-POE-Test-Loops/Makefile
+++ b/devel/p5-POE-Test-Loops/Makefile
@@ -18,11 +18,4 @@ LICENSE_COMB= dual
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Test-Simple>=1.001002:devel/p5-Test-Simple
-RUN_DEPENDS+= p5-Test-Simple>=1.001002:devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Package-DeprecationManager/Makefile b/devel/p5-Package-DeprecationManager/Makefile
index 82f4bb44f6e8..fbcfc17fb606 100644
--- a/devel/p5-Package-DeprecationManager/Makefile
+++ b/devel/p5-Package-DeprecationManager/Makefile
@@ -24,11 +24,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Parallel-ForkManager/Makefile b/devel/p5-Parallel-ForkManager/Makefile
index 1a0e528d240c..80d0fa32d85e 100644
--- a/devel/p5-Parallel-ForkManager/Makefile
+++ b/devel/p5-Parallel-ForkManager/Makefile
@@ -19,10 +19,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-TEST_DEPENDS+= p5-Test-Simple>=1.001002:devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Abstract/Makefile b/mail/p5-Email-Abstract/Makefile
index 5ca37ad1a317..4f4b67e435db 100644
--- a/mail/p5-Email-Abstract/Makefile
+++ b/mail/p5-Email-Abstract/Makefile
@@ -14,17 +14,11 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
RUN_DEPENDS= p5-Email-Simple>=1.998:mail/p5-Email-Simple \
- p5-MRO-Compat>=0:devel/p5-MRO-Compat
+ p5-MRO-Compat>=0:devel/p5-MRO-Compat \
+ p5-Module-Pluggable>1.5:devel/p5-Module-Pluggable
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>1.5:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>1.5:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-FolderType/Makefile b/mail/p5-Email-FolderType/Makefile
index df08317b97d3..68206c946288 100644
--- a/mail/p5-Email-FolderType/Makefile
+++ b/mail/p5-Email-FolderType/Makefile
@@ -14,17 +14,12 @@ COMMENT= Determine the type of a mail folder
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
+BUILD_DEPENDS= p5-Module-Pluggable>0:devel/p5-Module-Pluggable
+RUN_DEPENDS= p5-Module-Pluggable>0:devel/p5-Module-Pluggable
TEST_DEPENDS= p5-Capture-Tiny>0:devel/p5-Capture-Tiny
NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>0:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>0:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Kafka/Makefile b/net/p5-Kafka/Makefile
index 751b70b35d72..06959bab1b66 100644
--- a/net/p5-Kafka/Makefile
+++ b/net/p5-Kafka/Makefile
@@ -31,11 +31,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.38:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.38:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Whois-Raw/Makefile b/net/p5-Net-Whois-Raw/Makefile
index 4a02120a0675..44ef5fbfc942 100644
--- a/net/p5-Net-Whois-Raw/Makefile
+++ b/net/p5-Net-Whois-Raw/Makefile
@@ -29,11 +29,4 @@ USE_PERL5= configure
WRKSRC= ${WRKDIR}/${DISTNAME:R}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-IO-Socket-IP>=0:net/p5-IO-Socket-IP
-RUN_DEPENDS+= p5-IO-Socket-IP>=0:net/p5-IO-Socket-IP
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index 3fe2b74e16b9..21f90281eb96 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -19,7 +19,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Socket>=2.016:net/p5-Socket
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= IPV6 SASL SSL
+OPTIONS_DEFINE= SASL SSL
OPTIONS_DEFAULT=SASL SSL
SASL_DESC= SASL auth for POP3 and SMTP support
@@ -33,11 +33,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MIPV6} && ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-IO-Socket-IP>=0.20:net/p5-IO-Socket-IP
-RUN_DEPENDS+= p5-IO-Socket-IP>=0.20:net/p5-IO-Socket-IP
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-POE-Component-SSLify/Makefile b/security/p5-POE-Component-SSLify/Makefile
index a78985753c6f..d86e94285709 100644
--- a/security/p5-POE-Component-SSLify/Makefile
+++ b/security/p5-POE-Component-SSLify/Makefile
@@ -22,10 +22,4 @@ TEST_DEPENDS= p5-Test-FailWarnings>=0:devel/p5-Test-FailWarnings
USES= perl5
USE_PERL5= modbuildtiny
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-TEST_DEPENDS+= p5-Test-Simple>=1.001002:devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Unix-Passwd-File/Makefile b/security/p5-Unix-Passwd-File/Makefile
index 484b16bf2443..db3f163d923a 100644
--- a/security/p5-Unix-Passwd-File/Makefile
+++ b/security/p5-Unix-Passwd-File/Makefile
@@ -28,11 +28,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-experimental>=0:devel/p5-experimental
-RUN_DEPENDS+= p5-experimental>=0:devel/p5-experimental
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-Lingua-EN-MatchNames/Makefile b/textproc/p5-Lingua-EN-MatchNames/Makefile
index 9c61097367d3..8ec3edadecd6 100644
--- a/textproc/p5-Lingua-EN-MatchNames/Makefile
+++ b/textproc/p5-Lingua-EN-MatchNames/Makefile
@@ -22,11 +22,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Text-Soundex>=0:textproc/p5-Text-Soundex
-RUN_DEPENDS+= p5-Text-Soundex>=0:textproc/p5-Text-Soundex
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-Perl-Lint/Makefile b/textproc/p5-Perl-Lint/Makefile
index 81b246dfa4d0..822e68dcb04d 100644
--- a/textproc/p5-Perl-Lint/Makefile
+++ b/textproc/p5-Perl-Lint/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= p5-B-Keywords>=0:devel/p5-B-Keywords \
p5-Email-Address>=0:mail/p5-Email-Address \
p5-List-Flatten>=0:devel/p5-List-Flatten \
p5-List-MoreUtils>=0.33:lang/p5-List-MoreUtils \
+ p5-Module-Pluggable>=0:devel/p5-Module-Pluggable \
p5-Path-Tiny>=0.068:devel/p5-Path-Tiny \
p5-Regexp-Lexer>=0.05:devel/p5-Regexp-Lexer \
p5-String-CamelCase>=0:textproc/p5-String-CamelCase \
@@ -37,14 +38,4 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/eg/|} ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-.else
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.41:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.41:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Elemental/Makefile b/textproc/p5-Pod-Elemental/Makefile
index f004a189b421..502b5a422734 100644
--- a/textproc/p5-Pod-Elemental/Makefile
+++ b/textproc/p5-Pod-Elemental/Makefile
@@ -29,11 +29,4 @@ TEST_DEPENDS= p5-Test-Deep>=0:devel/p5-Test-Deep \
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Tree/Makefile b/textproc/p5-Pod-Tree/Makefile
index f831c5375117..73fc4753456f 100644
--- a/textproc/p5-Pod-Tree/Makefile
+++ b/textproc/p5-Pod-Tree/Makefile
@@ -30,10 +30,4 @@ post-patch:
@${REINPLACE_CMD} -e '/pod2html/d' ${WRKSRC}/MANIFEST
@${RM} ${WRKSRC}/t/pod2html.t
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-TEST_DEPENDS+= p5-Test-Simple>=1.001002:devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-RDF-Trine/Makefile b/textproc/p5-RDF-Trine/Makefile
index 4874e1b6ef21..e3d9d77b1ef7 100644
--- a/textproc/p5-RDF-Trine/Makefile
+++ b/textproc/p5-RDF-Trine/Makefile
@@ -49,11 +49,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Action-REST/Makefile b/www/p5-Catalyst-Action-REST/Makefile
index f4d2f2a15ed7..419c3e9d2232 100644
--- a/www/p5-Catalyst-Action-REST/Makefile
+++ b/www/p5-Catalyst-Action-REST/Makefile
@@ -16,6 +16,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Catalyst-Runtime>=5.80030:www/p5-Catalyst-Runtime \
p5-Class-Inspector>=1.13:devel/p5-Class-Inspector \
p5-MRO-Compat>=0.10:devel/p5-MRO-Compat \
+ p5-Module-Pluggable>=0:devel/p5-Module-Pluggable \
p5-Moose>=1.03:devel/p5-Moose \
p5-Params-Validate>=0.76:devel/p5-Params-Validate \
p5-URI-Find>=0:textproc/p5-URI-Find \
@@ -30,11 +31,4 @@ CONFIGURE_ARGS= --default
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-FormHandler/Makefile b/www/p5-HTML-FormHandler/Makefile
index d40ce73e8d8f..466b81b6292c 100644
--- a/www/p5-HTML-FormHandler/Makefile
+++ b/www/p5-HTML-FormHandler/Makefile
@@ -50,11 +50,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile b/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile
index 4962c9a1ab4a..fde0b03fe091 100644
--- a/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile
+++ b/www/p5-Mojolicious-Plugin-SetUserGroup/Makefile
@@ -22,11 +22,4 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= modbuildtiny
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502000
-BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Scraper-ISBN/Makefile b/www/p5-WWW-Scraper-ISBN/Makefile
index be5daf1ef704..7c4416dfb607 100644
--- a/www/p5-WWW-Scraper-ISBN/Makefile
+++ b/www/p5-WWW-Scraper-ISBN/Makefile
@@ -12,16 +12,12 @@ COMMENT= Retrieving information about books by ISBN number
LICENSE= ART20
+BUILD_DEPENDS= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
+RUN_DEPENDS= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
+
CONFLICTS_INSTALL= p5-WWW-Scraper-ISBN-Driver-[0-9]* p5-WWW-Scraper-ISBN-Record-[0-9]*
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>=0:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Alien-wxWidgets/Makefile b/x11-toolkits/p5-Alien-wxWidgets/Makefile
index ced905285376..53eacc2a7610 100644
--- a/x11-toolkits/p5-Alien-wxWidgets/Makefile
+++ b/x11-toolkits/p5-Alien-wxWidgets/Makefile
@@ -14,6 +14,9 @@ COMMENT= Perl5 module for building, finding and using wxWidgets binaries
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
+BUILD_DEPENDS= p5-Module-Pluggable>=5.1:devel/p5-Module-Pluggable
+RUN_DEPENDS= p5-Module-Pluggable>=5.1:devel/p5-Module-Pluggable
+
USES= perl5 compiler:env
USE_PERL5= modbuild
USE_WX= 3.0
@@ -31,11 +34,4 @@ post-install:
@(cd ${STAGEDIR}${PREFIX}; ${FIND} * -type f -name gtk2_\* -print \
>> ${TMPPLIST})
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502000
-BUILD_DEPENDS+= p5-Module-Pluggable>=5.1:devel/p5-Module-Pluggable
-RUN_DEPENDS+= p5-Module-Pluggable>=5.1:devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>