aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-04-05 23:27:21 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-04-05 23:27:21 +0800
commit8964891302a8398c4c37f89d683ccae12dc73dce (patch)
tree8aa8a4197117d64106640b8627c8a14ab39f3de1
parent82a7fe1e2dd31c817f8c48c44e609424f964edc4 (diff)
downloadfreebsd-ports-gnome-8964891302a8398c4c37f89d683ccae12dc73dce.tar.gz
freebsd-ports-gnome-8964891302a8398c4c37f89d683ccae12dc73dce.tar.zst
freebsd-ports-gnome-8964891302a8398c4c37f89d683ccae12dc73dce.zip
- Update to 0.0.6.5
-rw-r--r--games/opencity/Makefile15
-rw-r--r--games/opencity/distinfo4
-rw-r--r--games/opencity/files/patch-configure11
-rw-r--r--games/opencity/files/patch-no-pedantic-errors26
-rw-r--r--games/opencity/files/patch-src__tinyxpath__node_set.cpp12
5 files changed, 24 insertions, 44 deletions
diff --git a/games/opencity/Makefile b/games/opencity/Makefile
index 872e0f13ca35..25fb271c9fc8 100644
--- a/games/opencity/Makefile
+++ b/games/opencity/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= opencity
-PORTVERSION= 0.0.6.4
-PORTREVISION= 5
+PORTVERSION= 0.0.6.5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Stable/${PORTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+)\..*$/\1/}/
DISTNAME= ${PORTNAME}-${PORTVERSION}stable
@@ -11,11 +10,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}stable
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free 3D city simulator
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
USES= tar:bzip2 gmake pkgconfig
USE_SDL= sdl mixer image net
USE_GL= gl glu
-USE_GCC= any
INSTALL_TARGET= install-strip
PORTDOCS= *
@@ -23,4 +24,10 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+USE_GCC= yes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/opencity/distinfo b/games/opencity/distinfo
index 58c8004217d2..2b94b9083843 100644
--- a/games/opencity/distinfo
+++ b/games/opencity/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opencity-0.0.6.4stable.tar.bz2) = ec2741d826d34f99bbdc3462c94142cfc6ba45aec5a4912f0d1cde11db903fa5
-SIZE (opencity-0.0.6.4stable.tar.bz2) = 8350172
+SHA256 (opencity-0.0.6.5stable.tar.bz2) = 7d7015bee0803f4b8257eefc5e1d7f437d581c6dcc0cd48628acf9896f0bc491
+SIZE (opencity-0.0.6.5stable.tar.bz2) = 8385950
diff --git a/games/opencity/files/patch-configure b/games/opencity/files/patch-configure
new file mode 100644
index 000000000000..7a6fc35bf429
--- /dev/null
+++ b/games/opencity/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2015-03-16 00:38:20.000000000 +0300
++++ configure 2015-04-05 17:24:15.263362000 +0300
+@@ -16115,7 +16115,7 @@
+ fi
+
+
+-CPPFLAGS="-Wall -Wmissing-braces -Wparentheses -pedantic-errors $CPPFLAGS"
++CPPFLAGS="-Wall -Wmissing-braces -Wparentheses $CPPFLAGS"
+
+ CPPFLAGS="-I$with_gl_prefix/include $enable_gprof $enable_debug $CPPFLAGS"
+
diff --git a/games/opencity/files/patch-no-pedantic-errors b/games/opencity/files/patch-no-pedantic-errors
deleted file mode 100644
index 463ba2693c91..000000000000
--- a/games/opencity/files/patch-no-pedantic-errors
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Markus Koschany <apo@gambaru.de>
-Date: Mon, 2 Jun 2014 23:50:54 +0200
-Subject: no pedantic errors
-
---- configure.ac
-+++ configure.ac
-@@ -199,7 +199,7 @@ dnl ===========================================================================
- dnl Set the compiler and the linker options
- dnl ===========================================================================
- dnl Set C / C++ compiler options
--CPPFLAGS="-Wall -Wmissing-braces -Wparentheses -pedantic-errors $CPPFLAGS"
-+CPPFLAGS="-Wall -Wmissing-braces -Wparentheses $CPPFLAGS"
-
- dnl Set more C / C++ compiler options
- CPPFLAGS="-I$with_gl_prefix/include $enable_gprof $enable_debug $CPPFLAGS"
---- configure.orig 2011-07-03 17:14:48.000000000 +0000
-+++ configure 2014-08-30 23:00:42.000000000 +0000
-@@ -6150,7 +6150,7 @@
- fi
-
-
--CPPFLAGS="-Wall -Wmissing-braces -Wparentheses -pedantic-errors $CPPFLAGS"
-+CPPFLAGS="-Wall -Wmissing-braces -Wparentheses $CPPFLAGS"
-
- CPPFLAGS="-I$with_gl_prefix/include $enable_gprof $enable_debug $CPPFLAGS"
-
diff --git a/games/opencity/files/patch-src__tinyxpath__node_set.cpp b/games/opencity/files/patch-src__tinyxpath__node_set.cpp
deleted file mode 100644
index 4cdbcde1a5ec..000000000000
--- a/games/opencity/files/patch-src__tinyxpath__node_set.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/tinyxpath/node_set.cpp.orig 2011-07-03 20:36:33.000000000 +0400
-+++ src/tinyxpath/node_set.cpp 2014-03-28 20:44:24.828732644 +0400
-@@ -23,9 +23,7 @@
- */
-
- #include "node_set.h"
--#ifdef HAVE_STDINT_H
- #include "stdint.h" // for intptr_t (32/64 bits void* pointer compatibility)
--#endif
-
- namespace TinyXPath
- {