aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbz <sbz@FreeBSD.org>2012-02-04 11:23:53 +0800
committersbz <sbz@FreeBSD.org>2012-02-04 11:23:53 +0800
commit8ac955c7c60c9b3e6232a999fa4d4d2d3ed13131 (patch)
tree6e216e69ca8f35089515550b53bedd84e998b9cb
parent97f98d3f1bde980d2803d4ed4160855bedd9ae9f (diff)
downloadfreebsd-ports-gnome-8ac955c7c60c9b3e6232a999fa4d4d2d3ed13131.tar.gz
freebsd-ports-gnome-8ac955c7c60c9b3e6232a999fa4d4d2d3ed13131.tar.zst
freebsd-ports-gnome-8ac955c7c60c9b3e6232a999fa4d4d2d3ed13131.zip
- Update to 0.3.0
Approved by: jadawin@, miwi@ (mentors, implicit)
-rw-r--r--sysutils/pax-utils/Makefile2
-rw-r--r--sysutils/pax-utils/distinfo4
-rw-r--r--sysutils/pax-utils/files/patch-Makefile8
-rw-r--r--sysutils/pax-utils/files/patch-scanelf.c13
4 files changed, 20 insertions, 7 deletions
diff --git a/sysutils/pax-utils/Makefile b/sysutils/pax-utils/Makefile
index c6634357b382..6d2a2c838dde 100644
--- a/sysutils/pax-utils/Makefile
+++ b/sysutils/pax-utils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pax-utils
-PORTVERSION= 0.2.3
+PORTVERSION= 0.3.0
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GENTOO} \
http://dev.gentoo.org/~vapier/dist/
diff --git a/sysutils/pax-utils/distinfo b/sysutils/pax-utils/distinfo
index 8a32279edf22..3d1eedf60d16 100644
--- a/sysutils/pax-utils/distinfo
+++ b/sysutils/pax-utils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pax-utils-0.2.3.tar.xz) = b2cdc20a0c67b78753ff4c4cbaa84b8175b0e2eb926de7390daef34a19297285
-SIZE (pax-utils-0.2.3.tar.xz) = 76652
+SHA256 (pax-utils-0.3.0.tar.xz) = d6d2992a40d89ab02d39a90d3c88ef553ecf1c9b93bae82efe16453b9152696a
+SIZE (pax-utils-0.3.0.tar.xz) = 79892
diff --git a/sysutils/pax-utils/files/patch-Makefile b/sysutils/pax-utils/files/patch-Makefile
index 6d7d85f5bfd6..abb2876ce17e 100644
--- a/sysutils/pax-utils/files/patch-Makefile
+++ b/sysutils/pax-utils/files/patch-Makefile
@@ -1,6 +1,6 @@
---- ./Makefile.orig 2010-02-14 19:14:16.000000000 +0100
-+++ ./Makefile 2010-11-12 00:49:47.000000000 +0100
-@@ -21,7 +21,7 @@
+--- ./Makefile.orig 2012-01-24 00:49:40.000000000 +0100
++++ ./Makefile 2012-02-04 04:30:30.000000000 +0100
+@@ -24,7 +24,7 @@
LDFLAGS +=
LIBS :=
DESTDIR =
@@ -9,7 +9,7 @@
STRIP := strip
MKDIR := mkdir -p
CP := cp
-@@ -97,15 +97,15 @@
+@@ -100,15 +100,15 @@
$(STRIP) --strip-unneeded $(TARGETS)
install: all
diff --git a/sysutils/pax-utils/files/patch-scanelf.c b/sysutils/pax-utils/files/patch-scanelf.c
new file mode 100644
index 000000000000..ca6a2e9be4c0
--- /dev/null
+++ b/sysutils/pax-utils/files/patch-scanelf.c
@@ -0,0 +1,13 @@
+--- ./scanelf.c.orig 2012-02-04 05:19:34.000000000 +0100
++++ ./scanelf.c 2012-02-04 05:19:59.000000000 +0100
+@@ -14,6 +14,10 @@
+
+ #define IS_MODIFIER(c) (c == '%' || c == '#' || c == '+')
+
++#ifndef O_CLOEXEC
++#define O_CLOEXEC 0x00100000
++#endif
++
+ /* prototypes */
+ static int file_matches_list(const char *filename, char **matchlist);
+