aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-11-05 22:42:49 +0800
committermarino <marino@FreeBSD.org>2016-11-05 22:42:49 +0800
commit916c39049e1d3bf0e82f61c3aab2aa6aa40cb0b9 (patch)
tree7ea08d597ab82999b78bd8ca119addf9b85c6f2d
parent9837df5ca17aa645c9ddfa78c750ef0010d34bf0 (diff)
downloadfreebsd-ports-gnome-916c39049e1d3bf0e82f61c3aab2aa6aa40cb0b9.tar.gz
freebsd-ports-gnome-916c39049e1d3bf0e82f61c3aab2aa6aa40cb0b9.tar.zst
freebsd-ports-gnome-916c39049e1d3bf0e82f61c3aab2aa6aa40cb0b9.zip
mail/emailrelay: Fix DEFAULT_VERSIONS+=ssl
Both LibreSSL and the latest version of OpenSSL lack definitions for SSLv3_method, so handle that case to fix the build with those SSL options. Appoved by: SSL blanket
-rw-r--r--mail/emailrelay/Makefile2
-rw-r--r--mail/emailrelay/files/patch-src_gssl_gssl__openssl.cpp13
2 files changed, 15 insertions, 0 deletions
diff --git a/mail/emailrelay/Makefile b/mail/emailrelay/Makefile
index 2c1004cb3ef5..9d4ceccaf7d2 100644
--- a/mail/emailrelay/Makefile
+++ b/mail/emailrelay/Makefile
@@ -33,6 +33,8 @@ GUI_USE= QT4=gui,moc
OPENSSL_CONFIGURE_WITH= openssl
OPENSSL_USE= OPENSSL=yes
+OPENSSL_LDFLAGS= -L${OPENSSLLIB}
+OPENSSL_CPPFLAGS= -I${OPENSSLINC}
IPV6_CONFIGURE_ENABLE= ipv6
diff --git a/mail/emailrelay/files/patch-src_gssl_gssl__openssl.cpp b/mail/emailrelay/files/patch-src_gssl_gssl__openssl.cpp
new file mode 100644
index 000000000000..3f3bdf3a94eb
--- /dev/null
+++ b/mail/emailrelay/files/patch-src_gssl_gssl__openssl.cpp
@@ -0,0 +1,13 @@
+--- src/gssl/gssl_openssl.cpp.orig 2013-12-07 22:55:47 UTC
++++ src/gssl/gssl_openssl.cpp
+@@ -292,8 +292,10 @@ GSsl::Context::Context( const std::strin
+ {
+ if( (flags&3U) == 2U )
+ m_ssl_ctx = SSL_CTX_new(SSLv23_method()) ;
++#ifndef OPENSSL_NO_SSL3
+ else if( (flags&3U) == 3U )
+ m_ssl_ctx = SSL_CTX_new(SSLv3_method()) ;
++#endif
+ else
+ m_ssl_ctx = SSL_CTX_new(TLSv1_method()) ;
+