aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-04-12 11:02:36 +0800
committermiwi <miwi@FreeBSD.org>2011-04-12 11:02:36 +0800
commit925c6a46301dc9bebe8a6c4a978c72e83761a600 (patch)
treef16a7ea8aa18a518d0d994d4fbc78a2935d747bf
parent077f18c519b1c870934fdd6aea0b1fbc5ce06ff0 (diff)
downloadfreebsd-ports-gnome-925c6a46301dc9bebe8a6c4a978c72e83761a600.tar.gz
freebsd-ports-gnome-925c6a46301dc9bebe8a6c4a978c72e83761a600.tar.zst
freebsd-ports-gnome-925c6a46301dc9bebe8a6c4a978c72e83761a600.zip
This is a compression program optimised for large files. The larger the file
and the more memory you have, the better the compression advantage this will provide, especially once the files are larger than 100MB. The advantage can be chosen to be either size (much smaller than bzip2) or speed (much faster than bzip2). WWW: http://ck.kolivas.org/apps/lrzip/README PR: ports/156267 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/lrzip/Makefile35
-rw-r--r--archivers/lrzip/distinfo2
-rw-r--r--archivers/lrzip/files/patch-stream.diff11
-rw-r--r--archivers/lrzip/pkg-descr7
-rw-r--r--archivers/lrzip/pkg-plist27
6 files changed, 83 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 884c35a4a247..a96c19cc73f2 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -69,6 +69,7 @@
SUBDIR += linux-f10-upx
SUBDIR += linux-ucl
SUBDIR += linux-upx
+ SUBDIR += lrzip
SUBDIR += lzip
SUBDIR += lzlib
SUBDIR += lzma
diff --git a/archivers/lrzip/Makefile b/archivers/lrzip/Makefile
new file mode 100644
index 000000000000..a79b1215dd18
--- /dev/null
+++ b/archivers/lrzip/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lrzip
+# Date created: 2011-04-08
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lrzip
+PORTVERSION= 0.601
+CATEGORIES= archivers
+MASTER_SITES= http://ck.kolivas.org/apps/lrzip/ \
+ http://files.gslin.org/Software/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Long Range ZIP or Lzma RZIP
+
+BUILD_DEPENDS= nasm>=0:${PORTSDIR}/devel/nasm
+LIB_DEPENDS= lzo2:${PORTSDIR}/archivers/lzo2
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS+= --enable-asm
+CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+LICENSE= GPLv2
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5_BUILD= yes
+
+MAN1= lrunzip.1 \
+ lrzip.1 \
+ lrztar.1 \
+ lrzuntar.1
+MAN5= lrzip.conf.5
+
+.include <bsd.port.mk>
diff --git a/archivers/lrzip/distinfo b/archivers/lrzip/distinfo
new file mode 100644
index 000000000000..7d932c1a1ac5
--- /dev/null
+++ b/archivers/lrzip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lrzip-0.601.tar.bz2) = 3cbb4454ebd61b7c8fb22b3155291f7cad4168f7d86fabf33e8e0992356b05e7
+SIZE (lrzip-0.601.tar.bz2) = 431587
diff --git a/archivers/lrzip/files/patch-stream.diff b/archivers/lrzip/files/patch-stream.diff
new file mode 100644
index 000000000000..2e87b6fd02f2
--- /dev/null
+++ b/archivers/lrzip/files/patch-stream.diff
@@ -0,0 +1,11 @@
+--- stream.c.orig 2011-04-08 11:12:25.000000000 +0800
++++ stream.c 2011-04-08 11:12:53.000000000 +0800
+@@ -58,7 +58,7 @@
+ #include "lrzip.h"
+
+
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ # define fmemopen fake_fmemopen
+ # define open_memstream fake_open_memstream
+ # define memstream_update_buffer fake_open_memstream_update_buffer
diff --git a/archivers/lrzip/pkg-descr b/archivers/lrzip/pkg-descr
new file mode 100644
index 000000000000..b90db0a2434b
--- /dev/null
+++ b/archivers/lrzip/pkg-descr
@@ -0,0 +1,7 @@
+This is a compression program optimised for large files. The larger the file
+and the more memory you have, the better the compression advantage this will
+provide, especially once the files are larger than 100MB. The advantage can
+be chosen to be either size (much smaller than bzip2) or speed (much faster
+than bzip2).
+
+WWW: http://ck.kolivas.org/apps/lrzip/README
diff --git a/archivers/lrzip/pkg-plist b/archivers/lrzip/pkg-plist
new file mode 100644
index 000000000000..b8123c0f5d5e
--- /dev/null
+++ b/archivers/lrzip/pkg-plist
@@ -0,0 +1,27 @@
+@comment $FreeBSD$
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/BUGS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/README
+%%DOCSDIR%%/README-NOT-BACKWARD-COMPATIBLE
+%%DOCSDIR%%/README.Assembler
+%%DOCSDIR%%/README.benchmarks
+%%DOCSDIR%%/README.lzo_compresses.test.txt
+%%DOCSDIR%%/TODO
+%%DOCSDIR%%/WHATS-NEW
+%%DOCSDIR%%/lrzip.conf.example
+%%DOCSDIR%%/lzma/7zC.txt
+%%DOCSDIR%%/lzma/7zFormat.txt
+%%DOCSDIR%%/lzma/Methods.txt
+%%DOCSDIR%%/lzma/README
+%%DOCSDIR%%/lzma/README-Alloc
+%%DOCSDIR%%/lzma/history.txt
+%%DOCSDIR%%/lzma/lzma.txt
+%%DOCSDIR%%/magic.header.txt
+bin/lrunzip
+bin/lrzip
+bin/lrztar
+bin/lrzuntar
+@dirrm %%DOCSDIR%%/lzma
+@dirrm %%DOCSDIR%%