aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-11-28 19:41:56 +0800
committerkoobs <koobs@FreeBSD.org>2013-11-28 19:41:56 +0800
commit929edaae6a489d9499998f66c0d8434ca2eff4d7 (patch)
tree6378125e74532106a5726dc454584a7e5fa4e7b4
parent93e177d8c346a66c56c68e2f69a06f1c2c3b9d92 (diff)
downloadfreebsd-ports-gnome-929edaae6a489d9499998f66c0d8434ca2eff4d7.tar.gz
freebsd-ports-gnome-929edaae6a489d9499998f66c0d8434ca2eff4d7.tar.zst
freebsd-ports-gnome-929edaae6a489d9499998f66c0d8434ca2eff4d7.zip
net/libzmq4: ZeroMQ core library (Version 4) [NEW PORT]
ZeroMQ - Distributed Computing Made Simple * The socket library that acts as a concurrency framework. * Carries messages across inproc, IPC, TCP, and multicast. * Connect N-to-N via fanout, pubsub, pipeline, request-reply. * Asynch I/O for scalable multicore message-passing apps. Version 4 Features: * New wire level protocol, ZMTP/3.0 * New security framework with PLAIN and CURVE mechanisms * New ZMQ_STREAM socket type WWW: http://www.zeromq.org/ PR: ports/183730 Reviewed by: kwm, wg
-rw-r--r--net/Makefile1
-rw-r--r--net/libzmq4/Makefile42
-rw-r--r--net/libzmq4/distinfo2
-rw-r--r--net/libzmq4/pkg-descr14
-rw-r--r--net/libzmq4/pkg-plist59
5 files changed, 118 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a55a6ea4a496..884a74c9184b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -348,6 +348,7 @@
SUBDIR += libunp
SUBDIR += libutp
SUBDIR += libvncserver
+ SUBDIR += libzmq4
SUBDIR += liferea
SUBDIR += linc
SUBDIR += linc-reference
diff --git a/net/libzmq4/Makefile b/net/libzmq4/Makefile
new file mode 100644
index 000000000000..0ce65dcad895
--- /dev/null
+++ b/net/libzmq4/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= libzmq4
+PORTVERSION= 4.0.2
+CATEGORIES= net
+MASTER_SITES= http://download.zeromq.org/
+DISTNAME= zeromq-${DISTVERSION}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= ZeroMQ core library (Version 4)
+
+LICENSE= LGPL3
+
+USES= pathfix
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= CURVE DEBUG PGM
+CURVE_DESC= CURVE security mechanism via libsodium
+PGM_DESC= Reliable multicast transport using PGM via OpenPGM
+
+CURVE_CONFIGURE_ON= --with-libsodium=${LOCALBASE}
+CURVE_LIB_DEPENDS= libsodium.so:${PORTSDIR}/security/libsodium
+DEBUG_CONFIGURE_ON= --enable-debug
+PGM_CONFIGURE_ON= --with-system-pgm
+PGM_LIB_DEPENDS= libpgm.so:${PORTSDIR}/net/openpgm
+PGM_USES= pkgconfig
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+WITH_DEBUG= yes
+.endif
+
+GNU_CONFIGURE= yes
+CFLAGS+= -Wno-long-long
+
+CONFLICTS= zmq-[0-9]* libzmq[^4]-[0-9]*
+
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/net/libzmq4/distinfo b/net/libzmq4/distinfo
new file mode 100644
index 000000000000..6e51dc92eda1
--- /dev/null
+++ b/net/libzmq4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zeromq-4.0.2.tar.gz) = c8b2b1e8fe47fd6e1ca710ba68d71086ddb323e8ab5c5bd96155390dc5c8d75a
+SIZE (zeromq-4.0.2.tar.gz) = 2168988
diff --git a/net/libzmq4/pkg-descr b/net/libzmq4/pkg-descr
new file mode 100644
index 000000000000..9efee67ae339
--- /dev/null
+++ b/net/libzmq4/pkg-descr
@@ -0,0 +1,14 @@
+ZeroMQ - Distributed Computing Made Simple
+
+ * The socket library that acts as a concurrency framework.
+ * Carries messages across inproc, IPC, TCP, and multicast.
+ * Connect N-to-N via fanout, pubsub, pipeline, request-reply.
+ * Asynch I/O for scalable multicore message-passing apps.
+
+Version 4 Features:
+
+ * New wire level protocol, ZMTP/3.0
+ * New security framework with PLAIN and CURVE mechanisms
+ * New ZMQ_STREAM socket type
+
+WWW: http://www.zeromq.org/
diff --git a/net/libzmq4/pkg-plist b/net/libzmq4/pkg-plist
new file mode 100644
index 000000000000..7c18b559cacf
--- /dev/null
+++ b/net/libzmq4/pkg-plist
@@ -0,0 +1,59 @@
+bin/curve_keygen
+include/zmq.h
+include/zmq_utils.h
+lib/libzmq.a
+lib/libzmq.la
+lib/libzmq.so
+lib/libzmq.so.4
+libdata/pkgconfig/libzmq.pc
+man/man3/zmq_bind.3.gz
+man/man3/zmq_close.3.gz
+man/man3/zmq_connect.3.gz
+man/man3/zmq_ctx_destroy.3.gz
+man/man3/zmq_ctx_get.3.gz
+man/man3/zmq_ctx_new.3.gz
+man/man3/zmq_ctx_set.3.gz
+man/man3/zmq_ctx_term.3.gz
+man/man7/zmq_curve.7.gz
+man/man3/zmq_curve_keypair.3.gz
+man/man3/zmq_disconnect.3.gz
+man/man3/zmq_errno.3.gz
+man/man3/zmq_getsockopt.3.gz
+man/man3/zmq_init.3.gz
+man/man3/zmq_msg_close.3.gz
+man/man3/zmq_msg_copy.3.gz
+man/man3/zmq_msg_data.3.gz
+man/man3/zmq_msg_get.3.gz
+man/man3/zmq_msg_init.3.gz
+man/man3/zmq_msg_init_data.3.gz
+man/man3/zmq_msg_init_size.3.gz
+man/man3/zmq_msg_more.3.gz
+man/man3/zmq_msg_move.3.gz
+man/man3/zmq_msg_recv.3.gz
+man/man3/zmq_msg_send.3.gz
+man/man3/zmq_msg_set.3.gz
+man/man3/zmq_msg_size.3.gz
+man/man7/zmq_null.7.gz
+man/man3/zmq_poll.3.gz
+man/man7/zmq_plain.7.gz
+man/man3/zmq_proxy.3.gz
+man/man3/zmq_recv.3.gz
+man/man3/zmq_recvmsg.3.gz
+man/man3/zmq_send.3.gz
+man/man3/zmq_send_const.3.gz
+man/man3/zmq_sendmsg.3.gz
+man/man3/zmq_setsockopt.3.gz
+man/man3/zmq_socket.3.gz
+man/man3/zmq_socket_monitor.3.gz
+man/man3/zmq_strerror.3.gz
+man/man3/zmq_term.3.gz
+man/man3/zmq_unbind.3.gz
+man/man3/zmq_version.3.gz
+man/man3/zmq_z85_decode.3.gz
+man/man3/zmq_z85_encode.3.gz
+man/man7/zmq.7.gz
+man/man7/zmq_epgm.7.gz
+man/man7/zmq_inproc.7.gz
+man/man7/zmq_ipc.7.gz
+man/man7/zmq_pgm.7.gz
+man/man7/zmq_tcp.7.gz