aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-10-06 23:53:37 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-10-06 23:53:37 +0800
commit933c6cfcdeadec67afa038710e23fc70a71bf687 (patch)
tree7b6d866a479301b2b3fb422c790ebc77accf2d10
parent0335d62e07817f3358a587e90928bb21fa03c9b6 (diff)
downloadfreebsd-ports-gnome-933c6cfcdeadec67afa038710e23fc70a71bf687.tar.gz
freebsd-ports-gnome-933c6cfcdeadec67afa038710e23fc70a71bf687.tar.zst
freebsd-ports-gnome-933c6cfcdeadec67afa038710e23fc70a71bf687.zip
- Add license (commercial distribution is forbidden)
- Regenerate patches Approved by: portmgr blanket MFH: 2016Q4 (blanket)
-rw-r--r--games/frogatto/Makefile9
-rw-r--r--games/frogatto/files/patch-Makefile2
-rw-r--r--games/frogatto/files/patch-src-filesystem.cpp10
3 files changed, 14 insertions, 7 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 647da496c66a..7f8256c87608 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -3,12 +3,19 @@
PORTNAME= frogatto
PORTVERSION= 1.3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MAINTAINER= fiziologus@gmail.com
COMMENT= Old-school 2D classic adventure platformer game
+LICENSE= FROGATTO GPLv3
+LICENSE_COMB= multi
+LICENSE_NAME_FROGATTO= Frogatto license
+LICENSE_FILE_FROGATTO= ${WRKSRC}/LICENSE
+LICENSE_FILE_GPLv3= ${WRKSRC}/src/LICENSE
+LICENSE_PERMS_FROGATTO= dist-mirror pkg-mirror auto-accept
+
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libpng.so:graphics/png
diff --git a/games/frogatto/files/patch-Makefile b/games/frogatto/files/patch-Makefile
index 3f08bcd7243d..1d6d82bb7289 100644
--- a/games/frogatto/files/patch-Makefile
+++ b/games/frogatto/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig
+--- Makefile.orig 2012-12-08 22:36:13 UTC
+++ Makefile
@@ -22,7 +22,7 @@
# found in PATH), this option has no effect.
diff --git a/games/frogatto/files/patch-src-filesystem.cpp b/games/frogatto/files/patch-src-filesystem.cpp
index 5ab41e334d21..5df5a5f3f15f 100644
--- a/games/frogatto/files/patch-src-filesystem.cpp
+++ b/games/frogatto/files/patch-src-filesystem.cpp
@@ -1,8 +1,8 @@
---- src/filesystem.cpp.orig
+--- src/filesystem.cpp.orig 2012-12-08 22:36:13 UTC
+++ src/filesystem.cpp
-@@ -299,8 +299,14 @@
- FILE_NAME_MODE mode)
- {
+@@ -405,8 +405,14 @@ void get_files_in_dir(const std::string&
+ }
+ #else
struct stat st;
+ std::string dirname;
@@ -16,7 +16,7 @@
if(dir == NULL) {
return;
-@@ -331,14 +337,14 @@
+@@ -437,14 +443,14 @@ void get_files_in_dir(const std::string&
#endif /* !APPLE */
std::string fullname;