aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2019-02-12 01:10:05 +0800
committertcberner <tcberner@FreeBSD.org>2019-02-12 01:10:05 +0800
commit9f572edbd35a0080750a51ea70123bd684defae3 (patch)
tree3ba7e67672e6da68e14d2308683ddd7b22af74e2
parent4de94074292a444451eead9beb11dcb04ff162dc (diff)
downloadfreebsd-ports-gnome-9f572edbd35a0080750a51ea70123bd684defae3.tar.gz
freebsd-ports-gnome-9f572edbd35a0080750a51ea70123bd684defae3.tar.zst
freebsd-ports-gnome-9f572edbd35a0080750a51ea70123bd684defae3.zip
Update graphics/poppler* to 0.74.0
Changelog can be found here: https://poppler.freedesktop.org/releases.html PR: 235609 Exp-run by: antoine Approved by: gnome (kde) Differential Revision: https://reviews.freebsd.org/D18805
-rw-r--r--editors/calligra/Makefile4
-rw-r--r--editors/libreoffice/Makefile6
-rw-r--r--graphics/inkscape/Makefile3
-rw-r--r--graphics/poppler-glib/pkg-plist2
-rw-r--r--graphics/poppler-qt5/Makefile2
-rw-r--r--graphics/poppler-qt5/pkg-plist3
-rw-r--r--graphics/poppler/Makefile4
-rw-r--r--graphics/poppler/distinfo6
-rw-r--r--graphics/poppler/pkg-plist9
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp118
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h34
11 files changed, 163 insertions, 28 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index e625b16dff43..4022fcf67a6b 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -69,4 +69,8 @@ CMAKE_ARGS+= -DCMAKE_CXX_FLAGS="-DKDE_NO_DEBUG_OUTPUT"
PLIST_SUB+= SHLIB_VER=16.0.0
+post-patch:
+ # Fix with poppler 0.73
+ ${REINPLACE_CMD} -e 's|Guchar|unsigned char|g' \
+ ${WRKSRC}/filters/karbon/pdf/SvgOutputDev.cpp
.include <bsd.port.mk>
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index f94a94fe0794..e8ee47f62837 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -282,6 +282,12 @@ CXXFLAGS_WARN= -Wshadow -Woverloaded-virtual
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/shell/source/unix/exec/shellexec.cxx
+ # Fix with poppler 0.73
+ ${REINPLACE_CMD} -e 's|Guchar|unsigned char|g' \
+ ${WRKSRC}/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx \
+ ${WRKSRC}/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx \
+ ${WRKSRC}/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
+
.if ${COMPILER_FEATURES:Mlibstdc++}
${REINPLACE_CMD} -e 's/gb_CC/gb_CXX/' ${WRKSRC}/solenv/gbuild/platform/unxgcc.mk
.endif
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 84a8b6b9ba2e..667539e8ce06 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -85,5 +85,8 @@ post-patch:
# Obtained from Arch Linux
@${REINPLACE_CMD} -e 's|gTrue|true|g' -e 's|gFalse|false|g' -e 's|GBool|bool|g' \
${WRKSRC}/src/extension/internal/pdfinput/pdf-parser.*
+ # Fix with poppler 0.73
+ @${REINPLACE_CMD} -E '/#include "goo\/gtypes.h"/d' \
+ ${WRKSRC}/src/extension/internal/pdfinput/pdf-parser.h
.include <bsd.port.mk>
diff --git a/graphics/poppler-glib/pkg-plist b/graphics/poppler-glib/pkg-plist
index 5b5c10e69f89..24881e8d0542 100644
--- a/graphics/poppler-glib/pkg-plist
+++ b/graphics/poppler-glib/pkg-plist
@@ -16,6 +16,6 @@ include/poppler/glib/poppler.h
lib/girepository-1.0/Poppler-0.18.typelib
lib/libpoppler-glib.so
lib/libpoppler-glib.so.8
-lib/libpoppler-glib.so.8.11.0
+lib/libpoppler-glib.so.8.12.0
libdata/pkgconfig/poppler-glib.pc
share/gir-1.0/Poppler-0.18.gir
diff --git a/graphics/poppler-qt5/Makefile b/graphics/poppler-qt5/Makefile
index 32f0fe55ef5b..686ee8cf48b0 100644
--- a/graphics/poppler-qt5/Makefile
+++ b/graphics/poppler-qt5/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
PKGNAMESUFFIX= -qt5
COMMENT= Qt 5 bindings to poppler
diff --git a/graphics/poppler-qt5/pkg-plist b/graphics/poppler-qt5/pkg-plist
index ca6e9a5c6ab5..dabf261a957f 100644
--- a/graphics/poppler-qt5/pkg-plist
+++ b/graphics/poppler-qt5/pkg-plist
@@ -6,7 +6,8 @@ include/poppler/qt5/poppler-media.h
include/poppler/qt5/poppler-optcontent.h
include/poppler/qt5/poppler-page-transition.h
include/poppler/qt5/poppler-qt5.h
+include/poppler/qt5/poppler-version.h
lib/libpoppler-qt5.so
lib/libpoppler-qt5.so.1
-lib/libpoppler-qt5.so.1.17.0
+lib/libpoppler-qt5.so.1.19.0
libdata/pkgconfig/poppler-qt5.pc
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index ad84d746f8b2..e9bd445935ea 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= poppler
-DISTVERSION= 0.72.0
+DISTVERSION= 0.74.0
CATEGORIES= graphics print
MASTER_SITES= http://poppler.freedesktop.org/
@@ -29,7 +29,7 @@ USE_LDCONFIG= yes
CMAKE_ON= ENABLE_LIBJPEG \
ENABLE_LIBPNG \
ENABLE_LIBTIFF \
- ENABLE_XPDF_HEADERS \
+ ENABLE_UNSTABLE_API_ABI_HEADERS \
ENABLE_ZLIB \
ENABLE_NSS \
ENABLE_SPLASH
diff --git a/graphics/poppler/distinfo b/graphics/poppler/distinfo
index 5d53e8e19678..12430d09aef6 100644
--- a/graphics/poppler/distinfo
+++ b/graphics/poppler/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1544313959
-SHA256 (poppler-0.72.0.tar.xz) = c1747eb8f26e9e753c4001ed951db2896edc1021b6d0f547a0bd2a27c30ada51
-SIZE (poppler-0.72.0.tar.xz) = 1492912
+TIMESTAMP = 1549603391
+SHA256 (poppler-0.74.0.tar.xz) = 92e09fd3302567fd36146b36bb707db43ce436e8841219025a82ea9fb0076b2f
+SIZE (poppler-0.74.0.tar.xz) = 1514044
diff --git a/graphics/poppler/pkg-plist b/graphics/poppler/pkg-plist
index 59763fc86b7a..4c81fffd3c75 100644
--- a/graphics/poppler/pkg-plist
+++ b/graphics/poppler/pkg-plist
@@ -5,6 +5,7 @@ include/poppler/BuiltinFontTables.h
include/poppler/CMap.h
include/poppler/CachedFile.h
include/poppler/Catalog.h
+include/poppler/CertificateInfo.h
include/poppler/CharCodeToUnicode.h
include/poppler/CharTypes.h
include/poppler/CompactFontTables.h
@@ -75,6 +76,7 @@ include/poppler/UnicodeMapTables.h
include/poppler/UnicodeTypeTable.h
include/poppler/ViewerPreferences.h
include/poppler/XRef.h
+include/poppler/cpp/poppler-destination.h
include/poppler/cpp/poppler-document.h
include/poppler/cpp/poppler-embedded-file.h
include/poppler/cpp/poppler-font.h
@@ -107,7 +109,6 @@ include/poppler/goo/gfile.h
include/poppler/goo/gmem.h
include/poppler/goo/grandom.h
include/poppler/goo/gstrtod.h
-include/poppler/goo/gtypes.h
include/poppler/poppler-config.h
include/poppler/splash/Splash.h
include/poppler/splash/SplashBitmap.h
@@ -131,10 +132,10 @@ include/poppler/splash/SplashXPath.h
include/poppler/splash/SplashXPathScanner.h
lib/libpoppler-cpp.so
lib/libpoppler-cpp.so.0
-lib/libpoppler-cpp.so.0.5.0
+lib/libpoppler-cpp.so.0.7.0
lib/libpoppler.so
-lib/libpoppler.so.83
-lib/libpoppler.so.83.0.0
+lib/libpoppler.so.85
+lib/libpoppler.so.85.0.0
libdata/pkgconfig/poppler-cairo.pc
libdata/pkgconfig/poppler-cpp.pc
libdata/pkgconfig/poppler-splash.pc
diff --git a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp
index f7762cbca03a..c57aa07648cd 100644
--- a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp
+++ b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp
@@ -1,4 +1,4 @@
---- scribus/plugins/import/pdf/slaoutput.cpp.orig 2018-12-11 13:04:07 UTC
+--- scribus/plugins/import/pdf/slaoutput.cpp.orig 2019-01-10 06:21:56 UTC
+++ scribus/plugins/import/pdf/slaoutput.cpp
@@ -44,7 +44,7 @@ LinkSubmitForm::LinkSubmitForm(Object *actionObj)
{
@@ -397,6 +397,15 @@
{
// qDebug() << "Draw Image Mask";
QImage * image = 0;
+@@ -2449,7 +2442,7 @@ void SlaOutputDev::drawImageMask(GfxState *state, Obje
+ int x, y, i, bit;
+ unsigned char *dest = 0;
+ unsigned char *buffer;
+- Guchar *pix;
++ unsigned char *pix;
+ ImageStream * imgStr = new ImageStream(str, width, 1, 1);
+ imgStr->reset();
+ #ifdef WORDS_BIGENDIAN
@@ -2512,8 +2505,7 @@ void SlaOutputDev::drawImageMask(GfxState *state, Obje
t++;
}
@@ -418,6 +427,32 @@
{
// qDebug() << "Masked Image Components" << colorMap->getNumPixelComps();
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
+@@ -2617,7 +2609,7 @@ void SlaOutputDev::drawSoftMaskedImage(GfxState *state
+ for (int y = 0; y < height; y++)
+ {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+ }
+ image = new QImage(buffer, width, height, QImage::Format_RGB32);
+@@ -2630,13 +2622,13 @@ void SlaOutputDev::drawSoftMaskedImage(GfxState *state
+ }
+ ImageStream *mskStr = new ImageStream(maskStr, maskWidth, maskColorMap->getNumPixelComps(), maskColorMap->getBits());
+ mskStr->reset();
+- Guchar *mdest = 0;
++ unsigned char *mdest = 0;
+ unsigned char * mbuffer = new unsigned char[maskWidth * maskHeight];
+ memset(mbuffer, 0, maskWidth * maskHeight);
+ for (int y = 0; y < maskHeight; y++)
+ {
+- mdest = (Guchar *)(mbuffer + y * maskWidth);
+- Guchar * pix = mskStr->getLine();
++ mdest = (unsigned char *)(mbuffer + y * maskWidth);
++ unsigned char * pix = mskStr->getLine();
+ maskColorMap->getGrayLine(pix, mdest, maskWidth);
+ }
+ if ((maskWidth != width) || (maskHeight != height))
@@ -2658,8 +2650,7 @@ void SlaOutputDev::drawSoftMaskedImage(GfxState *state
t++;
}
@@ -437,6 +472,33 @@
{
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
imgStr->reset();
+@@ -2760,7 +2751,7 @@ void SlaOutputDev::drawMaskedImage(GfxState *state, Ob
+ for (int y = 0; y < height; y++)
+ {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+ }
+ image = new QImage(buffer, width, height, QImage::Format_RGB32);
+@@ -2773,14 +2764,14 @@ void SlaOutputDev::drawMaskedImage(GfxState *state, Ob
+ }
+ ImageStream *mskStr = new ImageStream(maskStr, maskWidth, 1, 1);
+ mskStr->reset();
+- Guchar *mdest = 0;
++ unsigned char *mdest = 0;
+ int invert_bit = maskInvert ? 1 : 0;
+ unsigned char * mbuffer = new unsigned char[maskWidth * maskHeight];
+ memset(mbuffer, 0, maskWidth * maskHeight);
+ for (int y = 0; y < maskHeight; y++)
+ {
+- mdest = (Guchar *)(mbuffer + y * maskWidth);
+- Guchar * pix = mskStr->getLine();
++ mdest = (unsigned char *)(mbuffer + y * maskWidth);
++ unsigned char * pix = mskStr->getLine();
+ for (int x = 0; x < maskWidth; x++)
+ {
+ if (pix[x] ^ invert_bit)
@@ -2808,8 +2799,7 @@ void SlaOutputDev::drawMaskedImage(GfxState *state, Ob
t++;
}
@@ -456,6 +518,24 @@
{
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
// qDebug() << "Image Components" << colorMap->getNumPixelComps() << "Mask" << maskColors;
+@@ -2912,7 +2902,7 @@ void SlaOutputDev::drawImage(GfxState *state, Object *
+ for (int y = 0; y < height; y++)
+ {
+ QRgb *s = (QRgb*)(image->scanLine(y));
+- Guchar *pix = imgStr->getLine();
++ unsigned char *pix = imgStr->getLine();
+ for (int x = 0; x < width; x++)
+ {
+ GfxRGB rgb;
+@@ -2940,7 +2930,7 @@ void SlaOutputDev::drawImage(GfxState *state, Object *
+ for (int y = 0; y < height; y++)
+ {
+ QRgb *s = (QRgb*)(image->scanLine(y));
+- Guchar *pix = imgStr->getLine();
++ unsigned char *pix = imgStr->getLine();
+ for (int x = 0; x < width; x++)
+ {
+ if (colorMap->getNumPixelComps() == 4)
@@ -2973,8 +2963,7 @@ void SlaOutputDev::drawImage(GfxState *state, Object *
delete image;
return;
@@ -608,7 +688,12 @@
: "(unnamed)");
goto err2;
}
-@@ -3488,7 +3477,7 @@ void SlaOutputDev::updateFont(GfxState *state)
+@@ -3484,11 +3473,11 @@ void SlaOutputDev::updateFont(GfxState *state)
+ if (n) {
+ codeToGID = (int *)gmallocn(n, sizeof(int));
+ memcpy(codeToGID, ((GfxCIDFont *)gfxFont)->getCIDToGID(),
+- n * sizeof(Gushort));
++ n * sizeof(unsigned short));
}
} else {
if (fileName)
@@ -626,6 +711,15 @@
: "(unnamed)");
goto err2;
}
+@@ -3559,7 +3548,7 @@ void SlaOutputDev::updateFont(GfxState *state)
+ GooString *fileName;
+ char *tmpBuf;
+ int tmpBufLen;
+- Gushort *codeToGID;
++ unsigned short *codeToGID;
+ DisplayFontParam *dfp;
+ double *textMat;
+ double m11, m12, m21, m22, fontSize;
@@ -3604,7 +3593,7 @@ void SlaOutputDev::updateFont(GfxState *state)
}
if (!dfp)
@@ -705,7 +799,16 @@
goto err2;
}
break;
-@@ -3703,7 +3692,7 @@ void SlaOutputDev::updateFont(GfxState *state)
+@@ -3696,14 +3685,14 @@ void SlaOutputDev::updateFont(GfxState *state)
+ n = ((GfxCIDFont *)gfxFont)->getCIDToGIDLen();
+ if (n)
+ {
+- codeToGID = (Gushort *)gmallocn(n, sizeof(Gushort));
+- memcpy(codeToGID, ((GfxCIDFont *)gfxFont)->getCIDToGID(), n * sizeof(Gushort));
++ codeToGID = (unsigned short *)gmallocn(n, sizeof(unsigned short));
++ memcpy(codeToGID, ((GfxCIDFont *)gfxFont)->getCIDToGID(), n * sizeof(unsigned short));
+ }
+ }
else
{
if (fileName)
@@ -723,6 +826,15 @@
goto err2;
}
break;
+@@ -3775,7 +3764,7 @@ void SlaOutputDev::drawChar(GfxState *state, double x,
+ qPath.setFillRule(Qt::WindingFill);
+ for (int i = 0; i < fontPath->getLength(); ++i)
+ {
+- Guchar f;
++ unsigned char f;
+ fontPath->getPoint(i, &x1, &y1, &f);
+ if (f & splashPathFirst)
+ qPath.moveTo(x1,y1);
@@ -3793,8 +3782,7 @@ void SlaOutputDev::drawChar(GfxState *state, double x,
if (f & splashPathLast)
qPath.closeSubpath();
diff --git a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h
index fce11994c7e5..7ec2a45fb445 100644
--- a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h
+++ b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h
@@ -1,6 +1,14 @@
---- scribus/plugins/import/pdf/slaoutput.h.orig 2018-12-11 13:04:07 UTC
+--- scribus/plugins/import/pdf/slaoutput.h.orig 2019-01-10 06:21:56 UTC
+++ scribus/plugins/import/pdf/slaoutput.h
-@@ -61,9 +61,9 @@ class LinkSubmitForm: public LinkAction (public)
+@@ -26,7 +26,6 @@ for which a new license (GPL+exception) is in place.
+ #include "selection.h"
+ #include "vgradient.h"
+
+-#include <poppler/goo/gtypes.h>
+ #include <poppler/Object.h>
+ #include <poppler/OutputDev.h>
+ #include <poppler/Gfx.h>
+@@ -61,9 +60,9 @@ class LinkSubmitForm: public LinkAction (public)
// Destructor.
virtual ~LinkSubmitForm();
// Was the LinkImportData created successfully?
@@ -12,7 +20,7 @@
GooString *getFileName() { return fileName; }
int getFlags() { return m_flags; }
private:
-@@ -83,9 +83,9 @@ class LinkImportData: public LinkAction (public)
+@@ -83,9 +82,9 @@ class LinkImportData: public LinkAction (public)
// Destructor.
virtual ~LinkImportData();
// Was the LinkImportData created successfully?
@@ -24,7 +32,7 @@
GooString *getFileName() { return fileName; }
private:
GooString *fileName; // file name
-@@ -98,9 +98,9 @@ class SplashOutFontFileID: public SplashFontFileID
+@@ -98,9 +97,9 @@ class SplashOutFontFileID: public SplashFontFileID
{
public:
@@ -36,7 +44,7 @@
{
return ((SplashOutFontFileID *)id)->r.num == r.num && ((SplashOutFontFileID *)id)->r.gen == r.gen;
}
-@@ -115,18 +115,18 @@ class AnoOutputDev : public OutputDev
+@@ -115,18 +114,18 @@ class AnoOutputDev : public OutputDev
public:
AnoOutputDev(ScribusDoc* doc, QStringList *importedColors);
virtual ~AnoOutputDev();
@@ -64,7 +72,7 @@
QString CurrColorText;
QString CurrColorFill;
-@@ -135,7 +135,7 @@ class AnoOutputDev : public OutputDev
+@@ -135,7 +134,7 @@ class AnoOutputDev : public OutputDev
GooString *m_fontName;
GooString *m_itemText;
private:
@@ -73,7 +81,7 @@
ScribusDoc* m_doc;
QStringList *m_importedColors;
};
-@@ -148,7 +148,7 @@ class SlaOutputDev : public OutputDev (public)
+@@ -148,7 +147,7 @@ class SlaOutputDev : public OutputDev (public)
virtual ~SlaOutputDev();
LinkAction* SC_getAction(AnnotWidget *ano);
LinkAction* SC_getAdditionalAction(const char *key, AnnotWidget *ano);
@@ -82,7 +90,7 @@
bool handleTextAnnot(Annot* annota, double xCoor, double yCoor, double width, double height);
bool handleLinkAnnot(Annot* annota, double xCoor, double yCoor, double width, double height);
bool handleWidgetAnnot(Annot* annota, double xCoor, double yCoor, double width, double height);
-@@ -156,15 +156,15 @@ class SlaOutputDev : public OutputDev (public)
+@@ -156,15 +155,15 @@ class SlaOutputDev : public OutputDev (public)
void handleActions(PageItem* ite, AnnotWidget *ano);
void startDoc(PDFDoc *doc, XRef *xrefA, Catalog *catA);
@@ -107,7 +115,7 @@
virtual void startPage(int pageNum, GfxState *, XRef *);
virtual void endPage();
// graphics state
-@@ -175,30 +175,30 @@ class SlaOutputDev : public OutputDev (public)
+@@ -175,30 +174,30 @@ class SlaOutputDev : public OutputDev (public)
virtual void stroke(GfxState *state);
virtual void fill(GfxState *state);
virtual void eoFill(GfxState *state);
@@ -149,7 +157,7 @@
{
return state->getFillColorSpace()->getMode() == csPattern;
}
-@@ -206,36 +206,36 @@ class SlaOutputDev : public OutputDev (public)
+@@ -206,36 +205,36 @@ class SlaOutputDev : public OutputDev (public)
virtual void endMaskClip(GfxState *state) { qDebug() << "End Mask Clip"; }
//----- grouping operators
@@ -198,7 +206,7 @@
virtual void clearSoftMask(GfxState * /*state*/);
virtual void updateFillColor(GfxState *state);
-@@ -245,7 +245,7 @@ class SlaOutputDev : public OutputDev (public)
+@@ -245,7 +244,7 @@ class SlaOutputDev : public OutputDev (public)
virtual void beginTextObject(GfxState *state);
virtual void endTextObject(GfxState *state);
virtual void drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/);
@@ -207,7 +215,7 @@
virtual void endType3Char(GfxState * /*state*/);
virtual void type3D0(GfxState * /*state*/, double /*wx*/, double /*wy*/);
virtual void type3D1(GfxState * /*state*/, double /*wx*/, double /*wy*/, double /*llx*/, double /*lly*/, double /*urx*/, double /*ury*/);
-@@ -260,13 +260,13 @@ class SlaOutputDev : public OutputDev (public)
+@@ -260,13 +259,13 @@ class SlaOutputDev : public OutputDev (public)
private:
void getPenState(GfxState *state);
@@ -225,7 +233,7 @@
bool checkClip();
bool pathIsClosed;
QString CurrColorFill;
-@@ -283,9 +283,9 @@ class SlaOutputDev : public OutputDev (public)
+@@ -283,9 +282,9 @@ class SlaOutputDev : public OutputDev (public)
struct groupEntry
{
QList<PageItem*> Items;