aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-04 08:54:13 +0800
committerbapt <bapt@FreeBSD.org>2014-01-04 08:54:13 +0800
commita7b5f7dcfb604c9e5d280d286f262a63b5b58946 (patch)
tree282105d1534b821136343dde77bd34bd5520668c
parent5658bba1d9ed5e9db8e3b856e05c3bf7ade256fa (diff)
downloadfreebsd-ports-gnome-a7b5f7dcfb604c9e5d280d286f262a63b5b58946.tar.gz
freebsd-ports-gnome-a7b5f7dcfb604c9e5d280d286f262a63b5b58946.tar.zst
freebsd-ports-gnome-a7b5f7dcfb604c9e5d280d286f262a63b5b58946.zip
Fix pkgname conflicts
-rw-r--r--archivers/rpm/Makefile2
-rw-r--r--archivers/rpm4/Makefile2
-rw-r--r--archivers/rpm5/Makefile4
3 files changed, 4 insertions, 4 deletions
diff --git a/archivers/rpm/Makefile b/archivers/rpm/Makefile
index 082e719cd043..94b6b5ef7826 100644
--- a/archivers/rpm/Makefile
+++ b/archivers/rpm/Makefile
@@ -14,7 +14,7 @@ COMMENT= The Red Hat Package Manager
LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
-CONFLICTS= rpm-[45].*
+CONFLICTS= rpm-[45].* rpm[45]-*
NO_STAGE= yes
USES= gmake
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index f53ab58ecc61..5e8ee8ca6289 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -27,7 +27,7 @@ USE_BDB= 46+
INVALID_BDB_VER=51
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFLICTS_INSTALL= rpm-[35].*
+CONFLICTS_INSTALL= rpm-[35].* rpm5-*
SHEBANG_FILES= scripts/brp-python-bytecompile scripts/check-prereqs \
scripts/check-rpaths-worker scripts/pythondeps.sh \
scripts/mono-find-requires scripts/mono-find-provides \
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
index ff701e6908a9..a15292ee6592 100644
--- a/archivers/rpm5/Makefile
+++ b/archivers/rpm5/Makefile
@@ -6,6 +6,7 @@ PORTVERSION= 5.2.1
PORTREVISION= 3
CATEGORIES= archivers
MASTER_SITES= http://rpm5.org/files/rpm/rpm-${PORTVERSION:R}/
+PKGNAMESUFFIX= 5
MAINTAINER= afb@rpm5.org
COMMENT= The RPM Package Manager
@@ -36,8 +37,7 @@ CONFIGURE_ARGS= --without-js
USES= gmake perl5
USE_PERL5= build
USE_LDCONFIG= yes
-LATEST_LINK= rpm5
-CONFLICTS= rpm-3.* rpm-4.*
+CONFLICTS= rpm-3.* rpm-4.* rpm4-*
.include <bsd.port.options.mk>