aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2015-05-24 05:26:36 +0800
committerohauer <ohauer@FreeBSD.org>2015-05-24 05:26:36 +0800
commita8d57f7ae5804ff1589650f4f743618ba4869ecd (patch)
treefd9bdd1d7cb6b7f98ca7501b2efb7373fce0ae4a
parent75c1eb1ba6b942f5a3a15e155659a414df1d1ab8 (diff)
downloadfreebsd-ports-gnome-a8d57f7ae5804ff1589650f4f743618ba4869ecd.tar.gz
freebsd-ports-gnome-a8d57f7ae5804ff1589650f4f743618ba4869ecd.tar.zst
freebsd-ports-gnome-a8d57f7ae5804ff1589650f4f743618ba4869ecd.zip
- update to r1676013
- make threads mandatory - enable posix-shm
-rw-r--r--devel/apr2/Makefile16
-rw-r--r--devel/apr2/distinfo4
-rw-r--r--devel/apr2/files/patch-build__apr_hints.m46
-rw-r--r--devel/apr2/files/patch-build__iconv.m46
-rw-r--r--devel/apr2/files/patch-buildconf8
5 files changed, 20 insertions, 20 deletions
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 1a21fda2f9df..639d6d4a456e 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -5,8 +5,8 @@ PORTNAME= apr
PORTVERSION= 2.0.${SNAPDATE}
CATEGORIES= devel
MASTER_SITES= LOCAL/ohauer
-DISTNAME= ${PORTNAME}_${SNAPDATE}
PKGNAMESUFFIX= 2
+DISTNAME= ${PORTNAME}_${SNAPDATE}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache Portability Library
@@ -17,10 +17,11 @@ LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
NO_PACKAGE= yes
-SNAPDATE= 20140626144503
+# r1676013
+SNAPDATE= 20150425134304
USES= autoreconf:build cpe iconv libtool pathfix perl5 \
- python:2,build tar:xz
+ python:2.7,build tar:xz
CPE_PRODUCT= apr-util
CPE_VENDOR= apache
CPE_VERSION= ${PORTVERSION:S|.${SNAPDATE}||}
@@ -31,7 +32,7 @@ GNU_CONFIGURE= yes
OPTIONS_SUB= yes
OPTIONS_DEFINE= DEVELOPER_ONLY
OPTIONS_GROUP= APR APU
-OPTIONS_GROUP_APR= THREADS IPV6 DEVRANDOM
+OPTIONS_GROUP_APR= IPV6 DEVRANDOM
OPTIONS_GROUP_APU= BDB GDBM MYSQL NDBM PGSQL SQLITE
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= SSL NSS
@@ -46,9 +47,6 @@ SSL_DESC= OpenSSL crypto driver
WRKSRC= ${WRKDIR}/apr
DEVRANDOM_CONFIGURE_WITH= devrandom
-# is there a valid requirement to build without threads
-# if not make thread a mandantory default
-THREADS_CONFIGURE_ENABLE= threads
# APR-Util Options
BDB_USE= BDB=48+
@@ -80,6 +78,8 @@ NSS_CONFIGURE_WITH= nss=${LOCALBASE}
CONFIGURE_ENV+= CC="${CC}"
CONFIGURE_ARGS+=--with-installbuilddir=${DATADIR}/build-2 \
+ --enable-threads \
+ --enable-posix-shm \
--with-expat=${LOCALBASE} \
--with-iconv=${ICONV_PREFIX}
@@ -107,7 +107,7 @@ CONFIGURE_ARGS+= --without-crypto
post-patch:
${REINPLACE_CMD} -e 's|%%OSVERSION%%|${OSVERSION}|g' ${WRKSRC}/build/apr_hints.m4
- ${REINPLACE_CMD} -e '1s|${SETENV} python|${LOCALBASE}/bin/${PYTHON_VERSION}|' \
+ ${REINPLACE_CMD} -e '1s|${SETENV} python|${PYTHON_CMD}|' \
${WRKSRC}/build/gen-build.py
${REINPLACE_CMD} -e 's|PrintPath python|PrintPath ${PYTHON_VERSION}|' \
-e 's|python -c|${PYTHON_VERSION} -c|' \
diff --git a/devel/apr2/distinfo b/devel/apr2/distinfo
index 1744cd244833..09c6180cd4d1 100644
--- a/devel/apr2/distinfo
+++ b/devel/apr2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (apr_20140626144503.tar.xz) = b9e5a644c6852ec1980ddbc2724e3fe24584104e40fecbc5c87ddf0b34a1c17e
-SIZE (apr_20140626144503.tar.xz) = 727996
+SHA256 (apr_20150425134304.tar.xz) = 4eecb26847a61b5b65e88c6c5ff00f970073db63330358d0b7cab5e961b889e6
+SIZE (apr_20150425134304.tar.xz) = 736364
diff --git a/devel/apr2/files/patch-build__apr_hints.m4 b/devel/apr2/files/patch-build__apr_hints.m4
index 0b8a380869ab..c0918aceba2a 100644
--- a/devel/apr2/files/patch-build__apr_hints.m4
+++ b/devel/apr2/files/patch-build__apr_hints.m4
@@ -1,6 +1,6 @@
---- ./build/apr_hints.m4.orig 2010-02-06 16:14:03.000000000 -0500
-+++ ./build/apr_hints.m4 2010-05-26 23:19:19.263812317 -0400
-@@ -159,15 +159,11 @@
+--- build/apr_hints.m4.orig 2015-04-05 07:04:48 UTC
++++ build/apr_hints.m4
+@@ -147,15 +147,11 @@ dnl # Not a problem in 10.20. Ot
;;
*-freebsd*)
APR_SETIFNULL(apr_lock_method, [USE_FLOCK_SERIALIZE])
diff --git a/devel/apr2/files/patch-build__iconv.m4 b/devel/apr2/files/patch-build__iconv.m4
index d27eb6a6ee93..25966d2363dc 100644
--- a/devel/apr2/files/patch-build__iconv.m4
+++ b/devel/apr2/files/patch-build__iconv.m4
@@ -1,6 +1,6 @@
---- ./build/iconv.m4.orig 2010-05-26 23:19:28.011405098 -0400
-+++ ./build/iconv.m4 2010-05-26 23:19:37.002271826 -0400
-@@ -44,7 +44,7 @@
+--- build/iconv.m4.orig 2015-01-02 17:14:32 UTC
++++ build/iconv.m4
+@@ -44,7 +44,7 @@ AC_ARG_WITH(iconv,[ --with-iconv[=DIR]
if test -f "$apu_iconv_dir/include/iconv.h"; then
have_iconv="1"
APR_ADDTO(CPPFLAGS,[-I$apu_iconv_dir/include])
diff --git a/devel/apr2/files/patch-buildconf b/devel/apr2/files/patch-buildconf
index 985d119bb2f0..7261d3eda3ce 100644
--- a/devel/apr2/files/patch-buildconf
+++ b/devel/apr2/files/patch-buildconf
@@ -1,6 +1,6 @@
---- ./buildconf.orig 2011-08-10 22:03:47.000000000 +0200
-+++ ./buildconf 2011-08-10 22:08:22.000000000 +0200
-@@ -81,6 +81,7 @@
+--- buildconf.orig 2015-01-02 17:14:31 UTC
++++ buildconf
+@@ -81,6 +81,7 @@ if test "$1" = "1"; then
fi
# Do we need this anymore?
echo "buildconf: Using libtool.m4 at ${ltfile}."
@@ -8,7 +8,7 @@
rm -f build/libtool.m4
cp -p $ltfile build/libtool.m4
-@@ -94,9 +95,12 @@
+@@ -94,9 +95,12 @@ fi
# Not sure, would it interfere with httpd top_builddir when bundled?
mv build/libtool.m4 build/libtool.m4.$$
sed -e 's/\(LIBTOOL=.*\)top_build/\1apr_build/' < build/libtool.m4.$$ > build/libtool.m4