aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-07-11 03:25:03 +0800
committerkrion <krion@FreeBSD.org>2004-07-11 03:25:03 +0800
commitaa2ae8f55bb62e651fb81428224b9b1a8eb18baf (patch)
treeacebe1da164f34f1f4b676af43676c975e6e0d10
parent5886fb8ec54689066f2f72e44740b805bd5420d2 (diff)
downloadfreebsd-ports-gnome-aa2ae8f55bb62e651fb81428224b9b1a8eb18baf.tar.gz
freebsd-ports-gnome-aa2ae8f55bb62e651fb81428224b9b1a8eb18baf.tar.zst
freebsd-ports-gnome-aa2ae8f55bb62e651fb81428224b9b1a8eb18baf.zip
Support WITHOUT_NLS
-rw-r--r--misc/hello/Makefile9
-rw-r--r--misc/hello/pkg-plist62
2 files changed, 39 insertions, 32 deletions
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index 707985db1482..afc1f68a3dba 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -15,11 +15,18 @@ MASTER_SITE_SUBDIR= hello
MAINTAINER= shipley@dis.org
COMMENT= A utility for saying hello to the world and reading email
-USE_GETTEXT= YES
USE_PERL5_BUILD= YES
GNU_CONFIGURE= YES
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= hello.1
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.include <bsd.port.mk>
diff --git a/misc/hello/pkg-plist b/misc/hello/pkg-plist
index ca2f7d5a0c3f..914c002038dc 100644
--- a/misc/hello/pkg-plist
+++ b/misc/hello/pkg-plist
@@ -2,34 +2,34 @@ bin/hello
@unexec install-info --delete %D/info/hello.info %D/info/dir
info/hello.info
@exec install-info --dir-file=%D/info/dir --entry="* Hello: (hello). Hello Reference Manual." %D/info/hello.info
-share/locale/ca/LC_MESSAGES/hello.mo
-share/locale/da/LC_MESSAGES/hello.mo
-share/locale/de/LC_MESSAGES/hello.mo
-share/locale/de_DE/LC_MESSAGES/hello.mo
-share/locale/el/LC_MESSAGES/hello.mo
-share/locale/eo/LC_MESSAGES/hello.mo
-share/locale/es/LC_MESSAGES/hello.mo
-share/locale/et/LC_MESSAGES/hello.mo
-share/locale/fi/LC_MESSAGES/hello.mo
-share/locale/fr/LC_MESSAGES/hello.mo
-share/locale/gl/LC_MESSAGES/hello.mo
-share/locale/he/LC_MESSAGES/hello.mo
-share/locale/hr/LC_MESSAGES/hello.mo
-share/locale/hu/LC_MESSAGES/hello.mo
-share/locale/id/LC_MESSAGES/hello.mo
-share/locale/it/LC_MESSAGES/hello.mo
-share/locale/ja/LC_MESSAGES/hello.mo
-share/locale/ko/LC_MESSAGES/hello.mo
-share/locale/lv/LC_MESSAGES/hello.mo
-share/locale/nb/LC_MESSAGES/hello.mo
-share/locale/nl/LC_MESSAGES/hello.mo
-share/locale/nn/LC_MESSAGES/hello.mo
-share/locale/pl/LC_MESSAGES/hello.mo
-share/locale/pt/LC_MESSAGES/hello.mo
-share/locale/pt_BR/LC_MESSAGES/hello.mo
-share/locale/ru/LC_MESSAGES/hello.mo
-share/locale/sk/LC_MESSAGES/hello.mo
-share/locale/sl/LC_MESSAGES/hello.mo
-share/locale/sv/LC_MESSAGES/hello.mo
-share/locale/tr/LC_MESSAGES/hello.mo
-share/locale/uk/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/da/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/de/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/el/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/es/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/et/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/he/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/id/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/it/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/hello.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/hello.mo