aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-07 01:22:52 +0800
committeraz <az@FreeBSD.org>2012-06-07 01:22:52 +0800
commitaa2dbf15fbd5cb5ac364caf1f4228d8efb437158 (patch)
tree1b3c2e52046872caf1fd9697d9186df694c4f55e
parent726cca3ddc54b6abeaf2cfcc6731a0cdc60df2c9 (diff)
downloadfreebsd-ports-gnome-aa2dbf15fbd5cb5ac364caf1f4228d8efb437158.tar.gz
freebsd-ports-gnome-aa2dbf15fbd5cb5ac364caf1f4228d8efb437158.tar.zst
freebsd-ports-gnome-aa2dbf15fbd5cb5ac364caf1f4228d8efb437158.zip
- Remove SITE_PERL from *_DEPENDS
-rw-r--r--security/p5-Authen-Captcha/Makefile2
-rw-r--r--security/p5-Authen-Simple-DBI/Makefile4
-rw-r--r--security/p5-Authen-Simple-HTTP/Makefile4
-rw-r--r--security/p5-Crypt-Blowfish/Makefile2
-rw-r--r--security/p5-Crypt-CBCeasy/Makefile16
-rw-r--r--security/p5-Crypt-DES/Makefile2
-rw-r--r--security/p5-Crypt-DSA/Makefile6
-rw-r--r--security/p5-Crypt-Random/Makefile4
-rw-r--r--security/p5-Crypt-SSLeay/Makefile2
-rw-r--r--security/p5-Crypt-xDBM_File/Makefile2
-rw-r--r--security/p5-Digest-MD5/Makefile2
-rw-r--r--security/p5-GD-SecurityImage/Makefile4
-rw-r--r--security/p5-Net-OpenID-JanRain/Makefile8
-rw-r--r--security/p5-SHA/Makefile2
-rw-r--r--security/p5-Sudo/Makefile6
15 files changed, 33 insertions, 33 deletions
diff --git a/security/p5-Authen-Captcha/Makefile b/security/p5-Authen-Captcha/Makefile
index bece76f21b41..5bb800d20403 100644
--- a/security/p5-Authen-Captcha/Makefile
+++ b/security/p5-Authen-Captcha/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module to verify the human element in transactions
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Authen-Simple-DBI/Makefile b/security/p5-Authen-Simple-DBI/Makefile
index b406522a0db7..afbcc05ed20f 100644
--- a/security/p5-Authen-Simple-DBI/Makefile
+++ b/security/p5-Authen-Simple-DBI/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple DBI authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_SAFE= yes
diff --git a/security/p5-Authen-Simple-HTTP/Makefile b/security/p5-Authen-Simple-HTTP/Makefile
index faf85bfa36fa..69b62813c114 100644
--- a/security/p5-Authen-Simple-HTTP/Makefile
+++ b/security/p5-Authen-Simple-HTTP/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple HTTP authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_SAFE= yes
diff --git a/security/p5-Crypt-Blowfish/Makefile b/security/p5-Crypt-Blowfish/Makefile
index f3531e063db1..e57be1bc97e1 100644
--- a/security/p5-Crypt-Blowfish/Makefile
+++ b/security/p5-Crypt-Blowfish/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to the Blowfish encryption alogorithm
-BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+BUILD_DEPENDS= p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC
WRKSRC= ${WRKDIR}/${DISTNAME:C/a$//}
PERL_CONFIGURE= yes
diff --git a/security/p5-Crypt-CBCeasy/Makefile b/security/p5-Crypt-CBCeasy/Makefile
index 107c28498edb..b12672d2eec9 100644
--- a/security/p5-Crypt-CBCeasy/Makefile
+++ b/security/p5-Crypt-CBCeasy/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Easy things make really easy with Crypt::CBC
-BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
- ${SITE_PERL}/MD5.pm:${PORTSDIR}/security/p5-MD5
+BUILD_DEPENDS= p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC \
+ p5-MD5>=0:${PORTSDIR}/security/p5-MD5
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -34,22 +34,22 @@ RIJNDAEL_DESC= Build with Crypt::Rijndael support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDES}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
+BUILD_DEPENDS+= p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES
.endif
.if ${PORT_OPTIONS:MIDEA}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/IDEA.pm:${PORTSDIR}/security/p5-Crypt-IDEA
+BUILD_DEPENDS+= p5-Crypt-IDEA>=0:${PORTSDIR}/security/p5-Crypt-IDEA
.endif
.if ${PORT_OPTIONS:MBLOWFISH}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish
+BUILD_DEPENDS+= p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish
.endif
.if ${PORT_OPTIONS:MBLOWFISH_PP}
-BUILD_DEPENDS+= ${SITE_PERL}/Crypt/Blowfish_PP.pm:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
+BUILD_DEPENDS+= p5-Crypt-Blowfish_PP>=0:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
.endif
.if ${PORT_OPTIONS:MTWOFISH2}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Twofish2.pm:${PORTSDIR}/security/p5-Crypt-Twofish2
+BUILD_DEPENDS+= p5-Crypt-Twofish2>=0:${PORTSDIR}/security/p5-Crypt-Twofish2
.endif
.if ${PORT_OPTIONS:MRIJNDAEL}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael
+BUILD_DEPENDS+= p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael
.endif
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-DES/Makefile b/security/p5-Crypt-DES/Makefile
index 038f6c16a857..c8e32d5f815e 100644
--- a/security/p5-Crypt-DES/Makefile
+++ b/security/p5-Crypt-DES/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to DES block cipher
-BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+BUILD_DEPENDS= p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Crypt-DSA/Makefile b/security/p5-Crypt-DSA/Makefile
index 7bf9540618c0..edda7a5635fd 100644
--- a/security/p5-Crypt-DSA/Makefile
+++ b/security/p5-Crypt-DSA/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= DSA signature and key generation
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/Convert/PEM.pm:${PORTSDIR}/converters/p5-Convert-PEM \
- ${SITE_PERL}/Data/Buffer.pm:${PORTSDIR}/misc/p5-Data-Buffer \
+RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Convert-PEM>=0:${PORTSDIR}/converters/p5-Convert-PEM \
+ p5-Data-Buffer>=0:${PORTSDIR}/misc/p5-Data-Buffer \
p5-File-Which>=0.05:${PORTSDIR}/sysutils/p5-File-Which
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/security/p5-Crypt-Random/Makefile b/security/p5-Crypt-Random/Makefile
index 122e3428c2ef..fe56fe82d46d 100644
--- a/security/p5-Crypt-Random/Makefile
+++ b/security/p5-Crypt-Random/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Cryptographically Secure, True Random Number Generator
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
- ${SITE_PERL}/Class/Loader.pm:${PORTSDIR}/devel/p5-Class-Loader
+BUILD_DEPENDS= p5-Math-Pari>=0:${PORTSDIR}/math/p5-Math-Pari \
+ p5-Class-Loader>=0:${PORTSDIR}/devel/p5-Class-Loader
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Crypt-SSLeay/Makefile b/security/p5-Crypt-SSLeay/Makefile
index d48b0a6d246b..3b52a9720abd 100644
--- a/security/p5-Crypt-SSLeay/Makefile
+++ b/security/p5-Crypt-SSLeay/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to allow p5-libwww LWP to make https connections
-BUILD_DEPENDS= ${SITE_PERL}/URI/URL.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Crypt-xDBM_File/Makefile b/security/p5-Crypt-xDBM_File/Makefile
index a89568080599..910b6f7c06e3 100644
--- a/security/p5-Crypt-xDBM_File/Makefile
+++ b/security/p5-Crypt-xDBM_File/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module encrypt almost any kind of dbm file
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish
+BUILD_DEPENDS= p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Digest-MD5/Makefile b/security/p5-Digest-MD5/Makefile
index e21ae3184e58..c12835eaa231 100644
--- a/security/p5-Digest-MD5/Makefile
+++ b/security/p5-Digest-MD5/Makefile
@@ -21,7 +21,7 @@ MAN3= Digest::MD5.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500803
-RUN_DEPENDS+= ${SITE_PERL}/Digest/base.pm:${PORTSDIR}/security/p5-Digest
+RUN_DEPENDS+= p5-Digest>=0:${PORTSDIR}/security/p5-Digest
.endif
.include <bsd.port.post.mk>
diff --git a/security/p5-GD-SecurityImage/Makefile b/security/p5-GD-SecurityImage/Makefile
index 2216ec5493a2..a69019d029b9 100644
--- a/security/p5-GD-SecurityImage/Makefile
+++ b/security/p5-GD-SecurityImage/Makefile
@@ -34,8 +34,8 @@ MAN3= GD::SecurityImage.3 \
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMAGEMAGICK}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+BUILD_DEPENDS+= ImageMagick>=0:${PORTSDIR}/graphics/ImageMagick
+RUN_DEPENDS+= ImageMagick>=0:${PORTSDIR}/graphics/ImageMagick
.endif
.include <bsd.port.pre.mk>
diff --git a/security/p5-Net-OpenID-JanRain/Makefile b/security/p5-Net-OpenID-JanRain/Makefile
index 21d9c0131fb4..41407d228fbf 100644
--- a/security/p5-Net-OpenID-JanRain/Makefile
+++ b/security/p5-Net-OpenID-JanRain/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= OpenID JanRain and Consumer with JanRain API
-BUILD_DEPENDS= ${SITE_PERL}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/LWPx/ParanoidAgent.pm:${PORTSDIR}/www/p5-LWPx-ParanoidAgent \
- ${SITE_PERL}/Net/Yadis.pm:${PORTSDIR}/net/p5-Net-Yadis \
+BUILD_DEPENDS= p5-Crypt-DH>=0:${PORTSDIR}/security/p5-Crypt-DH \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-LWPx-ParanoidAgent>=0:${PORTSDIR}/www/p5-LWPx-ParanoidAgent \
+ p5-Net-Yadis>=0:${PORTSDIR}/net/p5-Net-Yadis \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/security/p5-SHA/Makefile b/security/p5-SHA/Makefile
index 2a1f5fd02e8b..3e812d0bd76c 100644
--- a/security/p5-SHA/Makefile
+++ b/security/p5-SHA/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to the SHA1 algorithm
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Sudo/Makefile b/security/p5-Sudo/Makefile
index 02fb51902dd7..0defedf4f486 100644
--- a/security/p5-Sudo/Makefile
+++ b/security/p5-Sudo/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for running a command line sudo
-BUILD_DEPENDS= ${SITE_PERL}/Term/ReadPassword.pm:${PORTSDIR}/devel/p5-Term-ReadPassword \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+BUILD_DEPENDS= p5-Term-ReadPassword>=0:${PORTSDIR}/devel/p5-Term-ReadPassword \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes