aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhibbits <jhibbits@FreeBSD.org>2018-01-10 11:51:12 +0800
committerjhibbits <jhibbits@FreeBSD.org>2018-01-10 11:51:12 +0800
commitaa3d920458678f55c37367e9ab8f4025e4744043 (patch)
treee13cc3f904795bbe7a6dacae4aa13cd171a89fc2
parent5c2cecea076b5403f62a23cbf96867dfcafba9ec (diff)
downloadfreebsd-ports-gnome-aa3d920458678f55c37367e9ab8f4025e4744043.tar.gz
freebsd-ports-gnome-aa3d920458678f55c37367e9ab8f4025e4744043.tar.zst
freebsd-ports-gnome-aa3d920458678f55c37367e9ab8f4025e4744043.zip
Add support for GCC-based targets to luajit
Summary: luajit requires CC to be passed on the command line, not via the Make environment in order to override the Makefile. Pass it explicitly, and for GCC targets (powerpc, mips, sparc64) explicitly use ports GCC. Reviewed By: mat Differential Revision: https://reviews.freebsd.org/D13804
-rw-r--r--lang/luajit/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index 68ba24986a40..940f05536427 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -14,11 +14,16 @@ COMMENT= Just-In-Time Compiler for Lua
WRKSRC= ${WRKDIR}/LuaJIT-${DISTVERSION}
USES= gmake
USE_LDCONFIG= yes
+MAKE_ARGS= CC=${CC}
PLIST_SUB+= VERSION=${DISTVERSION}
+BROKEN_powerpc64= Not ported to powerpc64 upstream
-ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
-ONLY_FOR_ARCHS_REASON= Requires newer gcc/clang to compile.
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc*} || ${ARCH:Mmips*} || ${ARCH:Msparc*}
+USE_GCC=yes
+.endif
post-install:
${LN} -sf ${PORTNAME}-${DISTVERSION} \