aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2019-11-15 04:09:10 +0800
committerehaupt <ehaupt@FreeBSD.org>2019-11-15 04:09:10 +0800
commitab3d2109c7170d74b3136a88d74bdfcb302f810f (patch)
tree06969d4cc9d763113baf5ecf8d9a4869a57e698a
parentac11cd067984e0d69b77d867ca616aa52af42857 (diff)
downloadfreebsd-ports-gnome-ab3d2109c7170d74b3136a88d74bdfcb302f810f.tar.gz
freebsd-ports-gnome-ab3d2109c7170d74b3136a88d74bdfcb302f810f.tar.zst
freebsd-ports-gnome-ab3d2109c7170d74b3136a88d74bdfcb302f810f.zip
Fix build on GCC architectures
PR: 241894 Submitted by: pkubaj MFH: 2019Q4 (blanket)
-rw-r--r--net-mgmt/driftnet/Makefile1
-rw-r--r--net-mgmt/driftnet/files/patch-configure.ac11
2 files changed, 11 insertions, 1 deletions
diff --git a/net-mgmt/driftnet/Makefile b/net-mgmt/driftnet/Makefile
index 85216791baa9..e6abbc55efbf 100644
--- a/net-mgmt/driftnet/Makefile
+++ b/net-mgmt/driftnet/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= makedepend:devel/makedepend
GNU_CONFIGURE= yes
USES= autoreconf gettext-runtime gmake gnome jpeg localbase:ldflags \
pkgconfig xorg
+USE_CSTD= c99
USE_GITHUB= yes
USE_GNOME= gtk20
USE_XORG= x11 xext xi
diff --git a/net-mgmt/driftnet/files/patch-configure.ac b/net-mgmt/driftnet/files/patch-configure.ac
index 3998e1c88f1c..41a82111be90 100644
--- a/net-mgmt/driftnet/files/patch-configure.ac
+++ b/net-mgmt/driftnet/files/patch-configure.ac
@@ -1,4 +1,4 @@
---- configure.ac.orig 2018-09-15 19:08:05 UTC
+--- configure.ac.orig 2019-10-19 17:01:57 UTC
+++ configure.ac
@@ -22,7 +22,7 @@ build_linux=no
build_mac=no
@@ -9,3 +9,12 @@
build_linux=yes
;;
cygwin*|mingw*)
+@@ -69,7 +69,7 @@ AC_ARG_ENABLE([debug],
+ [enable_debug=yes])
+
+ if test "x$enable_debug" = xyes; then
+- CFLAGS="-O2 -g -DDEBUG"
++ CFLAGS+="-O2 -g -DDEBUG"
+ else
+ CFLAGS="-O2 -DNDEBUG"
+ fi