aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-03-22 20:05:59 +0800
committerrafan <rafan@FreeBSD.org>2008-03-22 20:05:59 +0800
commitaddc7fdb9637dc4c4f999b8f70cfecad9563dcbd (patch)
tree821e3b75bf66639879ee86d772da4999c05c576d
parent24927dbe2f61dcfcb371ee796c08e9225e744a37 (diff)
downloadfreebsd-ports-gnome-addc7fdb9637dc4c4f999b8f70cfecad9563dcbd.tar.gz
freebsd-ports-gnome-addc7fdb9637dc4c4f999b8f70cfecad9563dcbd.tar.zst
freebsd-ports-gnome-addc7fdb9637dc4c4f999b8f70cfecad9563dcbd.zip
coWPAtty is designed to audit the security of pre-shared keys
(PSK) selected in WiFi Protected Access (WPA) networks. WWW: http://www.willhackforsushi.com/Cowpatty.html PR: ports/121931 Submitted by: Dennis Herrmann <adox at mcx2.org>
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/cowpatty/Makefile36
-rw-r--r--net-mgmt/cowpatty/distinfo3
-rw-r--r--net-mgmt/cowpatty/files/patch-Makefile36
-rw-r--r--net-mgmt/cowpatty/files/pkg-message.in8
-rw-r--r--net-mgmt/cowpatty/pkg-descr4
6 files changed, 88 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 4d43a3658f9e..9def61d81aed 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -47,6 +47,7 @@
SUBDIR += clog
SUBDIR += collectd
SUBDIR += confregdecode
+ SUBDIR += cowpatty
SUBDIR += cricket
SUBDIR += darkstat
SUBDIR += disco
diff --git a/net-mgmt/cowpatty/Makefile b/net-mgmt/cowpatty/Makefile
new file mode 100644
index 000000000000..c29f785831f7
--- /dev/null
+++ b/net-mgmt/cowpatty/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: cowpatty
+# Date created: March 20, 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cowpatty
+PORTVERSION= 4.3
+CATEGORIES= net-mgmt security
+MASTER_SITES= http://www.willhackforsushi.com/code/cowpatty/4.3/ \
+ http://mcx2.org/files/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= adox@mcx2.org
+COMMENT= Brute-force dictionary attack against WPA-PSK
+
+PORTDOCS= FAQ README
+SUB_FILES= pkg-message
+
+USE_OPENSSL= yes
+
+PLIST_FILES= bin/cowpatty bin/genpmk
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "Installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+ @${ECHO_MSG} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/cowpatty/distinfo b/net-mgmt/cowpatty/distinfo
new file mode 100644
index 000000000000..74b044f282e8
--- /dev/null
+++ b/net-mgmt/cowpatty/distinfo
@@ -0,0 +1,3 @@
+MD5 (cowpatty-4.3.tgz) = deccac0763a05ef7014107d347bf9190
+SHA256 (cowpatty-4.3.tgz) = b82154c9183fed3c26226c124f5e50ef38adaaafc84c5a13d9256b1ebd489bca
+SIZE (cowpatty-4.3.tgz) = 103720
diff --git a/net-mgmt/cowpatty/files/patch-Makefile b/net-mgmt/cowpatty/files/patch-Makefile
new file mode 100644
index 000000000000..3ebe33c0f7dd
--- /dev/null
+++ b/net-mgmt/cowpatty/files/patch-Makefile
@@ -0,0 +1,36 @@
+--- Makefile.orig 2008-03-20 21:36:01.000000000 +0100
++++ Makefile 2008-03-20 21:40:39.000000000 +0100
+@@ -1,21 +1,11 @@
+-##################################
+-# <jwright> Well, I may be doing stupid things with make
+-# <jwright> OK, it was Makefile stupid'ness
+-# <jwright> I don't really understand what the hell I am doing with Make, I'm
+-# just copying other files and seeing what works.
+-# <dragorn> heh
+-# <dragorn> i think thats all anyone does
+-# <dragorn> make is a twisted beast
+-##################################
+ LDLIBS = -lpcap
+ CFLAGS = -pipe -Wall -DOPENSSL
+ CFLAGS += -O2
+ LDLIBS += -lcrypto
+ CFLAGS += -g3 -ggdb
+-#CFLAGS += -static
+ PROGOBJ = md5.o sha1.o utils.o cowpatty.o genpmk.o
+ PROG = cowpatty genpmk
+-BINDIR = /usr/local/bin
++PREFIX?= /usr/local
+
+ all: $(PROGOBJ) $(PROG)
+
+@@ -44,8 +34,5 @@
+ @ls -l $(PROG)
+
+ install: all
+- install -d $(DESTDIR)$(BINDIR)
+- install -m 755 $(PROG) $(BINDIR)$(DESTDIR)
+-
+-love:
+- @echo "Not right now, I have a headache."
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -m 755 $(PROG) $(PREFIX)/bin
diff --git a/net-mgmt/cowpatty/files/pkg-message.in b/net-mgmt/cowpatty/files/pkg-message.in
new file mode 100644
index 000000000000..9bd537f852e7
--- /dev/null
+++ b/net-mgmt/cowpatty/files/pkg-message.in
@@ -0,0 +1,8 @@
+###########################################################################
+cowpatty has been installed
+
+If you have questions read %%DOCSDIR%%/FAQ
+For more information about coWPAtty visit:
+
+http://www.willhackforsushi.com/Cowpatty.html
+###########################################################################
diff --git a/net-mgmt/cowpatty/pkg-descr b/net-mgmt/cowpatty/pkg-descr
new file mode 100644
index 000000000000..7da225a4da4d
--- /dev/null
+++ b/net-mgmt/cowpatty/pkg-descr
@@ -0,0 +1,4 @@
+coWPAtty is designed to audit the security of pre-shared keys
+(PSK) selected in WiFi Protected Access (WPA) networks.
+
+WWW: http://www.willhackforsushi.com/Cowpatty.html
mitgraph'>* Update to the 20051122 snapshot of GCC 3.4.5.gerald2005-11-292-11/+16 * Update to the 20051115 snapshot of GCC 3.4.5.gerald2005-11-162-11/+11 * Update to the 20051108 snapshot of GCC 3.4.5.gerald2005-11-092-11/+11 * Update to the 20050920 snapshot of GCC 3.4.5.gerald2005-09-222-11/+11 * Update to the 20050913 snapshot of GCC 3.4.5.gerald2005-09-143-27/+11 * Update to the 20050906 snapshot of GCC 3.4.5.gerald2005-09-112-11/+11 * Fix bug where static forward declarations weren't accepted.obrien2005-09-071-0/+16 * Remove extraneous patch I had erroneously included in the previous update.gerald2005-09-021-20/+0 * Prevent running ranlib during installation to unbreak user modegerald2005-09-012-0/+21 * Update to the 20050830 snapshot of GCC 3.4.5.gerald2005-08-312-11/+11 * Update to the 20050823 snapshot of GCC 3.4.5.gerald2005-08-292-11/+11 * Update to the 20050726 snapshot of GCC 3.4.5.gerald2005-07-272-11/+11 * Update wrt. the removal of Java support.gerald2005-07-221-3/+3 * Update to the 20050719 snapshot of GCC 3.4.5. Should now work on FreeBSD 7.gerald2005-07-212-11/+11 * We no longer install any libraries to $PREFIX/lib, so remove this fromgerald2005-07-191-1/+1 * Update to the 20050712 snapshot of GCC 3.4.5.gerald2005-07-142-14/+14 * Update to the 20050628 snapshot of GCC 3.4.5.gerald2005-07-062-20/+13 * Remove support for Java, not the least because libjava only builds on i386,gerald2005-07-063-64/+5 * Update to the 20050607 snapshot GCC 3.4.5.gerald2005-06-092-13/+13 * Update to the 20050531 snapshot of GCC 3.4.5.gerald2005-06-022-13/+13 * Update to the 20050524 snapshot of GCC 3.4.5.gerald2005-05-262-13/+13 * Fix the handling of man pages on systems with an old version of Perl, oncegerald2005-05-231-1/+1 * Update to the 20050520 snapshot of 3.4.5. Simplify the handling of mangerald2005-05-222-23/+21 * We no longer need to/should remove libdata/pkgconfig.gerald2005-05-171-1/+0 * Update to the 20050513 snapshot of GCC 3.4.4.gerald2005-05-173-42/+27 * Update to the 20050506 snapshot of GCC 3.4.4. Fix some portlint warningsgerald2005-05-092-15/+15 * Add -fPIC to CXXFLAGS for static builds on alpha for 4.x. Should not begerald2005-05-071-0/+3 * Update to the 20050429 snapshot of GCC 3.4.4.gerald2005-05-012-13/+13 * Update to the 20050422 snapshot of GCC 3.4.4.gerald2005-04-252-13/+13 * Update to the 20050415 snapshot of GCC 3.4.4.gerald2005-04-182-13/+13 * Update to the 20050408 snapshot of GCC 3.4.4.gerald2005-04-112-13/+13 * On alpha, we need at least GCC 3.3 to bootstrap GCC 3.4 or well'll getgerald2005-04-041-0/+4 * Update to the 20050401 snapshot of GCC 3.4.4.gerald2005-04-032-13/+13 * Update to the 20050311 snapshot of GCC 3.4.4.gerald2005-03-162-13/+13 * Update to the 20050211 snapshot of GCC 3.4.4.gerald2005-02-132-13/+13 * Update to the 20050128 snapshot of GCC 3.4.4.gerald2005-01-292-13/+13 * Update to the 20050114 snapshot of GCC 3.4.4.gerald2005-01-172-13/+13 * Update to the 20050107 snapshot of GCC 3.4.4.gerald2005-01-102-13/+13 * Update to the 20041224 snapshot of GCC 3.4.4.gerald2004-12-252-13/+13 * Update to the 20041217 snapshot of GCC 3.4.4. On the way, properly removegerald2004-12-203-13/+14 * Back out to original. Maho (myself) committedmaho2004-12-167-73/+107 * gcc-ooo, gcc compiler for OpenOffice.org 2.0 or latermaho2004-12-167-107/+73 * Update to the 20041210 snapshot of GCC 3.4.4.gerald2004-12-162-13/+13 * Add missing quote in post-build target (which is a real bug, but had notgerald2004-12-101-1/+1 * Update to the 20041203 snapshot of GCC 3.4.4.gerald2004-12-072-13/+13 * Update to the 20041126 snapshot of GCC 3.4.4.gerald2004-11-302-13/+13 * Update to the 20041119 snapshot of GCC 3.4.4.gerald2004-11-222-13/+13 * Update to the 20041112 snapshot, the first of 3.4.4.gerald2004-11-142-14/+14 * Update to the 20041105 snapshot.gerald2004-11-082-13/+13 * Catch the 'cklatest' target up to changes on the MASTER_SITES.obrien2004-11-061-1/+1 * Update to the 20041029 snapshot of GCC 3.4.3.gerald2004-10-312-13/+13 * Update to the 20041015 snapshot of GCC 3.4.3.gerald2004-10-222-14/+14 * Update to the 20040827 snapshot of GCC 3.4.2.gerald2004-09-042-13/+13 * Fix location of pkgconfig-datavs2004-09-042-2/+12 * Update to the 20040806 snapshot off GCC 3.4.gerald2004-08-122-13/+13 * Update to the 2004-07-23 snapshot of GCC 3.4.2.gerald2004-07-252-13/+13 * Update to the 20040709 snapshot of GCC 3.4.2 (from GCC 3.4.1).gerald2004-07-112-14/+14 * Update to the 20040702 snapshot. Optimize that SNAPDATE variable away ongerald2004-07-042-17/+16 * Use ${ECHO} instead of echo.gerald2004-06-181-3/+3 * Update to the 2004-06-11 snapshot of GCC 3.4.1.gerald2004-06-172-13/+13 * Update to the 2004-06-04 snapshot of GCC 3.4.1.gerald2004-06-062-15/+15 * Update to the 2004-04-14 snapshot, which should be nearly identical to thegerald2004-04-182-14/+17 * I give up, gerald wants the cruft back in.obrien2004-03-231-0/+2 * Use a different method to remove possibly shared directory, so we canobrien2004-03-221-2/+2 * Re-commit revision 1.165. The perceived breakage by it was a bug in pkg-plist.obrien2004-03-221-2/+0 * Remove libexec/gcc/%%GNU_HOST%% and libexec/gcc on pkg_delete.obrien2004-03-211-0/+2 * Try to fix breakage of non-amd64 platforms introduced by 1.165 andgerald2004-03-171-13/+3 * Don't hardcode CONFIGURE_TARGET anymore -- the value in bsd.port.mk hasobrien2004-03-171-3/+2 * Add a WITHOUT_LIBJAVA know, which disables building libgcj and thus savesgerald2004-03-153-37/+50 * Adopt this port and update to the 2004-02-18 snapshot of GCC 3.4.gerald2004-02-202-45/+18 * Update to the 2004-02-11 snapshot of GCC 3.4.gerald2004-02-132-22/+24 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * Update to the 2004-01-28 snapshot of GCC 3.4. Merge in my 2004/01/26gerald2004-01-293-39/+38 * Update to the 2004-01-14 snapshot of GCC 3.4.gerald2004-01-224-38/+54 * Use the SORT macro from bsd.port.mk.trevor2004-01-221-1/+1 * Use PAX macro.trevor2004-01-221-1/+1 * Update to the 2004-01-07 snapshot of GCC 3.4. Merge in my 2004-01-05gerald2004-01-103-28/+13 * Fix packaging which was quite broken. On the way, update PORTVERSION togerald2004-01-102-7/+6 * Update to the 2003-12-31 snapshot.obrien2004-01-072-7/+7 * Update to the 2003-12-24 snapshot.obrien2003-12-264-19/+10 * Sync with gcc33/Makefile rev 1.146, which fixed my broken logic in theobrien2003-12-151-1/+1 * * Deal with GCC's configurary's assumption that /usr/local/{include,lib}obrien2003-12-153-0/+14 * Update to the 2003-12-10 mainline snapshot of GCC which has fixes for (atgerald2003-12-143-22/+36 * Really mark as broken.gerald2003-12-051-1/+1 * Update to the 2003-11-26 snapshot and fix several packaging issues.gerald2003-12-053-67/+17 * Update from repo-copy of lang/gcc33 to the 2003-11-12 snapshot of GCC 3.4.gerald2003-11-158-295/+45 * - ECHO -> ECHO_MSGedwin2003-09-271-3/+3 * Use ${STRIP_CMD} instead of strip. Strip some additional files and simplifygerald2003-07-121-17/+16 * My manpage creation fake-out broke with 3.1.1. Give up and add a buildobrien2003-07-121-0/+1 * Add checksum for bounds-checking-gcc-3.3-1.00.patch.bz2 lost by revision 1.69.gerald2003-07-101-0/+1 * Upgrade to the 7-July-2003 GCC 3.3.1 in-development snapshot.obrien2003-07-103-18/+17 * Add bounds-checking support using Herman ten Brugge's patches.gerald2003-06-183-1/+36 * Don't remove the share/java and share/java/classes system directories.kris2003-06-091-2/+0 * Update to the official release of GCC 3.3. On the way, somewhat restructuregerald2003-05-153-24/+20 * Update to the second prerelease of GCC 3.3. Add support for the coregerald2003-05-092-6/+16 * I now made .bz2 sources available on gcc.gnu.org, so again use these insteadgerald2003-05-081-3/+1 * Update to the first prerelease of GCC 3.3, which is only available as .tar.gz.gerald2003-05-073-38/+20 * Remove --with-gnu-as --with-gnu-ld, which are actually no-ops.gerald2003-05-061-1/+1 * Properly add the "[FreeBSD]" marker to the GCC version string also forgerald2003-05-061-1/+1 * G++ headers are now installed in c++/<gcc_ver> rather than g++-v3.obrien2003-05-061-1/+1 * Upgrade to the 28-April-2003 GCC 3.3 in-development snapshot.obrien2003-05-042-6/+6 * Upgrade to the 21-April-2003 GCC 3.3 in-development snapshot.obrien2003-04-282-6/+6 * Merge targets pre-configure and pre-build, simplify them, and removegerald2003-04-262-20/+2 * Make MAINTAINER overrideable by slave ports.gerald2003-04-251-1/+1 * Fifty-one months after ELF flag day, and after the system compiler becamegerald2003-04-243-96/+0 * Further fixes to pkg-plist. (Tested according to Porter's Handbook 2.4 ongerald2003-04-231-3/+1 * Allow YACC to be used, rather than Bison, for C/C++.obrien2003-04-231-0/+29 * merge changes from gcc32 to gcc33 after testingdinoex2003-04-212-7/+36 * Not sure how I missed these patches in my 24-March-2003 GCC 3.3obrien2003-04-212-90/+10 * Remove files/patch-t-freebsd. The underlying problem has been fixed ingerald2003-04-171-10/+0 * Remove the last part of jdp's profile fixes from 1998/10/08, which actuallygerald2003-04-151-11/+0 * Appease portlint by various whitespace changes. Remove last traces ofgerald2003-04-061-12/+8 * Finally remove the parts of this patch that date back to 1998 and have nowgerald2003-04-031-24/+0 * Remove special alpha optimization warning. alpha support now should begerald2003-04-021-20/+0 * LATEST_LINK can now be overwritten by the slave port.dinoex2003-03-311-1/+1 * Upgrade to the 24-March-2003 GCC 3.3 in-development snapshot.obrien2003-03-303-18/+60 * Fix COMMENT and a Makefile comment.gerald2003-03-251-2/+2 * De-pkg-comment.knu2003-02-212-1/+1 * Use the most modern spelling of egcs.cygnus.com.obrien2002-12-041-1/+1 * The effort to maintain these for FreeBSD just isn't worth it with the lackobrien2002-11-051-1/+1 * Use MASTER_SITES_GCC.knu2002-10-201-3/+2 * Upgrade to the 14-Oct-2002 GCC 3.3 in-development snapshot.obrien2002-10-182-9/+9 * Upgrade to a 7-Oct-2002 GCC 3.3 in-development checkout.obrien2002-10-115-146/+165 * ftp://ftp.netwinder.org/ is no longer a MASTER_SITE.gerald2002-07-311-1/+0 * This is now in the stock FSF sources.obrien2002-05-191-64/+0 * Upgrade to a 18-May-2002 GCC 3.2 in-development checkout.obrien2002-05-181-15/+15 * GCC 2.95 and later aren't called egcs (any longer). Also updategerald2002-04-172-13/+3 * GCC 2.95 and later aren't called egcs (any longer), so remove two patchesgerald2002-04-122-23/+0 * Upgrade to a 06-April-2002 GCC 3.2 in-development checkout.obrien2002-04-072-30/+30 * Upgrade to a 27-March-2002 GCC 3.2 in-development checkout.obrien2002-03-292-24/+28 * Upgrade to a 12-March-2002 GCC 3.2 in-development checkout.obrien2002-03-131-2/+2 * Upgrade to the 10-March-2002 GCC 3.2 in-development snapshot.obrien2002-03-132-41/+46 * Mark broken while I find a suitable snapshot.obrien2002-03-101-0/+1 * Sync with gcc30's style.obrien2002-03-053-85/+39 * Upgrade to the 25-Feb-2002 GCC 3.1 development snapshot.obrien2002-03-033-28/+10 * Update to the 2002-02-04 snapshot.obrien2002-02-102-6/+6 * This allows the port to build, but it still has install problems.obrien2002-02-051-2/+5 * Upgrade to the 28-Jan-2002 GCC 3.1 development snapshot.obrien2002-02-0311-297/+202 * Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;knu2002-01-291-7/+7 * Style police: WWW tags should either end in a file/script or TRAILING /; Fix ...lioux2001-11-211-1/+1 * Utilize the PATCH_WRKDIR knob now that it exists.obrien2001-10-281-4/+1 * Major overhall and style clean up.obrien2001-08-161-27/+17 * Upgrade to the 30-April-2001 edition GCC 2.97 development snapshot.obrien2001-05-043-14/+29 * Upgrade to the 20-March-2001 edition GCC 2.97 development snapshot.obrien2001-03-242-6/+6 * Fix version number.obrien2001-03-111-1/+1 * Upgrade to the 5-March-2001 edition GCC 2.97 development snapshot.obrien2001-03-072-6/+6 * Fix nits in the auto lib-gcc PLIST generation.obrien2001-03-022-26/+14