aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2006-06-27 06:16:22 +0800
committerbsam <bsam@FreeBSD.org>2006-06-27 06:16:22 +0800
commitb48db50a9153b759352db999fb2478c8c3b8565a (patch)
treea0ae9623596d75b604440536f718d4d07f333412
parent636d907b8cb123613e594040956a2489a2775665 (diff)
downloadfreebsd-ports-gnome-b48db50a9153b759352db999fb2478c8c3b8565a.tar.gz
freebsd-ports-gnome-b48db50a9153b759352db999fb2478c8c3b8565a.tar.zst
freebsd-ports-gnome-b48db50a9153b759352db999fb2478c8c3b8565a.zip
o update Makefile to use bsd.linux-rpm.mk infrostructure;
o update to newer version 0.22.0.18 (for Fedora Core 4); o add fetching of the sources files when PACKAGE_BUILDING is enabled (needed according to GPL); o add support for amd64. Approved by: Seth Kingsley <sethk@meowfishies.com> (maintainer by email), netchild (mentor)
-rw-r--r--graphics/linux-f10-gdk-pixbuf/Makefile33
-rw-r--r--graphics/linux-f10-gdk-pixbuf/distinfo9
-rw-r--r--graphics/linux-f8-gdk-pixbuf/Makefile33
-rw-r--r--graphics/linux-f8-gdk-pixbuf/distinfo9
-rw-r--r--graphics/linux-gdk-pixbuf/Makefile33
-rw-r--r--graphics/linux-gdk-pixbuf/distinfo9
6 files changed, 39 insertions, 87 deletions
diff --git a/graphics/linux-f10-gdk-pixbuf/Makefile b/graphics/linux-f10-gdk-pixbuf/Makefile
index 1f048d96ecd0..6658bff8fd27 100644
--- a/graphics/linux-f10-gdk-pixbuf/Makefile
+++ b/graphics/linux-f10-gdk-pixbuf/Makefile
@@ -6,39 +6,20 @@
#
PORTNAME= gdk-pixbuf
-PORTVERSION= 0.22.0.12.fc2
-PORTREVISION= 1
+PORTVERSION= 0.22.0.18.fc4.2
CATEGORIES= graphics linux
-MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
-MASTER_SITE_SUBDIR=updates/${BASEVERSION}/${MACHINE_ARCH}
-PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}.${MACHINE_ARCH}
-EXTRACT_SUFX= .rpm
-EXTRACT_ONLY=
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}
MAINTAINER= sethk@meowfishies.com
COMMENT= Linux version of the graphic library for GTK+
-BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-
CONFLICTS= linux-gtk2*
-USE_LINUX_PREFIX=yes
-USE_LINUX= yes
-ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm
-NO_BUILD= yes
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 4
+ONLY_FOR_ARCHS= i386 amd64
+INSTALLS_SHLIB= yes
PLIST_SUB= VERSION=${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+).+/\1/}
-
-# Set the version of Fedora Core
-BASEVERSION?= 2
-RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm\
- --nodeps --replacepkgs
-
-do-install:
- @for rpm in ${DISTFILES}; do\
- ${ECHO_MSG} $$rpm;\
- rpm -U ${RPMFLAGS} ${DISTDIR}/${DIST_SUBDIR}/$$rpm || true;\
- done
+MD5_FILE?= ${PKGDIR}/distinfo
.include <bsd.port.mk>
diff --git a/graphics/linux-f10-gdk-pixbuf/distinfo b/graphics/linux-f10-gdk-pixbuf/distinfo
index 9e88227bbb11..419c0eac20fd 100644
--- a/graphics/linux-f10-gdk-pixbuf/distinfo
+++ b/graphics/linux-f10-gdk-pixbuf/distinfo
@@ -1,3 +1,6 @@
-MD5 (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = f56442e8a45c71b7004373b94acf5a9f
-SHA256 (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = 6b58395a9538990c6e735fe612034581312636d50f3366cd84f7d178bdb2efeb
-SIZE (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = 228423
+MD5 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = 212ce3ac8b0fe3f767048a2186cb3766
+SHA256 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = e1636bbf66356c8edee7d1197b10f315b3c3ee0d2e916e787f90762a2426b7d7
+SIZE (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = 230909
+MD5 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = 7c780b05008f3e1999bf8abbb0bb7b7a
+SHA256 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = c6359209f5d36974d2e4d2c0479eac138d25297abf89b36598755d1e32565c46
+SIZE (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = 424241
diff --git a/graphics/linux-f8-gdk-pixbuf/Makefile b/graphics/linux-f8-gdk-pixbuf/Makefile
index 1f048d96ecd0..6658bff8fd27 100644
--- a/graphics/linux-f8-gdk-pixbuf/Makefile
+++ b/graphics/linux-f8-gdk-pixbuf/Makefile
@@ -6,39 +6,20 @@
#
PORTNAME= gdk-pixbuf
-PORTVERSION= 0.22.0.12.fc2
-PORTREVISION= 1
+PORTVERSION= 0.22.0.18.fc4.2
CATEGORIES= graphics linux
-MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
-MASTER_SITE_SUBDIR=updates/${BASEVERSION}/${MACHINE_ARCH}
-PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}.${MACHINE_ARCH}
-EXTRACT_SUFX= .rpm
-EXTRACT_ONLY=
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}
MAINTAINER= sethk@meowfishies.com
COMMENT= Linux version of the graphic library for GTK+
-BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-
CONFLICTS= linux-gtk2*
-USE_LINUX_PREFIX=yes
-USE_LINUX= yes
-ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm
-NO_BUILD= yes
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 4
+ONLY_FOR_ARCHS= i386 amd64
+INSTALLS_SHLIB= yes
PLIST_SUB= VERSION=${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+).+/\1/}
-
-# Set the version of Fedora Core
-BASEVERSION?= 2
-RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm\
- --nodeps --replacepkgs
-
-do-install:
- @for rpm in ${DISTFILES}; do\
- ${ECHO_MSG} $$rpm;\
- rpm -U ${RPMFLAGS} ${DISTDIR}/${DIST_SUBDIR}/$$rpm || true;\
- done
+MD5_FILE?= ${PKGDIR}/distinfo
.include <bsd.port.mk>
diff --git a/graphics/linux-f8-gdk-pixbuf/distinfo b/graphics/linux-f8-gdk-pixbuf/distinfo
index 9e88227bbb11..419c0eac20fd 100644
--- a/graphics/linux-f8-gdk-pixbuf/distinfo
+++ b/graphics/linux-f8-gdk-pixbuf/distinfo
@@ -1,3 +1,6 @@
-MD5 (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = f56442e8a45c71b7004373b94acf5a9f
-SHA256 (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = 6b58395a9538990c6e735fe612034581312636d50f3366cd84f7d178bdb2efeb
-SIZE (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = 228423
+MD5 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = 212ce3ac8b0fe3f767048a2186cb3766
+SHA256 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = e1636bbf66356c8edee7d1197b10f315b3c3ee0d2e916e787f90762a2426b7d7
+SIZE (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = 230909
+MD5 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = 7c780b05008f3e1999bf8abbb0bb7b7a
+SHA256 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = c6359209f5d36974d2e4d2c0479eac138d25297abf89b36598755d1e32565c46
+SIZE (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = 424241
diff --git a/graphics/linux-gdk-pixbuf/Makefile b/graphics/linux-gdk-pixbuf/Makefile
index 1f048d96ecd0..6658bff8fd27 100644
--- a/graphics/linux-gdk-pixbuf/Makefile
+++ b/graphics/linux-gdk-pixbuf/Makefile
@@ -6,39 +6,20 @@
#
PORTNAME= gdk-pixbuf
-PORTVERSION= 0.22.0.12.fc2
-PORTREVISION= 1
+PORTVERSION= 0.22.0.18.fc4.2
CATEGORIES= graphics linux
-MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
-MASTER_SITE_SUBDIR=updates/${BASEVERSION}/${MACHINE_ARCH}
-PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}.${MACHINE_ARCH}
-EXTRACT_SUFX= .rpm
-EXTRACT_ONLY=
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}
MAINTAINER= sethk@meowfishies.com
COMMENT= Linux version of the graphic library for GTK+
-BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-
CONFLICTS= linux-gtk2*
-USE_LINUX_PREFIX=yes
-USE_LINUX= yes
-ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm
-NO_BUILD= yes
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 4
+ONLY_FOR_ARCHS= i386 amd64
+INSTALLS_SHLIB= yes
PLIST_SUB= VERSION=${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+).+/\1/}
-
-# Set the version of Fedora Core
-BASEVERSION?= 2
-RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm\
- --nodeps --replacepkgs
-
-do-install:
- @for rpm in ${DISTFILES}; do\
- ${ECHO_MSG} $$rpm;\
- rpm -U ${RPMFLAGS} ${DISTDIR}/${DIST_SUBDIR}/$$rpm || true;\
- done
+MD5_FILE?= ${PKGDIR}/distinfo
.include <bsd.port.mk>
diff --git a/graphics/linux-gdk-pixbuf/distinfo b/graphics/linux-gdk-pixbuf/distinfo
index 9e88227bbb11..419c0eac20fd 100644
--- a/graphics/linux-gdk-pixbuf/distinfo
+++ b/graphics/linux-gdk-pixbuf/distinfo
@@ -1,3 +1,6 @@
-MD5 (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = f56442e8a45c71b7004373b94acf5a9f
-SHA256 (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = 6b58395a9538990c6e735fe612034581312636d50f3366cd84f7d178bdb2efeb
-SIZE (rpm/gdk-pixbuf-0.22.0-12.fc2.i386.rpm) = 228423
+MD5 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = 212ce3ac8b0fe3f767048a2186cb3766
+SHA256 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = e1636bbf66356c8edee7d1197b10f315b3c3ee0d2e916e787f90762a2426b7d7
+SIZE (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.i386.rpm) = 230909
+MD5 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = 7c780b05008f3e1999bf8abbb0bb7b7a
+SHA256 (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = c6359209f5d36974d2e4d2c0479eac138d25297abf89b36598755d1e32565c46
+SIZE (rpm/i386/fedora/4/gdk-pixbuf-0.22.0-18.fc4.2.src.rpm) = 424241