aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-01-29 14:34:59 +0800
committerscheidell <scheidell@FreeBSD.org>2012-01-29 14:34:59 +0800
commitb6a809c50e373656ab0b3504fb86737f04b5470c (patch)
tree3df04e810f83eafc4c563867b8fb4dd05f88953a
parenta8ff9f054cb403cd4d0914c5c2e717021e4fec66 (diff)
downloadfreebsd-ports-gnome-b6a809c50e373656ab0b3504fb86737f04b5470c.tar.gz
freebsd-ports-gnome-b6a809c50e373656ab0b3504fb86737f04b5470c.tar.zst
freebsd-ports-gnome-b6a809c50e373656ab0b3504fb86737f04b5470c.zip
- patching *.pl files to remove deprecated use of defined(%a_hash) statements
- committer is now maintainer PR: ports/164560 Submitted by: Rickie Kerndt <kerndtr@kerndt.com> (maintainer) Approved by: maintainer, gabor (mentor, implicit)
-rw-r--r--www/mhonarc/Makefile3
-rw-r--r--www/mhonarc/files/patch-lib__mhamain.pl11
-rw-r--r--www/mhonarc/files/patch-lib__mhopt.pl11
-rw-r--r--www/mhonarc/files/patch-lib__readmail.pl74
4 files changed, 98 insertions, 1 deletions
diff --git a/www/mhonarc/Makefile b/www/mhonarc/Makefile
index 535425c4fbc5..13e1066da761 100644
--- a/www/mhonarc/Makefile
+++ b/www/mhonarc/Makefile
@@ -7,12 +7,13 @@
PORTNAME= mhonarc
PORTVERSION= 2.6.18
+PORTREVISION= 1
CATEGORIES= www mail
MASTER_SITES= http://www.mhonarc.org/release/MHonArc/tar/ \
http://www.oac.uci.edu/indiv/ehood/tar/
DISTNAME= MHonArc-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kerndtr@kerndt.com
COMMENT= WWW front end for mail archives
USE_BZIP2= Yes
diff --git a/www/mhonarc/files/patch-lib__mhamain.pl b/www/mhonarc/files/patch-lib__mhamain.pl
new file mode 100644
index 000000000000..12be664b2d57
--- /dev/null
+++ b/www/mhonarc/files/patch-lib__mhamain.pl
@@ -0,0 +1,11 @@
+--- ./lib/mhamain.pl.orig 2012-01-16 14:28:02.000000000 -0800
++++ ./lib/mhamain.pl 2012-01-16 14:31:22.000000000 -0800
+@@ -1561,7 +1561,7 @@
+ ## Create Index2MsgId if not defined
+ ##
+ sub defineIndex2MsgId {
+- if (!defined(%Index2MsgId)) {
++ if (!(%Index2MsgId)) {
+ foreach (keys %MsgId) {
+ $Index2MsgId{$MsgId{$_}} = $_;
+ }
diff --git a/www/mhonarc/files/patch-lib__mhopt.pl b/www/mhonarc/files/patch-lib__mhopt.pl
new file mode 100644
index 000000000000..3c5a9adcf991
--- /dev/null
+++ b/www/mhonarc/files/patch-lib__mhopt.pl
@@ -0,0 +1,11 @@
+--- ./lib/mhopt.pl.orig 2012-01-16 14:32:41.000000000 -0800
++++ ./lib/mhopt.pl 2012-01-16 14:33:10.000000000 -0800
+@@ -864,7 +864,7 @@
+ ##
+ sub update_data_2_1_to_later {
+ # we can preserve filter arguments
+- if (defined(%main::MIMEFiltersArgs)) {
++ if (%main::MIMEFiltersArgs) {
+ warn qq/ preserving MIMEARGS...\n/;
+ %readmail::MIMEFiltersArgs = %main::MIMEFiltersArgs;
+ $IsDefault{'MIMEARGS'} = 0;
diff --git a/www/mhonarc/files/patch-lib__readmail.pl b/www/mhonarc/files/patch-lib__readmail.pl
new file mode 100644
index 000000000000..1ba4d8afb885
--- /dev/null
+++ b/www/mhonarc/files/patch-lib__readmail.pl
@@ -0,0 +1,74 @@
+--- ./lib/readmail.pl.orig 2012-01-16 14:33:30.000000000 -0800
++++ ./lib/readmail.pl 2012-01-16 14:35:37.000000000 -0800
+@@ -117,9 +117,9 @@
+ ## set to true.
+
+ %MIMEDecoders = ()
+- unless defined(%MIMEDecoders);
++ unless (%MIMEDecoders);
+ %MIMEDecodersSrc = ()
+- unless defined(%MIMEDecodersSrc);
++ unless (%MIMEDecodersSrc);
+
+ ## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ ## %MIMECharSetConverters is the associative array for storing functions
+@@ -153,9 +153,9 @@
+ ## string.
+
+ %MIMECharSetConverters = ()
+- unless defined(%MIMECharSetConverters);
++ unless (%MIMECharSetConverters);
+ %MIMECharSetConvertersSrc = ()
+- unless defined(%MIMECharSetConvertersSrc);
++ unless (%MIMECharSetConvertersSrc);
+
+ ## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ ## %MIMEFilters is the associative array for storing functions that
+@@ -180,9 +180,9 @@
+ ## that all functions are defined before invoking MAILread_body.
+
+ %MIMEFilters = ()
+- unless defined(%MIMEFilters);
++ unless (%MIMEFilters);
+ %MIMEFiltersSrc = ()
+- unless defined(%MIMEFiltersSrc);
++ unless (%MIMEFiltersSrc);
+
+ ## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ ## %MIMEFiltersArgs is the associative array for storing any optional
+@@ -196,7 +196,7 @@
+ ## listed for a function if both are applicable.
+
+ %MIMEFiltersArgs = ()
+- unless defined(%MIMEFiltersArgs);
++ unless (%MIMEFiltersArgs);
+
+ ## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ ## %MIMEExcs is the associative array listing which data types
+@@ -206,7 +206,7 @@
+ ## Values => <should evaluate to a true expression>
+
+ %MIMEExcs = ()
+- unless defined(%MIMEExcs);
++ unless (%MIMEExcs);
+
+ ## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ ## %MIMEIncs is the associative array listing which data types
+@@ -220,7 +220,7 @@
+ ## be used to only allow a well-defined set of content-types.
+
+ %MIMEIncs = ()
+- unless defined(%MIMEIncs);
++ unless (%MIMEIncs);
+
+ ## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ ## %MIMECharsetAliases is a mapping of charset names to charset names.
+@@ -231,7 +231,7 @@
+ ## Values => real charset name
+ ##
+ %MIMECharsetAliases = ()
+- unless defined(%MIMECharsetAliases);
++ unless (%MIMECharsetAliases);
+
+ ##---------------------------------------------------------------------------
+ ## Text entity-related variables