aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-05-28 17:47:40 +0800
committermatthew <matthew@FreeBSD.org>2016-05-28 17:47:40 +0800
commitb89bf1f623cef4db839798678495e1a292787add (patch)
tree84977424b776c80618dc54ac51ebee3bb55715c8
parent08f4fd7be45533b085cb6102c7bc9125da8af2f0 (diff)
downloadfreebsd-ports-gnome-b89bf1f623cef4db839798678495e1a292787add.tar.gz
freebsd-ports-gnome-b89bf1f623cef4db839798678495e1a292787add.tar.zst
freebsd-ports-gnome-b89bf1f623cef4db839798678495e1a292787add.zip
- install the 'wordbreaker' program
- install the example minimum configuration file - use OPTION dependent targets for DOCS, EXAMPLES - always install man pages, irrespective of the DOCS option
-rw-r--r--textproc/sphinxsearch/Makefile46
-rw-r--r--textproc/sphinxsearch/distinfo1
-rw-r--r--textproc/sphinxsearch/pkg-plist12
3 files changed, 28 insertions, 31 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index bdb8824ee494..3cd5b89726da 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sphinxsearch
PORTVERSION= 2.2.10
+PORTREVISION= 1
CATEGORIES= textproc databases
MASTER_SITES= http://sphinxsearch.com/files/ \
http://snowball.tartarus.org/dist/:libstemmer
@@ -24,7 +25,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libexpat.so:textproc/expat2
OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
- RE2 SYSLOG UNIXODBC DOCS
+ RE2 SYSLOG UNIXODBC DOCS EXAMPLES
OPTIONS_DEFAULT=ICONV MYSQL SYSLOG
ICONV_CONFIGURE_WITH= iconv
@@ -56,7 +57,7 @@ LIBSTEMMER_DISTNAME= libstemmer_c
LIBSTEMMER_DISTFILES= ${LIBSTEMMER_DISTNAME}.tgz:libstemmer
.if make(makesum) || defined(FETCH_ALL)
-OPTIONS_SET_FORCE= LIBSTEMMER
+OPTIONS_SET_FORCE= LIBSTEMMER
.endif
# The port will successfully compile with both PGSQL and MYSQL support
@@ -89,8 +90,6 @@ UNIXODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
CONFLICTS= sphinxsearch-devel-[0-9]* dpsearch-[0-9]* rdb-[0-9]* \
swish++-[0-9]* xaira-[0-9]*
-.include <bsd.port.options.mk>
-
USERS?= _sphinx
GROUPS?= _sphinx
@@ -114,18 +113,19 @@ SUB_LIST+= PORTNAME=${PORTNAME} \
SPHINX_LOG=${SPHINX_LOG}
SUB_FILES+= pkg-deinstall
+BINS= indexer indextool spelldump wordbreaker
+
EXAMPLES= example.sql api
-DOCS= doc/sphinx.css doc/sphinx.html doc/sphinx.txt doc/sphinx.xml
+DOCS= doc/sphinx.css doc/sphinx.html doc/sphinx.txt doc/sphinx.xml \
+ sphinx-min.conf.dist
DOCSRC= ${WRKSRC}/doc
MAN1SRC= indexer.1 indextool.1 spelldump.1
MAN8SRC= searchd.8
-post-extract:
-.if ${PORT_OPTIONS:MLIBSTEMMER}
+post-extract-LIBSTEMMER-on:
@( cd ${WRKDIR} && ${COPYTREE_SHARE} ${LIBSTEMMER_DISTNAME} ${WRKSRC} )
-.endif
# Fix up the sample configuration file to correspond to FreeBSD norms
post-patch:
@@ -141,24 +141,12 @@ post-patch:
${DOCSRC}/${man}
.endfor
-do-install: install-bin install-docs install-man install-examples
-
-install-bin:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/indexer ${STAGEDIR}${PREFIX}/bin/indexer
- ${INSTALL_PROGRAM} ${WRKSRC}/src/indextool ${STAGEDIR}${PREFIX}/bin/indextool
- ${INSTALL_PROGRAM} ${WRKSRC}/src/spelldump ${STAGEDIR}${PREFIX}/bin/spelldump
- ${INSTALL_PROGRAM} ${WRKSRC}/src/searchd ${STAGEDIR}${PREFIX}/sbin/searchd
- ${INSTALL_DATA} ${WRKSRC}/sphinx.conf.dist ${STAGEDIR}${CFGFILE}.sample
-
-install-docs:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for doc in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+do-install:
+.for bin in ${BINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${bin} ${STAGEDIR}${PREFIX}/bin/${bin}
.endfor
-.endif
-
-install-man:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/searchd ${STAGEDIR}${PREFIX}/sbin/searchd
+ ${INSTALL_DATA} ${WRKSRC}/sphinx.conf.dist ${STAGEDIR}${CFGFILE}.sample
.for man in ${MAN1SRC}
${INSTALL_MAN} ${DOCSRC}/${man} ${STAGEDIR}${MANPREFIX}/man/man1/${man}
.endfor
@@ -166,7 +154,13 @@ install-man:
${INSTALL_MAN} ${DOCSRC}/${man} ${STAGEDIR}${MANPREFIX}/man/man8/${man}
.endfor
-install-examples:
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for example in ${EXAMPLES}
@cd ${WRKSRC} && ${COPYTREE_SHARE} ${example} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/textproc/sphinxsearch/distinfo b/textproc/sphinxsearch/distinfo
index e014bc228716..23308224804a 100644
--- a/textproc/sphinxsearch/distinfo
+++ b/textproc/sphinxsearch/distinfo
@@ -1,3 +1,4 @@
+TIMESTAMP = 1464425151
SHA256 (sphinx-2.2.10-release.tar.gz) = 054cb86e64bd48997d89386e1224d4405063d9857b2d7c33dc6cc1b9ef6df440
SIZE (sphinx-2.2.10-release.tar.gz) = 3109250
SHA256 (libstemmer_c.tgz) = 6530c3638f29f5b03bc3786bb9212e39adaf3bf15b5b0a483b2eb5111f7f416e
diff --git a/textproc/sphinxsearch/pkg-plist b/textproc/sphinxsearch/pkg-plist
index 5513b42edca7..45fc5a0467ca 100644
--- a/textproc/sphinxsearch/pkg-plist
+++ b/textproc/sphinxsearch/pkg-plist
@@ -1,12 +1,14 @@
bin/indexer
bin/indextool
bin/spelldump
-sbin/searchd
+bin/wordbreaker
@sample etc/sphinx.conf.sample
-%%PORTDOCS%%man/man1/indexer.1.gz
-%%PORTDOCS%%man/man1/indextool.1.gz
-%%PORTDOCS%%man/man1/spelldump.1.gz
-%%PORTDOCS%%man/man8/searchd.8.gz
+man/man1/indexer.1.gz
+man/man1/indextool.1.gz
+man/man1/spelldump.1.gz
+man/man8/searchd.8.gz
+sbin/searchd
+%%PORTDOCS%%%%DOCSDIR%%/sphinx-min.conf.dist
%%PORTDOCS%%%%DOCSDIR%%/sphinx.css
%%PORTDOCS%%%%DOCSDIR%%/sphinx.html
%%PORTDOCS%%%%DOCSDIR%%/sphinx.txt