aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-07-06 05:46:07 +0800
committerstephen <stephen@FreeBSD.org>2011-07-06 05:46:07 +0800
commitb93b3f8928af41437d38b3254f40a988986b0aa8 (patch)
treee9666c46feedf1cc5b8d3c1fa82bfaa15eae3715
parent7c180d768b22d36c4d574167bcbe90003c826abe (diff)
downloadfreebsd-ports-gnome-b93b3f8928af41437d38b3254f40a988986b0aa8.tar.gz
freebsd-ports-gnome-b93b3f8928af41437d38b3254f40a988986b0aa8.tar.zst
freebsd-ports-gnome-b93b3f8928af41437d38b3254f40a988986b0aa8.zip
- Add script to allow users to bind with nautilus.
- Bump portrevision. PR: ports/150361 Submitted by: Kuan-Chung Chiu <buganini@gmail.com> Approved by: maho (mentor)
-rw-r--r--multimedia/ffmpegthumbnailer/Makefile10
-rw-r--r--multimedia/ffmpegthumbnailer/files/bind-nautilus.sh16
-rw-r--r--multimedia/ffmpegthumbnailer/files/pkg-message.in2
-rw-r--r--multimedia/ffmpegthumbnailer/pkg-plist2
4 files changed, 27 insertions, 3 deletions
diff --git a/multimedia/ffmpegthumbnailer/Makefile b/multimedia/ffmpegthumbnailer/Makefile
index af15c521919d..06523dd30359 100644
--- a/multimedia/ffmpegthumbnailer/Makefile
+++ b/multimedia/ffmpegthumbnailer/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ffmpegthumbnailer
PORTVERSION= 2.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia graphics
MASTER_SITES= GOOGLE_CODE
@@ -17,8 +17,7 @@ LIB_DEPENDS= png:${PORTSDIR}/graphics/png \
swscale:${PORTSDIR}/multimedia/ffmpeg \
jpeg.11:${PORTSDIR}/graphics/jpeg
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
GNU_CONFIGURE= yes
@@ -28,7 +27,12 @@ USE_LDCONFIG= yes
MAN1= ffmpegthumbnailer.1
+SUB_FILES= pkg-message
+
post-install:
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} install-pkgconfigDATA
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${FILESDIR}/bind-nautilus.sh ${DATADIR}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/multimedia/ffmpegthumbnailer/files/bind-nautilus.sh b/multimedia/ffmpegthumbnailer/files/bind-nautilus.sh
new file mode 100644
index 000000000000..327f5db5bb83
--- /dev/null
+++ b/multimedia/ffmpegthumbnailer/files/bind-nautilus.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+# Use this script to bind ffmpegthumbnailer to nautilus.
+
+type="application@x-extension-webm video/3gpp video/3gpp2 video@avi \
+video@flv video@mkv video@mp4 video@mpeg video@ogg video@quicktime video@webm \
+video@x-avi video@x-flv video@x-m4v video@x-matroska video@x-mkv video@x-mp4 \
+video@x-mpeg video@x-ms-asf video@x-ms-wmv video@x-ms-wvx video@x-msvideo \
+video@x-msvideo@avi video@x-theora@ogg video@x-theora@ogv video@x-webm"
+
+cmd="/usr/bin/ffmpegthumbnailer -s %s -i %i -o %o -f"
+
+for i in $type; do
+gconftool-2 -s "/desktop/gnome/thumbnailers/$i/command" -t string "$cmd"
+gconftool-2 -s "/desktop/gnome/thumbnailers/$i/enable" -t boolean "true"
+done
diff --git a/multimedia/ffmpegthumbnailer/files/pkg-message.in b/multimedia/ffmpegthumbnailer/files/pkg-message.in
new file mode 100644
index 000000000000..bcf6cc1c9434
--- /dev/null
+++ b/multimedia/ffmpegthumbnailer/files/pkg-message.in
@@ -0,0 +1,2 @@
+Gnome users may bind ffmpegthumbnailer to nautilus using:
+%%DATADIR%%/bind-nautilus.sh.
diff --git a/multimedia/ffmpegthumbnailer/pkg-plist b/multimedia/ffmpegthumbnailer/pkg-plist
index 7f8e8fb27c5b..a4f514597ec6 100644
--- a/multimedia/ffmpegthumbnailer/pkg-plist
+++ b/multimedia/ffmpegthumbnailer/pkg-plist
@@ -10,4 +10,6 @@ lib/libffmpegthumbnailer.la
lib/libffmpegthumbnailer.so
lib/libffmpegthumbnailer.so.4
libdata/pkgconfig/libffmpegthumbnailer.pc
+%%DATADIR%%/bind-nautilus.sh
@dirrm include/libffmpegthumbnailer
+@dirrm %%DATADIR%%