aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-06 20:26:18 +0800
committerbapt <bapt@FreeBSD.org>2014-05-06 20:26:18 +0800
commitbb82b553a6fd2521e0e77b850bea21b689278cf1 (patch)
tree2635fccdae0b599e343b6c5fc45e86f779d5ac23
parent40de6a8143867d35347c6e31279f46aac8a519ef (diff)
downloadfreebsd-ports-gnome-bb82b553a6fd2521e0e77b850bea21b689278cf1.tar.gz
freebsd-ports-gnome-bb82b553a6fd2521e0e77b850bea21b689278cf1.tar.zst
freebsd-ports-gnome-bb82b553a6fd2521e0e77b850bea21b689278cf1.zip
Support stage
Modernize
-rw-r--r--math/libmissing/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/math/libmissing/Makefile b/math/libmissing/Makefile
index fe248f712f18..97b1126adcd6 100644
--- a/math/libmissing/Makefile
+++ b/math/libmissing/Makefile
@@ -9,17 +9,17 @@ MASTER_SITES= LOCAL/bf
MAINTAINER= bf@FreeBSD.org
COMMENT= Standard math functions missing from the FreeBSD libm
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
LIB_DEPENDS= libmpc.so:${PORTSDIR}/math/mpc
USE_LDCONFIG= yes
-USE_XZ= yes
+USES= tar:xz uidfix
MAKE_ENV= LDADD=-lmpc LIB=missing SHLIB_MAJOR="${SHLIB_MAJOR}" \
- SRCCONF=/dev/null SRCS="${SRCS}"
+ SRCCONF=/dev/null SRCS="${SRCS}" __MAKE_CONF=/dev/null
-OPTIONS_DEFINE= PROFILE
+OPTIONS_DEFINE= PROFILE EXAMPLES
PLIST_FILES= include/missing_complex.h \
include/missing_math.h \
@@ -31,19 +31,16 @@ SRCS= libmissing.c
CFLAGS+= -fno-builtin -fno-math-errno -I. -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+PORTEXAMPLES= ${SRCS}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${OSVERSION} > 1000054
LDFLAGS+= -Wl,-z,interpose
.endif
-.if ${PORT_OPTIONS:MPROFILE} || defined(WITH_PROFILE)
-.if defined(NOPROFILE) || defined(NO_PROFILE) || defined(WITHOUT_PROFILE)
-IGNORE = you have defined WITH_PROFILE, but have also defined\
-WITHOUT_PROFILE, NOPROFILE, or NO_PROFILE
-.elif !exists(/usr/lib/libc_p.a)
+.if ${PORT_OPTIONS:MPROFILE}
+.if !exists(/usr/lib/libc_p.a)
IGNORE = you have chosen WITH_PROFILE, but have not installed the\
base system profiling libraries
.endif
@@ -81,11 +78,8 @@ check regression-test test: build
post-install:
@cd ${WRKSRC}; ${INSTALL_DATA} missing_complex.h missing_math.h \
- ${PREFIX}/include
-.if !${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKSRC}; ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+ ${STAGEDIR}${PREFIX}/include
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @cd ${WRKSRC}; ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
-PORTEXAMPLES= ${SRCS}
-.endif
.include <bsd.port.mk>