aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-11-14 09:21:37 +0800
committervanilla <vanilla@FreeBSD.org>2013-11-14 09:21:37 +0800
commitbceb6ff6f88a3bf72e572f04ce11be41ca9e273f (patch)
treed2bb5cf78ac85dfc52c8a038a0ea33df6df8fff6
parent3eb2378e133797656b5ba6f70901e937a381454f (diff)
downloadfreebsd-ports-gnome-bceb6ff6f88a3bf72e572f04ce11be41ca9e273f.tar.gz
freebsd-ports-gnome-bceb6ff6f88a3bf72e572f04ce11be41ca9e273f.tar.zst
freebsd-ports-gnome-bceb6ff6f88a3bf72e572f04ce11be41ca9e273f.zip
Support STAGEDIR.
-rw-r--r--sysutils/gaffitter/Makefile9
-rw-r--r--sysutils/gkleds2/Makefile6
-rw-r--r--sysutils/gkleds2/pkg-plist3
-rw-r--r--sysutils/gkrellm-trayicons/Makefile5
-rw-r--r--sysutils/gkrellm-trayicons/pkg-plist3
-rw-r--r--sysutils/gkrellmwho2/Makefile5
-rw-r--r--sysutils/gkrellmwho2/pkg-plist3
-rw-r--r--sysutils/gtk-imonc/Makefile15
-rw-r--r--sysutils/gtk-imonc/pkg-plist4
-rw-r--r--sysutils/gtk-send-pr/Makefile12
10 files changed, 33 insertions, 32 deletions
diff --git a/sysutils/gaffitter/Makefile b/sysutils/gaffitter/Makefile
index c99b026e4424..965b32e49dd6 100644
--- a/sysutils/gaffitter/Makefile
+++ b/sysutils/gaffitter/Makefile
@@ -15,17 +15,16 @@ LICENSE= GPLv3 # or later
USE_BZIP2= yes
USES= gmake # parallel builds (-jX) are broken with BSD make(1)
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
# Change "cd foo; $(MAKE)" into "$(MAKE) -C foo" to unbreak parallel builds
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -E 's|cd (.+); (\$$\(MAKE\))|\2 -C \1|' \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|g' ${WRKSRC}/src/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/sysutils/gkleds2/Makefile b/sysutils/gkleds2/Makefile
index 2343d1facc2c..77e91ddde3dd 100644
--- a/sysutils/gkleds2/Makefile
+++ b/sysutils/gkleds2/Makefile
@@ -22,15 +22,13 @@ USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= libexec/gkrellm2/plugins/gkleds.so
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g ; \
s|GK_LDFLAGS|GKM_LDFLAGS|g' ${WRKSRC}/src/Makefile.in
do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
${INSTALL_DATA} ${WRKSRC}/src/.libs/gkleds.so \
- ${PREFIX}/libexec/gkrellm2/plugins
+ ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
.include <bsd.port.mk>
diff --git a/sysutils/gkleds2/pkg-plist b/sysutils/gkleds2/pkg-plist
new file mode 100644
index 000000000000..601e0c6cc284
--- /dev/null
+++ b/sysutils/gkleds2/pkg-plist
@@ -0,0 +1,3 @@
+libexec/gkrellm2/plugins/gkleds.so
+@dirrmtry libexec/gkrellm2/plugins
+@dirrmtry libexec/gkrellm2
diff --git a/sysutils/gkrellm-trayicons/Makefile b/sysutils/gkrellm-trayicons/Makefile
index 418f6979039c..30db9e697393 100644
--- a/sysutils/gkrellm-trayicons/Makefile
+++ b/sysutils/gkrellm-trayicons/Makefile
@@ -16,16 +16,15 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
USES= pkgconfig
-PLIST_FILES= libexec/gkrellm2/plugins/trayicons.so
ALL_TARGET= trayicons.so
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$$(CC) $$(FLAGS)|$$(CC) $$(CFLAGS)|g' \
${WRKSRC}/Makefile
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.so ${PREFIX}/libexec/gkrellm2/plugins/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.so ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins/
.include <bsd.port.mk>
diff --git a/sysutils/gkrellm-trayicons/pkg-plist b/sysutils/gkrellm-trayicons/pkg-plist
new file mode 100644
index 000000000000..0542ce3427e8
--- /dev/null
+++ b/sysutils/gkrellm-trayicons/pkg-plist
@@ -0,0 +1,3 @@
+libexec/gkrellm2/plugins/trayicons.so
+@dirrmtry libexec/gkrellm2/plugins
+@dirrmtry libexec/gkrellm2
diff --git a/sysutils/gkrellmwho2/Makefile b/sysutils/gkrellmwho2/Makefile
index b3e94d7e91e4..bf47040088b6 100644
--- a/sysutils/gkrellmwho2/Makefile
+++ b/sysutils/gkrellmwho2/Makefile
@@ -20,14 +20,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
USES= pkgconfig
ALL_TARGET=
-PLIST_FILES= libexec/gkrellm2/plugins/gkrellmwho2.so
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/configure ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gkrellmwho2.so ${PREFIX}/libexec/gkrellm2/plugins/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
+ ${INSTALL_PROGRAM} ${WRKSRC}/gkrellmwho2.so ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins/
.include <bsd.port.mk>
diff --git a/sysutils/gkrellmwho2/pkg-plist b/sysutils/gkrellmwho2/pkg-plist
new file mode 100644
index 000000000000..2e433afa7fc8
--- /dev/null
+++ b/sysutils/gkrellmwho2/pkg-plist
@@ -0,0 +1,3 @@
+libexec/gkrellm2/plugins/gkrellmwho2.so
+@dirrmtry libexec/gkrellm2/plugins
+@dirrmtry libexec/gkrellm2
diff --git a/sysutils/gtk-imonc/Makefile b/sysutils/gtk-imonc/Makefile
index 1a2761ca17e6..90e745db5f9d 100644
--- a/sysutils/gtk-imonc/Makefile
+++ b/sysutils/gtk-imonc/Makefile
@@ -12,13 +12,13 @@ COMMENT= GTK2-based imond-client to control an on(e) disc fli4l router
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- cairo:${PORTSDIR}/graphics/cairo \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
GNU_CONFIGURE= yes
USES= pkgconfig gettext iconv
@@ -29,7 +29,6 @@ USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|/gnome/apps/Internet|/applications|' ${WRKSRC}/Makefile.in
diff --git a/sysutils/gtk-imonc/pkg-plist b/sysutils/gtk-imonc/pkg-plist
index dc852cab7a8a..83d2b85d6d24 100644
--- a/sysutils/gtk-imonc/pkg-plist
+++ b/sysutils/gtk-imonc/pkg-plist
@@ -12,5 +12,5 @@ share/applications/gtk-imonc.desktop
%%DATADIR%%/pixmaps/shutdown.png
share/locale/de/LC_MESSAGES/gtk-imonc.mo
share/pixmaps/gtk-imonc.png
-@dirrm %%DATADIR%%/pixmaps
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%%/pixmaps
+@dirrmtry %%DATADIR%%
diff --git a/sysutils/gtk-send-pr/Makefile b/sysutils/gtk-send-pr/Makefile
index e9e26518f6bd..a92fdebe5570 100644
--- a/sysutils/gtk-send-pr/Makefile
+++ b/sysutils/gtk-send-pr/Makefile
@@ -11,13 +11,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK2 send-pr tool
-LIB_DEPENDS= esmtp.7:${PORTSDIR}/mail/libesmtp
+LIB_DEPENDS= libesmtp.so:${PORTSDIR}/mail/libesmtp
USES= pkgconfig
USE_GNOME= gtk20
-MAN1= gtk-send-pr.1
-PLIST_FILES= bin/gtk-send-pr share/pixmaps/ladybird64.xpm
+PLIST_FILES= bin/gtk-send-pr man/man1/${PORTNAME}.1.gz share/pixmaps/ladybird64.xpm
DESKTOP_ENTRIES="Send Problem Report" \
"Send a FreeBSD PR" \
"${PREFIX}/share/pixmaps/ladybird64.xpm" \
@@ -25,10 +24,9 @@ DESKTOP_ENTRIES="Send Problem Report" \
"System;" \
true
-NO_STAGE= yes
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/gtk-send-pr ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/common/gtk-send-pr.1 ${PREFIX}/man/man1
- @${INSTALL_DATA} ${WRKSRC}/icon/ladybird64.xpm ${PREFIX}/share/pixmaps
+ @${INSTALL_PROGRAM} ${WRKSRC}/gtk-send-pr ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/common/gtk-send-pr.1 ${STAGEDIR}${PREFIX}/man/man1
+ @${INSTALL_DATA} ${WRKSRC}/icon/ladybird64.xpm ${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>