aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-10-01 08:31:09 +0800
committerjbeich <jbeich@FreeBSD.org>2018-10-01 08:31:09 +0800
commitbe913c930d05b1c474cb54739b1310a807e9e581 (patch)
tree211cc0b69b113e6b815d6772c55a81a7940e85c7
parentff75cd2eba2d9c723c13e72703710e0a26ea37f4 (diff)
downloadfreebsd-ports-gnome-be913c930d05b1c474cb54739b1310a807e9e581.tar.gz
freebsd-ports-gnome-be913c930d05b1c474cb54739b1310a807e9e581.tar.zst
freebsd-ports-gnome-be913c930d05b1c474cb54739b1310a807e9e581.zip
devel/googletest: oops, builds fine with clang++ -stdlib=libstdc++ -std=gnu++03
FreeBSD 9.x defaulted to GCC 4.2 but could use Clang, so c++11-lang used Clang while c++11-lib use lang/gcc* bun nowadays the difference no longer exists. While testing previous change I forgot to account that newer Clang versions have switched to C++14 by default while libstdc++ 4.2 doesn't support C++11 or newer. PR: 231835
-rw-r--r--devel/googletest/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
index 971bb4b2fc6c..7ab6b4ccff24 100644
--- a/devel/googletest/Makefile
+++ b/devel/googletest/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= google
-USES= autoreconf compiler:c++11-lib libtool
+USES= autoreconf compiler:c++11-lang libtool
WRKSRC_SUBDIR= ${PORTNAME}
GNU_CONFIGURE= yes
# fused-src python tests are only useful for bundling. There's no point in