aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-31 14:48:18 +0800
committermiwi <miwi@FreeBSD.org>2014-01-31 14:48:18 +0800
commitbf096fb1762a7e58bd5747e71e46adaddb6d9004 (patch)
treeae5fc626a96a202811039f88b296d1dcf19361f4
parent8d7ac3038addd9f273493852391e73869cda6361 (diff)
downloadfreebsd-ports-gnome-bf096fb1762a7e58bd5747e71e46adaddb6d9004.tar.gz
freebsd-ports-gnome-bf096fb1762a7e58bd5747e71e46adaddb6d9004.tar.zst
freebsd-ports-gnome-bf096fb1762a7e58bd5747e71e46adaddb6d9004.zip
- Stage support
-rw-r--r--net-im/sendxmpp/Makefile6
-rw-r--r--net/clamz/Makefile8
-rw-r--r--net/clamz/pkg-plist1
-rw-r--r--net/nemesis/Makefile17
4 files changed, 15 insertions, 17 deletions
diff --git a/net-im/sendxmpp/Makefile b/net-im/sendxmpp/Makefile
index 767bca3f4d78..a987ba0560e1 100644
--- a/net-im/sendxmpp/Makefile
+++ b/net-im/sendxmpp/Makefile
@@ -16,11 +16,9 @@ RUN_DEPENDS+= p5-Net-XMPP>0.0:${PORTSDIR}/net-im/p5-Net-XMPP \
USES= perl5
USE_PERL5= configure
-MAN1= sendxmpp.1
-
PLIST_FILES= bin/sendxmpp \
- %%SITE_PERL%%/mach/auto/sendxmpp/.packlist
+ %%SITE_PERL%%/mach/auto/sendxmpp/.packlist \
+ man/man1/sendxmpp.1.gz
PLIST_DIRS= %%SITE_PERL%%/mach/auto/sendxmpp
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/clamz/Makefile b/net/clamz/Makefile
index ec6a8c48df23..86c1518d652a 100644
--- a/net/clamz/Makefile
+++ b/net/clamz/Makefile
@@ -20,12 +20,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
USES= pkgconfig
-MAN1= ${PORTNAME}.1
-
-NO_STAGE= yes
-post-install:
- @${ECHO}
- @${CAT} ${PKGMESSAGE}
- @${ECHO}
-
.include <bsd.port.mk>
diff --git a/net/clamz/pkg-plist b/net/clamz/pkg-plist
index 58bc1e9bbd6e..03cad0b48ac1 100644
--- a/net/clamz/pkg-plist
+++ b/net/clamz/pkg-plist
@@ -1,6 +1,7 @@
bin/clamz
share/applications/clamz.desktop
share/mime/packages/clamz.xml
+man/man1/clamz.1.gz
@dirrmtry share/mime/packages
@dirrmtry share/mime
@dirrmtry share
diff --git a/net/nemesis/Makefile b/net/nemesis/Makefile
index 0d2f35f798b7..2a7f49cb46b7 100644
--- a/net/nemesis/Makefile
+++ b/net/nemesis/Makefile
@@ -17,14 +17,21 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libnet-includes="${LOCALBASE}/include" \
--with-libnet-libraries="${LOCALBASE}/lib"
-MAN1= nemesis-arp.1 nemesis-dns.1 nemesis-ethernet.1 nemesis-icmp.1 \
- nemesis-igmp.1 nemesis-ip.1 nemesis-ospf.1 nemesis-rip.1 \
- nemesis-tcp.1 nemesis-udp.1 nemesis.1
-PLIST_FILES= bin/nemesis
+PLIST_FILES= bin/nemesis \
+ man/man1/nemesis-arp.1.gz \
+ man/man1/nemesis-dns.1.gz \
+ man/man1/nemesis-ethernet.1.gz \
+ man/man1/nemesis-icmp.1.gz \
+ man/man1/nemesis-igmp.1.gz \
+ man/man1/nemesis-ip.1.gz \
+ man/man1/nemesis-ospf.1.gz \
+ man/man1/nemesis-rip.1.gz \
+ man/man1/nemesis-tcp.1.gz \
+ man/man1/nemesis-udp.1.gz \
+ man/man1/nemesis.1.gz
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}