aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-04-30 10:22:56 +0800
committermiwi <miwi@FreeBSD.org>2013-04-30 10:22:56 +0800
commitc066aaf97f4fd1d105e8c6bd0b529b20975a4562 (patch)
tree6dced62a58d16a6b794e4d834b80740f0b5d918f
parent7c15dba657017dd3fabf3df1f4a98b76d2304a57 (diff)
downloadfreebsd-ports-gnome-c066aaf97f4fd1d105e8c6bd0b529b20975a4562.tar.gz
freebsd-ports-gnome-c066aaf97f4fd1d105e8c6bd0b529b20975a4562.tar.zst
freebsd-ports-gnome-c066aaf97f4fd1d105e8c6bd0b529b20975a4562.zip
- Update to 1.42
PR: 177924 Submitted by: Ports Fury
-rw-r--r--ftp/twoftpd/Makefile53
-rw-r--r--ftp/twoftpd/distinfo4
-rw-r--r--ftp/twoftpd/pkg-plist13
3 files changed, 33 insertions, 37 deletions
diff --git a/ftp/twoftpd/Makefile b/ftp/twoftpd/Makefile
index 5d89f9d7ff11..4e6f056e9225 100644
--- a/ftp/twoftpd/Makefile
+++ b/ftp/twoftpd/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: twoftpd
-# Date created: 14 September 2001
-# Whom: Gea-Suan Lin (gslin@ccca.nctu.edu.tw)
-#
+# Created by: Gea-Suan Lin (gslin@ccca.nctu.edu.tw)
# $FreeBSD$
-#
PORTNAME= twoftpd
-PORTVERSION= 1.41
-PORTREVISION= 1
+PORTVERSION= 1.42
CATEGORIES= ftp
MASTER_SITES= http://untroubled.org/${PORTNAME}/
@@ -15,32 +10,46 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A simple, secure, efficient FTP server
BUILD_DEPENDS= ${LOCALBASE}/bin/bg-installer:${PORTSDIR}/devel/bglibs
-LIB_DEPENDS= cvm-v2client.2:${PORTSDIR}/security/cvm
+LIB_DEPENDS= cvm-v2client:${PORTSDIR}/security/cvm
-CFLAGS+= -I${LOCALBASE}/include
-#-I${LOCALBASE}/include/bglibs
+#LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+
BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
BGLIBS_INCLUDE= ${LOCALBASE}/include/bglibs
-DOCS= NEWS README TODO
MAN1= twoftpd-auth.1 twoftpd-switch.1 twoftpd-xfer.1
+PORTDOCS= NEWS README TODO
+PLIST_FILES= bin/twoftpd-anon bin/twoftpd-anon-conf \
+ bin/twoftpd-auth bin/twoftpd-bind-port \
+ bin/twoftpd-conf bin/twoftpd-drop \
+ bin/twoftpd-switch bin/twoftpd-xfer
+
+.include <bsd.port.options.mk>
-do-patch:
- ${REINPLACE_CMD} -e 's,timezone,tm.tm_gmtoff,' ${WRKSRC}/statmod.c
+post-patch:
+ @${REINPLACE_CMD} -e 's,timezone,tm.tm_gmtoff,' ${WRKSRC}/statmod.c
do-configure:
- ${ECHO_CMD} "${PREFIX}/bin" > ${WRKSRC}/conf-bin
- ${ECHO_CMD} "${MANPREFIX}/man" > ${WRKSRC}/conf-man
- ${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
- ${ECHO_CMD} "${CC} ${STRIP} ${LDFLAGS}" > ${WRKSRC}/conf-ld
- ${ECHO_CMD} "${BGLIBS_INCLUDE}" > ${WRKSRC}/conf-bgincs
- ${ECHO_CMD} "${BGLIBS_LIB}" > ${WRKSRC}/conf-bglibs
-
-.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} "${PREFIX}/bin" > ${WRKSRC}/conf-bin
+ @${ECHO_CMD} "${MANPREFIX}/man" > ${WRKSRC}/conf-man
+ @${ECHO_CMD} "${CC} ${CFLAGS} ${CPPFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO_CMD} "${CC} ${STRIP} ${LDFLAGS}" > ${WRKSRC}/conf-ld
+ @${ECHO_CMD} "${BGLIBS_INCLUDE}" > ${WRKSRC}/conf-bgincs
+ @${ECHO_CMD} "${BGLIBS_LIB}" > ${WRKSRC}/conf-bglibs
+
post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.for i in NEWS README TODO
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/ftp/twoftpd/distinfo b/ftp/twoftpd/distinfo
index 38ff96b95b2c..188be1a24c6e 100644
--- a/ftp/twoftpd/distinfo
+++ b/ftp/twoftpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (twoftpd-1.41.tar.gz) = 1b269fdcef6a351ca339aa3516cda593c29c9bb2522eee1233f3815f0f59d683
-SIZE (twoftpd-1.41.tar.gz) = 84923
+SHA256 (twoftpd-1.42.tar.gz) = 5eafc789668e40122b8bb0c1f1bea407bba2e835227035f8475891e60169da66
+SIZE (twoftpd-1.42.tar.gz) = 87596
diff --git a/ftp/twoftpd/pkg-plist b/ftp/twoftpd/pkg-plist
deleted file mode 100644
index a3a7b3a5fead..000000000000
--- a/ftp/twoftpd/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-@comment $FreeBSD$
-bin/twoftpd-anon
-bin/twoftpd-anon-conf
-bin/twoftpd-auth
-bin/twoftpd-bind-port
-bin/twoftpd-conf
-bin/twoftpd-drop
-bin/twoftpd-switch
-bin/twoftpd-xfer
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%