aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-03-29 06:38:02 +0800
committerantoine <antoine@FreeBSD.org>2014-03-29 06:38:02 +0800
commitc0fc030c3c888618b63b6895f24b5e8aaa3d6373 (patch)
tree96fa5e40efc68308da36a363b7106af675df2757
parent00e03887df67e5792c9e1323ea19b56c5d0d8b2f (diff)
downloadfreebsd-ports-gnome-c0fc030c3c888618b63b6895f24b5e8aaa3d6373.tar.gz
freebsd-ports-gnome-c0fc030c3c888618b63b6895f24b5e8aaa3d6373.tar.zst
freebsd-ports-gnome-c0fc030c3c888618b63b6895f24b5e8aaa3d6373.zip
- Stage support
- Remove support for deprecated NOPORTDATA
-rw-r--r--x11-wm/ratpoison/Makefile13
-rw-r--r--x11-wm/ratpoison/pkg-plist23
2 files changed, 15 insertions, 21 deletions
diff --git a/x11-wm/ratpoison/Makefile b/x11-wm/ratpoison/Makefile
index f3b4590a46f7..a4c461fe487a 100644
--- a/x11-wm/ratpoison/Makefile
+++ b/x11-wm/ratpoison/Makefile
@@ -17,9 +17,9 @@ GNU_CONFIGURE= yes
OPTIONS_DEFINE= GDM_SUPPORT DOCS
GDM_SUPPORT_DESC= Install session data files for GDM
+INFO= ratpoison
SUB_FILES= ratpoison.desktop
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -29,17 +29,10 @@ post-patch:
PLIST_SUB+= WITH_GDM=""
post-install:
- ${MKDIR} ${PREFIX}/etc/dm/Sessions
- ${INSTALL_DATA} ${WRKDIR}/ratpoison.desktop ${PREFIX}/etc/dm/Sessions/
+ @${MKDIR} ${PREFIX}/etc/dm/Sessions
+ ${INSTALL_DATA} ${WRKDIR}/ratpoison.desktop ${STAGEDIR}${PREFIX}/etc/dm/Sessions
.else
PLIST_SUB+= WITH_GDM="@comment "
.endif
-.if ${PORT_OPTIONS:MDOCS}
-MAN1= ratpoison.1
-INFO= ratpoison
-.else
-INSTALL_TARGET= SUBDIRS=src install-exec
-.endif
-
.include <bsd.port.mk>
diff --git a/x11-wm/ratpoison/pkg-plist b/x11-wm/ratpoison/pkg-plist
index e1dea5260689..cba3d23c76a7 100644
--- a/x11-wm/ratpoison/pkg-plist
+++ b/x11-wm/ratpoison/pkg-plist
@@ -1,14 +1,15 @@
bin/ratpoison
-%%PORTDATA%%bin/rpws
-%%PORTDATA%%%%DATADIR%%/allwindows.sh
-%%PORTDATA%%%%DATADIR%%/clickframe.pl
-%%PORTDATA%%%%DATADIR%%/genrpbindings
-%%PORTDATA%%%%DATADIR%%/ratpoison.el
-%%PORTDATA%%%%DATADIR%%/rpshowall.sh
-%%PORTDATA%%%%DATADIR%%/rpws
-%%PORTDATA%%%%DATADIR%%/split.sh
-%%PORTDATA%%%%DATADIR%%/sloppy.c
-%%PORTDATA%%%%DATADIR%%/unrat.c
+bin/rpws
+man/man1/ratpoison.1.gz
+%%DATADIR%%/allwindows.sh
+%%DATADIR%%/clickframe.pl
+%%DATADIR%%/genrpbindings
+%%DATADIR%%/ratpoison.el
+%%DATADIR%%/rpshowall.sh
+%%DATADIR%%/rpws
+%%DATADIR%%/split.sh
+%%DATADIR%%/sloppy.c
+%%DATADIR%%/unrat.c
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
@@ -16,4 +17,4 @@ bin/ratpoison
%%PORTDOCS%%%%DOCSDIR%%/README
%%WITH_GDM%%etc/dm/Sessions/ratpoison.desktop
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDATA%%@dirrm %%DATADIR%%
+@dirrm %%DATADIR%%