aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-06-25 00:05:47 +0800
committeradamw <adamw@FreeBSD.org>2015-06-25 00:05:47 +0800
commitc11285da015cb09ffcc4b4a99ea7b11a51d4fe02 (patch)
tree84b0b0c0a2dc21a7f6268db859daa1442caf71b8
parent8204d31027973caed1aaa88b89ac941696b359c9 (diff)
downloadfreebsd-ports-gnome-c11285da015cb09ffcc4b4a99ea7b11a51d4fe02.tar.gz
freebsd-ports-gnome-c11285da015cb09ffcc4b4a99ea7b11a51d4fe02.tar.zst
freebsd-ports-gnome-c11285da015cb09ffcc4b4a99ea7b11a51d4fe02.zip
Switch p5-Test-Tester dependencies to p5-Test-Simple, but only on
perl < 5.22. Bump PORTREVISION where necessary.
-rw-r--r--devel/p5-Number-Tolerant/Makefile9
-rw-r--r--devel/p5-Test-Benchmark/Makefile11
-rw-r--r--devel/p5-Test-BinaryData/Makefile10
-rw-r--r--devel/p5-Test-Bits/Makefile11
-rw-r--r--devel/p5-Test-CleanNamespaces/Makefile9
-rw-r--r--devel/p5-Test-Deep/Makefile5
-rw-r--r--devel/p5-Test-Filename/Makefile10
-rw-r--r--devel/p5-Test-JSON/Makefile12
-rw-r--r--devel/p5-Test-NoWarnings/Makefile10
-rw-r--r--devel/p5-Test-Output/Makefile9
-rw-r--r--devel/p5-Test-Spelling/Makefile9
-rw-r--r--devel/p5-Test-Timer/Makefile11
-rw-r--r--devel/p5-Test-Trap/Makefile11
-rw-r--r--devel/p5-Test-Version/Makefile11
-rw-r--r--devel/p5-Test-WWW-Declare/Makefile9
-rw-r--r--devel/p5-Test-Warnings/Makefile11
-rw-r--r--devel/p5-Type-Tiny/Makefile9
17 files changed, 123 insertions, 44 deletions
diff --git a/devel/p5-Number-Tolerant/Makefile b/devel/p5-Number-Tolerant/Makefile
index f8138d4596d8..5b2ae4e98b2f 100644
--- a/devel/p5-Number-Tolerant/Makefile
+++ b/devel/p5-Number-Tolerant/Makefile
@@ -16,9 +16,14 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Sub-Exporter>=0.950:${PORTSDIR}/devel/p5-Sub-Exporter
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Benchmark/Makefile b/devel/p5-Test-Benchmark/Makefile
index 29764aef32f6..9965d99f555e 100644
--- a/devel/p5-Test-Benchmark/Makefile
+++ b/devel/p5-Test-Benchmark/Makefile
@@ -13,10 +13,15 @@ COMMENT= Make sure something really is faster
LICENSE= LGPL21
-TEST_DEPENDS= p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester \
- p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
+TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-BinaryData/Makefile b/devel/p5-Test-BinaryData/Makefile
index 7a55f09c5e9c..72b7a5c84d86 100644
--- a/devel/p5-Test-BinaryData/Makefile
+++ b/devel/p5-Test-BinaryData/Makefile
@@ -14,9 +14,13 @@ COMMENT= Compare two things, give hex dumps if they differ
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-TEST_DEPENDS= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
-
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Bits/Makefile b/devel/p5-Test-Bits/Makefile
index 03331bbbf35e..ca0d8782149c 100644
--- a/devel/p5-Test-Bits/Makefile
+++ b/devel/p5-Test-Bits/Makefile
@@ -15,10 +15,15 @@ LICENSE= ART20
BUILD_DEPENDS= p5-List-AllUtils>=0:${PORTSDIR}/devel/p5-List-AllUtils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
- p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester
+TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-CleanNamespaces/Makefile b/devel/p5-Test-CleanNamespaces/Makefile
index e2df32a806fc..f86c17296e26 100644
--- a/devel/p5-Test-CleanNamespaces/Makefile
+++ b/devel/p5-Test-CleanNamespaces/Makefile
@@ -23,7 +23,6 @@ BUILD_DEPENDS= p5-File-Find-Rule>0:${PORTSDIR}/devel/p5-File-Find-Rule \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
- p5-Test-Tester>0:${PORTSDIR}/devel/p5-Test-Tester \
p5-Test-Warnings>=0.009:${PORTSDIR}/devel/p5-Test-Warnings
USES= perl5
@@ -32,4 +31,10 @@ USE_PERL5= configure
PLIST_FILES= %%SITE_PERL%%/Test/CleanNamespaces.pm \
%%PERL5_MAN3%%/Test::CleanNamespaces.3.gz
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Deep/Makefile b/devel/p5-Test-Deep/Makefile
index 667f8e82a0e7..1ffd6eded383 100644
--- a/devel/p5-Test-Deep/Makefile
+++ b/devel/p5-Test-Deep/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Test-Deep
PORTVERSION= 0.117
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -27,8 +28,8 @@ post-patch:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 502200
-BUILD_DEPENDS+= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
-RUN_DEPENDS+= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
+BUILD_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Filename/Makefile b/devel/p5-Test-Filename/Makefile
index 4ea4ab5bd374..9b7930a43a5a 100644
--- a/devel/p5-Test-Filename/Makefile
+++ b/devel/p5-Test-Filename/Makefile
@@ -13,10 +13,14 @@ COMMENT= Perl extension for portable filename comparison
RUN_DEPENDS= \
p5-Path-Tiny>0:${PORTSDIR}/devel/p5-Path-Tiny
BUILD_DEPENDS= ${RUN_DEPENDS}
-TEST_DEPENDS= \
- p5-Test-Tester>0:${PORTSDIR}/devel/p5-Test-Tester
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-JSON/Makefile b/devel/p5-Test-JSON/Makefile
index 97f711b7ab3a..0513f62d2266 100644
--- a/devel/p5-Test-JSON/Makefile
+++ b/devel/p5-Test-JSON/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Test-JSON
PORTVERSION= 0.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,11 +13,17 @@ MAINTAINER= lth@FreeBSD.org
COMMENT= Test JSON data
RUN_DEPENDS= p5-Test-Differences>=0.47:${PORTSDIR}/devel/p5-Test-Differences \
- p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester \
p5-JSON-Any>=1.20:${PORTSDIR}/converters/p5-JSON-Any
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+BUILD_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-NoWarnings/Makefile b/devel/p5-Test-NoWarnings/Makefile
index 71479e7d3105..f931b665129f 100644
--- a/devel/p5-Test-NoWarnings/Makefile
+++ b/devel/p5-Test-NoWarnings/Makefile
@@ -13,8 +13,6 @@ COMMENT= Hide and store warnings while running test scripts
LICENSE= LGPL21
-TEST_DEPENDS= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
-
USES= perl5
USE_PERL5= configure
@@ -28,4 +26,10 @@ BUILD_DEPENDS+= p5-Devel-StackTrace>=0:${PORTSDIR}/devel/p5-Devel-StackTrace
RUN_DEPENDS+= p5-Devel-StackTrace>=0:${PORTSDIR}/devel/p5-Devel-StackTrace
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Output/Makefile b/devel/p5-Test-Output/Makefile
index 8e9504275781..a5e7502b264f 100644
--- a/devel/p5-Test-Output/Makefile
+++ b/devel/p5-Test-Output/Makefile
@@ -17,9 +17,14 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Capture-Tiny>=0.17:${PORTSDIR}/devel/p5-Capture-Tiny \
p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Spelling/Makefile b/devel/p5-Test-Spelling/Makefile
index bbe96ed81102..8ac9ed51ca82 100644
--- a/devel/p5-Test-Spelling/Makefile
+++ b/devel/p5-Test-Spelling/Makefile
@@ -18,9 +18,14 @@ BUILD_DEPENDS= p5-Pod-Spell>=0:${PORTSDIR}/textproc/p5-Pod-Spell \
p5-IPC-Run3>=0:${PORTSDIR}/devel/p5-IPC-Run3
RUN_DEPENDS= p5-Pod-Spell>=0:${PORTSDIR}/textproc/p5-Pod-Spell \
p5-IPC-Run3>=0:${PORTSDIR}/devel/p5-IPC-Run3
-TEST_DEPENDS= p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Timer/Makefile b/devel/p5-Test-Timer/Makefile
index b8f41194f1b3..efc8e6fa686b 100644
--- a/devel/p5-Test-Timer/Makefile
+++ b/devel/p5-Test-Timer/Makefile
@@ -12,11 +12,16 @@ MAINTAINER= swills@FreeBSD.org
COMMENT= Perl test module to test/assert response times
BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
- p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Trap/Makefile b/devel/p5-Test-Trap/Makefile
index c3fa50b16c7c..a3d17b32b927 100644
--- a/devel/p5-Test-Trap/Makefile
+++ b/devel/p5-Test-Trap/Makefile
@@ -16,10 +16,15 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Refcount>=0:${PORTSDIR}/devel/p5-Test-Refcount \
- p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
+TEST_DEPENDS= p5-Test-Refcount>=0:${PORTSDIR}/devel/p5-Test-Refcount
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Version/Makefile b/devel/p5-Test-Version/Makefile
index 7ae4f8e43c6e..4b91acde74ef 100644
--- a/devel/p5-Test-Version/Makefile
+++ b/devel/p5-Test-Version/Makefile
@@ -15,10 +15,15 @@ LICENSE= ART20
BUILD_DEPENDS= p5-File-Find-Rule-Perl>=0:${PORTSDIR}/devel/p5-File-Find-Rule-Perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
- p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-WWW-Declare/Makefile b/devel/p5-Test-WWW-Declare/Makefile
index 7bb5e9bb7851..9d85cdd15002 100644
--- a/devel/p5-Test-WWW-Declare/Makefile
+++ b/devel/p5-Test-WWW-Declare/Makefile
@@ -13,9 +13,14 @@ COMMENT= Declarative testing for your web app
BUILD_DEPENDS= p5-Test-WWW-Mechanize>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Warnings/Makefile b/devel/p5-Test-Warnings/Makefile
index bf79e295d162..f68d03ffb270 100644
--- a/devel/p5-Test-Warnings/Makefile
+++ b/devel/p5-Test-Warnings/Makefile
@@ -15,10 +15,15 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-CPAN-Meta-Check>=0.007:${PORTSDIR}/devel/p5-CPAN-Meta-Check \
p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny \
- p5-Test-Kwalitee>=1.12:${PORTSDIR}/devel/p5-Test-Kwalitee \
- p5-Test-Tester>=0.108:${PORTSDIR}/devel/p5-Test-Tester
+ p5-Test-Kwalitee>=1.12:${PORTSDIR}/devel/p5-Test-Kwalitee
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Type-Tiny/Makefile b/devel/p5-Type-Tiny/Makefile
index f49ddd6456ad..28ff2f6805e6 100644
--- a/devel/p5-Type-Tiny/Makefile
+++ b/devel/p5-Type-Tiny/Makefile
@@ -31,7 +31,6 @@ TEST_DEPENDS= p5-Class-InsideOut>=0:${PORTSDIR}/devel/p5-Class-InsideOut \
p5-Sub-Exporter-Lexical>=0:${PORTSDIR}/devel/p5-Sub-Exporter-Lexical \
p5-Test-LeakTrace>=0:${PORTSDIR}/devel/p5-Test-LeakTrace \
p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires \
- p5-Test-Tester>=0.10.9:${PORTSDIR}/devel/p5-Test-Tester \
p5-Test-Warnings>=0:${PORTSDIR}/devel/p5-Test-Warnings \
p5-Validation-Class>=0:${PORTSDIR}/devel/p5-Validation-Class \
p5-match-simple>=0:${PORTSDIR}/devel/p5-match-simple
@@ -48,4 +47,10 @@ USES= perl5
XS_BUILD_DEPENDS= p5-Type-Tiny-XS>=0.010:${PORTSDIR}/devel/p5-Type-Tiny-XS
XS_RUN_DEPENDS= p5-Type-Tiny-XS>=0.010:${PORTSDIR}/devel/p5-Type-Tiny-XS
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>