aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-09 20:41:57 +0800
committerpawel <pawel@FreeBSD.org>2014-04-09 20:41:57 +0800
commitc273739eab784ec03479a1e0e4f29b51250de935 (patch)
tree3c428dbedf0f072e93e6a859e40ea68736e60d78
parent947635f2c34239c207e03e36fe310dac0b1d09a3 (diff)
downloadfreebsd-ports-gnome-c273739eab784ec03479a1e0e4f29b51250de935.tar.gz
freebsd-ports-gnome-c273739eab784ec03479a1e0e4f29b51250de935.tar.zst
freebsd-ports-gnome-c273739eab784ec03479a1e0e4f29b51250de935.zip
- Add staging support
- Remove leading article from COMMENT
-rw-r--r--emulators/aftp/Makefile8
-rw-r--r--emulators/aftp/files/patch-aa4
2 files changed, 4 insertions, 8 deletions
diff --git a/emulators/aftp/Makefile b/emulators/aftp/Makefile
index 0366d7ba6d68..3116c19e1ba7 100644
--- a/emulators/aftp/Makefile
+++ b/emulators/aftp/Makefile
@@ -9,16 +9,14 @@ DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A ftp-like shell for accessing Apple II disk images
+COMMENT= Ftp-like shell for accessing Apple II disk images
-MAN1= aftp.1
-PLIST_FILES= bin/aftp
+PLIST_FILES= bin/aftp man/man1/aftp.1.gz
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|^CC=.*|CC=${CC} ${CPPFLAGS} ${CFLAGS}|' ${WRKSRC}/Makefile
post-install:
- ${INSTALL_MAN} ${FILESDIR}/aftp.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${FILESDIR}/aftp.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/emulators/aftp/files/patch-aa b/emulators/aftp/files/patch-aa
index e4baa2231072..74c0c99fd44a 100644
--- a/emulators/aftp/files/patch-aa
+++ b/emulators/aftp/files/patch-aa
@@ -20,8 +20,6 @@
! OBJS= aftp.o pro.o dos.o
! #CC_OPTS= -DDIRECTORY_COMMANDS
! CC= gcc ${CC_OPTS}
-! INSTALL= install -c
-! INSTALL_BIN= ${INSTALL} -s -o bin -g bin
! PREFIX?= /usr/local
!
! all: aftp
@@ -33,7 +31,7 @@
! ${CC} -c ${CFLAGS} $<
!
! install: all
-! ${INSTALL_BIN} aftp ${PREFIX}/bin/
+! ${BSD_INSTALL_PROGRAM} aftp ${DESTDIR}${PREFIX}/bin
clean:
rm -f $(OBJS) aftp